aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Chart-Math-Axis/Makefile26
-rw-r--r--math/p5-Chart-Math-Axis/distinfo1
-rw-r--r--math/p5-Chart-Math-Axis/pkg-descr13
-rw-r--r--math/p5-Chart-Math-Axis/pkg-plist7
5 files changed, 48 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 3a82e515977b..6689f4692a25 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -89,6 +89,7 @@
SUBDIR += p5-AI-Perceptron
SUBDIR += p5-Bit-ShiftReg
SUBDIR += p5-Bit-Vector
+ SUBDIR += p5-Chart-Math-Axis
SUBDIR += p5-Date-Handler
SUBDIR += p5-Graph
SUBDIR += p5-Math-Base85
diff --git a/math/p5-Chart-Math-Axis/Makefile b/math/p5-Chart-Math-Axis/Makefile
new file mode 100644
index 000000000000..ecf1a7a6eeb0
--- /dev/null
+++ b/math/p5-Chart-Math-Axis/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Chart-Math-Axis
+# Date created: 18 May 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chart-Math-Axis
+PORTVERSION= 0.1
+CATEGORIES= math graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Chart
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Implements an algorithm to find good values for chart axis
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt \
+ ${SITE_PERL}/Math/BigFloat.pm:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Chart::Math::Axis.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Chart-Math-Axis/distinfo b/math/p5-Chart-Math-Axis/distinfo
new file mode 100644
index 000000000000..3c2f9c7a5192
--- /dev/null
+++ b/math/p5-Chart-Math-Axis/distinfo
@@ -0,0 +1 @@
+MD5 (Chart-Math-Axis-0.1.tar.gz) = 10ca6a4d0792ed39ac55794f9df9eb04
diff --git a/math/p5-Chart-Math-Axis/pkg-descr b/math/p5-Chart-Math-Axis/pkg-descr
new file mode 100644
index 000000000000..120987cd8612
--- /dev/null
+++ b/math/p5-Chart-Math-Axis/pkg-descr
@@ -0,0 +1,13 @@
+Chart::Math::Axis implements in a generic way an algorithm for finding a
+set of ideal values for an axis. That is, for any given set of data,
+what should the top and bottom of the axis scale be, and what should the
+interval between the ticks be.
+
+The terms top and bottom are used throughout this module, as it's
+primary use is for determining the Y axis. For calculating the X axis,
+you should think of 'top' as 'right', and 'bottom' as 'left'.
+
+WWW: http://search.cpan.org/dist/Chart-Math-Axis/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/math/p5-Chart-Math-Axis/pkg-plist b/math/p5-Chart-Math-Axis/pkg-plist
new file mode 100644
index 000000000000..4f0111ce866f
--- /dev/null
+++ b/math/p5-Chart-Math-Axis/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart/Math/Axis/.packlist
+%%SITE_PERL%%/Chart/Math/Axis.pm
+@unexec rmdir %D/%%SITE_PERL%%/Chart/Math 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Chart 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart/Math/Axis
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart/Math 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart 2>/dev/null || true