aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/superswitcher/Makefile29
-rw-r--r--deskutils/superswitcher/distinfo3
-rw-r--r--deskutils/superswitcher/pkg-descr6
-rw-r--r--deskutils/superswitcher/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 07c364eb0e51..95d5f51afd7b 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -136,6 +136,7 @@
SUBDIR += sugarcrm
SUBDIR += sunbird
SUBDIR += superkaramba
+ SUBDIR += superswitcher
SUBDIR += taskjuggler
SUBDIR += teapot
SUBDIR += timer-applet
diff --git a/deskutils/superswitcher/Makefile b/deskutils/superswitcher/Makefile
new file mode 100644
index 000000000000..8be5fadf344f
--- /dev/null
+++ b/deskutils/superswitcher/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: superswitcher
+# Date Created: 02 Jan 2006
+# Whom: Remington Lang <MrL0Lz@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= superswitcher
+PORTVERSION= 0.1
+CATEGORIES= deskutils gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= browserbookapp
+
+MAINTAINER= MrL0Lz@gmail.com
+COMMENT= Alt-Tab replacement
+
+BUILD_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnomecommon
+RUN_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnomecommon
+
+USE_GMAKE= yes
+USE_GNOME= gtk20 libwnck pango
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/x11//g' ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/superswitcher ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/deskutils/superswitcher/distinfo b/deskutils/superswitcher/distinfo
new file mode 100644
index 000000000000..0e25a3c3124b
--- /dev/null
+++ b/deskutils/superswitcher/distinfo
@@ -0,0 +1,3 @@
+MD5 (superswitcher-0.1.tar.gz) = 75bbaaddbca5928c801a70c436fe9691
+SHA256 (superswitcher-0.1.tar.gz) = af2e1df434d976373c9c924b5ec2f4cd0809befea80f64e7f61c68af3824b685
+SIZE (superswitcher-0.1.tar.gz) = 218807
diff --git a/deskutils/superswitcher/pkg-descr b/deskutils/superswitcher/pkg-descr
new file mode 100644
index 000000000000..931cfe71aec5
--- /dev/null
+++ b/deskutils/superswitcher/pkg-descr
@@ -0,0 +1,6 @@
+A more feature-full replacement of thr Alt-Tab window switching behavior.
+
+Superswitcher uses the "Super" key, also known as the Windows key to switch
+between windows and workspaces.
+
+WWW: http://www.gnomefiles.com/app.php?soft_id=1231
diff --git a/deskutils/superswitcher/pkg-plist b/deskutils/superswitcher/pkg-plist
new file mode 100644
index 000000000000..ee9126a25031
--- /dev/null
+++ b/deskutils/superswitcher/pkg-plist
@@ -0,0 +1 @@
+bin/superswitcher