aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/rtc/Makefile2
-rw-r--r--emulators/rtc/files/rtc.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/emulators/rtc/Makefile b/emulators/rtc/Makefile
index e69104f14505..3bc1152f0c46 100644
--- a/emulators/rtc/Makefile
+++ b/emulators/rtc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rtc
PORTVERSION= 2004.02.24.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= emulators linux
MASTER_SITES= # none
DISTFILES= # none
diff --git a/emulators/rtc/files/rtc.c b/emulators/rtc/files/rtc.c
index 16f573caaf0f..c038575e4d18 100644
--- a/emulators/rtc/files/rtc.c
+++ b/emulators/rtc/files/rtc.c
@@ -269,8 +269,8 @@ rtc_ioctl(dev_t dev, u_long cmd, caddr_t arg, int mode, struct proc *p)
}
sc->var.freq = freq;
if ((sc->var.freq > hz) && (hz < 1000)) {
- sc->var.freq = hz;
printf("rtc: %d > kern.hz: Timing will be inaccurate, please increase kern.hz.\n", sc->var.freq);
+ sc->var.freq = hz;
}
sleep = hz / sc->var.freq;
DLog(Linfo, "Set RTC freq %d", sc->var.freq);