aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-DOM-Lite/Makefile30
-rw-r--r--textproc/p5-XML-DOM-Lite/distinfo3
-rw-r--r--textproc/p5-XML-DOM-Lite/pkg-descr16
-rw-r--r--textproc/p5-XML-DOM-Lite/pkg-plist18
5 files changed, 68 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index cd39747083e3..e0e5f5637bdd 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -559,6 +559,7 @@
SUBDIR += p5-XML-Clean
SUBDIR += p5-XML-DBMS
SUBDIR += p5-XML-DOM
+ SUBDIR += p5-XML-DOM-Lite
SUBDIR += p5-XML-DOM-XPath
SUBDIR += p5-XML-DOM2
SUBDIR += p5-XML-DT
diff --git a/textproc/p5-XML-DOM-Lite/Makefile b/textproc/p5-XML-DOM-Lite/Makefile
new file mode 100644
index 000000000000..a9be6c8a4d5c
--- /dev/null
+++ b/textproc/p5-XML-DOM-Lite/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-XML-DOM-Lite
+# Date created: 2006-08-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-DOM-Lite
+PORTVERSION= 0.11
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Lite Pure Perl XML DOM Parser Kit
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::DOM::Lite.3 XML::DOM::Lite::Document.3 \
+ XML::DOM::Lite::NodeList.3 XML::DOM::Lite::Parser.3 \
+ XML::DOM::Lite::XPath.3 XML::DOM::Lite::XSLT.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500803
+IGNORE= requires Perl 5.8.3 or newer. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-DOM-Lite/distinfo b/textproc/p5-XML-DOM-Lite/distinfo
new file mode 100644
index 000000000000..e60a810266e9
--- /dev/null
+++ b/textproc/p5-XML-DOM-Lite/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-DOM-Lite-0.11.tar.gz) = 87ee8f6aea8c821536ad23792e730cc1
+SHA256 (XML-DOM-Lite-0.11.tar.gz) = 11ea5a62e560e4640f6024404e2e1a6c9bb912e5c76b3051a556736837cb8259
+SIZE (XML-DOM-Lite-0.11.tar.gz) = 31550
diff --git a/textproc/p5-XML-DOM-Lite/pkg-descr b/textproc/p5-XML-DOM-Lite/pkg-descr
new file mode 100644
index 000000000000..c331553be6c7
--- /dev/null
+++ b/textproc/p5-XML-DOM-Lite/pkg-descr
@@ -0,0 +1,16 @@
+XML::DOM::Lite is designed to be a reasonably fast, highly portable,
+XML parser kit written in pure perl, implementing the DOM standard
+quite closely. To keep performance up and footprint down.
+
+The standard pattern for using the XML::DOM::Lite parser kit is to use
+XML::DOM::Lite qw(Parser :constants);
+
+Available exports are : Parser, Node, NodeList, NodeIterator,
+NodeFilter, XPath, Document, XSLT and the constants.
+
+This is mostly for convenience, so that you can save your key-strokes
+for the fun stuff. Alternatively, to avoid polluting your namespace,
+you can simply : use XML::DOM::Lite::Parser; use
+XML::DOM::Lite::Constants qw(:all); # ... etc
+
+WWW: http://search.cpan.org/dist/XML-DOM-Lite/
diff --git a/textproc/p5-XML-DOM-Lite/pkg-plist b/textproc/p5-XML-DOM-Lite/pkg-plist
new file mode 100644
index 000000000000..75cc40248681
--- /dev/null
+++ b/textproc/p5-XML-DOM-Lite/pkg-plist
@@ -0,0 +1,18 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/DOM/Lite/.packlist
+%%SITE_PERL%%/XML/DOM/Lite.pm
+%%SITE_PERL%%/XML/DOM/Lite/Parser.pm
+%%SITE_PERL%%/XML/DOM/Lite/XSLT.pm
+%%SITE_PERL%%/XML/DOM/Lite/NodeList.pm
+%%SITE_PERL%%/XML/DOM/Lite/NodeIterator.pm
+%%SITE_PERL%%/XML/DOM/Lite/XPath.pm
+%%SITE_PERL%%/XML/DOM/Lite/Serializer.pm
+%%SITE_PERL%%/XML/DOM/Lite/Node.pm
+%%SITE_PERL%%/XML/DOM/Lite/Constants.pm
+%%SITE_PERL%%/XML/DOM/Lite/Document.pm
+@dirrmtry %%SITE_PERL%%/XML/DOM/Lite
+@dirrmtry %%SITE_PERL%%/XML/DOM
+@dirrmtry %%SITE_PERL%%/XML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/DOM/Lite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/DOM
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML