aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/hilite/Makefile34
-rw-r--r--sysutils/hilite/distinfo2
-rw-r--r--sysutils/hilite/pkg-descr7
-rw-r--r--sysutils/hilite/pkg-message10
5 files changed, 54 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 6aab21372ba4..28cf4b91879d 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -216,6 +216,7 @@
SUBDIR += heartbeat
SUBDIR += heirloom
SUBDIR += highlnk
+ SUBDIR += hilite
SUBDIR += hourglass
SUBDIR += hoz
SUBDIR += httplog
diff --git a/sysutils/hilite/Makefile b/sysutils/hilite/Makefile
new file mode 100644
index 000000000000..d4ba5b1a008d
--- /dev/null
+++ b/sysutils/hilite/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: hilite
+# Date created: 21 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hilite
+PORTVERSION= 1.5
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .c
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command-line utility to highlight anything printed to stderr
+
+PLIST_FILES= bin/hilite
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/hilite/distinfo b/sysutils/hilite/distinfo
new file mode 100644
index 000000000000..67ad766f3dd8
--- /dev/null
+++ b/sysutils/hilite/distinfo
@@ -0,0 +1,2 @@
+MD5 (hilite.c) = 0214a3ef553cf4cf1e41f9c3bf93ca83
+SIZE (hilite.c) = 2872
diff --git a/sysutils/hilite/pkg-descr b/sysutils/hilite/pkg-descr
new file mode 100644
index 000000000000..0260d340efa2
--- /dev/null
+++ b/sysutils/hilite/pkg-descr
@@ -0,0 +1,7 @@
+hilite is a tiny command-line utility which executes the command you specify,
+highlighting anything printed to stderr.
+
+It is designed mainly for use with builds, to make warnings and errors stick
+out like a sore cliche.
+
+WWW: http://sourceforge.net/projects/hilite
diff --git a/sysutils/hilite/pkg-message b/sysutils/hilite/pkg-message
new file mode 100644
index 000000000000..aa01f53f0d7c
--- /dev/null
+++ b/sysutils/hilite/pkg-message
@@ -0,0 +1,10 @@
+===============================================================================
+You might want to put something like
+
+.if defined(HILITE)
+CC= hilite cc
+CXX= hilite c++
+.endif
+
+in your /etc/make.conf
+===============================================================================