aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/afbinit/Makefile4
-rw-r--r--sysutils/afbinit/distinfo6
-rw-r--r--sysutils/afbinit/files/patch-afbinit.c41
3 files changed, 12 insertions, 39 deletions
diff --git a/sysutils/afbinit/Makefile b/sysutils/afbinit/Makefile
index c5e6ffbbce60..ae26ae704dcb 100644
--- a/sysutils/afbinit/Makefile
+++ b/sysutils/afbinit/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
PATCH_SITES= ${MASTER_SITES}
PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
-PATCHFILES= ${PORTNAME}_${PORTVERSION}-1.diff.gz
+PATCHFILES= ${PORTNAME}_${PORTVERSION}-4.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= marius@FreeBSD.org
@@ -32,7 +32,7 @@ post-patch:
.for i in afbinit.c debian/afbinit.8
@${REINPLACE_CMD} -E -e 's|\/usr\/lib|${DATADIR}|g; \
s|(\/dev\/fb\[)[0-3]+(\])|\10-7\2|g; \
- s|\/etc\/init.d\/afb|${PREFIX}/etc/rc.d/afbinit\{,.sh\}|g' \
+ s|\/etc\/init.d\/afbinit|${PREFIX}/etc/rc.d/afbinit\{,.sh\}|g' \
${WRKSRC}/${i}
.endfor
@${SED} 's|%%DATADIR%%|${DATADIR}|g' ${PKGDIR}/pkg-message > \
diff --git a/sysutils/afbinit/distinfo b/sysutils/afbinit/distinfo
index 6bf52ac8d28e..7395701b7fdf 100644
--- a/sysutils/afbinit/distinfo
+++ b/sysutils/afbinit/distinfo
@@ -1,6 +1,6 @@
MD5 (afbinit_1.0.orig.tar.gz) = c126b3ebb72e5028fd5d35fb6128316f
SHA256 (afbinit_1.0.orig.tar.gz) = cc0e316ed911955042186f5e1ccc43f9413fa369e4ddb8de8aaad293ad56a206
SIZE (afbinit_1.0.orig.tar.gz) = 2979
-MD5 (afbinit_1.0-1.diff.gz) = 499e2ad6922e377b8f05d661d332d0de
-SHA256 (afbinit_1.0-1.diff.gz) = 5a1372da16caeccd351d1df3d15b894c5773e6c80c13567828fe53ee48eb773e
-SIZE (afbinit_1.0-1.diff.gz) = 2712
+MD5 (afbinit_1.0-4.diff.gz) = 894ee8cf4afa258aa879be7ebe90edf9
+SHA256 (afbinit_1.0-4.diff.gz) = ca6a321f6e85dd63ac0b12c88468e8104f22014f0533ff416a9215d8f200c971
+SIZE (afbinit_1.0-4.diff.gz) = 3815
diff --git a/sysutils/afbinit/files/patch-afbinit.c b/sysutils/afbinit/files/patch-afbinit.c
index f659aa893ce3..ca8ddc2d6731 100644
--- a/sysutils/afbinit/files/patch-afbinit.c
+++ b/sysutils/afbinit/files/patch-afbinit.c
@@ -24,17 +24,7 @@
--- afbinit.c.orig Fri Nov 30 03:04:21 2001
+++ afbinit.c Mon Sep 15 17:33:19 2003
-@@ -12,7 +12,9 @@
- #include <sys/mman.h>
- #include <unistd.h>
- #include <fcntl.h>
-+#include <stdlib.h>
- #include <stdio.h>
-+#include <string.h>
-
- /* Define this to debug the microcode loading procedure. */
- #undef DEBUG_UCODE_LOAD
-@@ -184,7 +186,7 @@
+@@ -186,7 +186,7 @@
static void usage(char *me)
{
@@ -43,7 +33,7 @@
exit(1);
}
-@@ -193,13 +195,14 @@
+@@ -195,13 +195,14 @@
struct afb_ucode_header {
char ident[8];
unsigned int ucode_words;
@@ -59,7 +49,7 @@
if(argc != 2 && argc != 3)
usage(argp[0]);
-@@ -222,7 +225,7 @@
+@@ -224,7 +225,7 @@
perror("Read UCODE header");
exit(1);
}
@@ -68,25 +58,7 @@
if(ucode == NULL) {
fprintf(stderr, "Cannot malloc %d bytes for UCODE.\n",
ucheader.ucode_words << 2);
-@@ -236,7 +239,7 @@
- /* MMAP the registers. */
- uregs = mmap(0, 0x2000,
- PROT_READ | PROT_WRITE,
-- MAP_PRIVATE,
-+ MAP_SHARED,
- afb_fd,
- 0x04000000);
- if (uregs == (void *)-1L) {
-@@ -246,7 +249,7 @@
-
- kregs = mmap(0, 0x2000,
- PROT_READ | PROT_WRITE,
-- MAP_PRIVATE,
-+ MAP_SHARED,
- afb_fd,
- 0x0bc04000);
- if (kregs == (void *)-1L) {
-@@ -254,14 +257,26 @@
+@@ -256,15 +257,27 @@
exit(1);
}
@@ -112,8 +84,9 @@
(ucode_version >> 16) & 0xff,
(ucode_version >> 8) & 0xff,
(ucode_version >> 0) & 0xff);
--
-- afb_ucode_upload((char *)ucode, ucheader.ucode_words / 16, uregs, kregs);
+- afb_ucode_upload((char *)ucode, ucheader.ucode_words / 16, uregs, kregs);
+-
munmap(kregs, 0x2000);
munmap(uregs, 0x2000);
+