aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/cpu-x/Makefile38
-rw-r--r--sysutils/cpu-x/distinfo3
-rw-r--r--sysutils/cpu-x/files/patch-src_CMakeLists.txt17
-rw-r--r--sysutils/cpu-x/pkg-descr7
-rw-r--r--sysutils/cpu-x/pkg-plist36
6 files changed, 102 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 4f79fedaab74..247c38b7cd99 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -182,6 +182,7 @@
SUBDIR += cotty
SUBDIR += cpdup
SUBDIR += cpu
+ SUBDIR += cpu-x
SUBDIR += cpuburn
SUBDIR += cpuid
SUBDIR += cpulimit
diff --git a/sysutils/cpu-x/Makefile b/sysutils/cpu-x/Makefile
new file mode 100644
index 000000000000..f45a85adafb2
--- /dev/null
+++ b/sysutils/cpu-x/Makefile
@@ -0,0 +1,38 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cpu-x
+PORTVERSION= 3.1.3
+DISTVERSIONPREFIX= v
+CATEGORIES= sysutils
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Gathers information about CPU, motherboard, and more
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= nasm:devel/nasm
+LIB_DEPENDS= libcpuid.so:sysutils/libcpuid \
+ libpci.so:devel/libpci \
+ libstatgrab.so:devel/libstatgrab
+
+USE_GITHUB= yes
+GH_ACCOUNT= X0rg
+GH_PROJECT= ${PORTNAME:tu}
+
+USES= cmake execinfo gettext-tools ncurses pkgconfig
+USE_GNOME= gtk30
+INSTALLS_ICONS= yes
+
+PORTDOCS= ChangeLog README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's, -Wno-unused-result,,' ${WRKSRC}/CMakeLists.txt
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/cpu-x/distinfo b/sysutils/cpu-x/distinfo
new file mode 100644
index 000000000000..3f6c9164c93e
--- /dev/null
+++ b/sysutils/cpu-x/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1477420923
+SHA256 (X0rg-CPU-X-v3.1.3_GH0.tar.gz) = 078de38052daf64c93ec02ced78b3b498e6e88746971518a8c27a1d04c347eda
+SIZE (X0rg-CPU-X-v3.1.3_GH0.tar.gz) = 1813830
diff --git a/sysutils/cpu-x/files/patch-src_CMakeLists.txt b/sysutils/cpu-x/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..e185cb9ad2b6
--- /dev/null
+++ b/sysutils/cpu-x/files/patch-src_CMakeLists.txt
@@ -0,0 +1,17 @@
+--- src/CMakeLists.txt.orig 2016-10-25 18:42:03 UTC
++++ src/CMakeLists.txt
+@@ -37,7 +37,13 @@ endif(WITH_GTK)
+
+ # NCurses
+ if(WITH_NCURSES)
+- pkg_check_modules(NCURSES ncurses)
++ # Assume ncurses from the base on FreeBSD
++ if(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
++ set(NCURSES_FOUND 1)
++ set(NCURSES_LIBRARIES "-l:libncursesw.so")
++ else()
++ pkg_check_modules(NCURSES ncurses)
++ endif()
+ if(NCURSES_FOUND)
+ include_directories(${NCURSES_INCLUDE_DIRS})
+ link_directories(${NCURSES_LIBRARY_DIRS})
diff --git a/sysutils/cpu-x/pkg-descr b/sysutils/cpu-x/pkg-descr
new file mode 100644
index 000000000000..0d2d192c96b7
--- /dev/null
+++ b/sysutils/cpu-x/pkg-descr
@@ -0,0 +1,7 @@
+CPU-X is a free software that gathers information about CPU, motherboard, and
+more on one's system. It is similar to well-known CPU-Z program for Windows.
+
+It can be used in graphic mode by using GTK+3, or in text-based mode by using
+ncurses. Non-interactive dump mode is also available.
+
+WWW: http://x0rg.github.io/CPU-X/
diff --git a/sysutils/cpu-x/pkg-plist b/sysutils/cpu-x/pkg-plist
new file mode 100644
index 000000000000..41b614a96dcb
--- /dev/null
+++ b/sysutils/cpu-x/pkg-plist
@@ -0,0 +1,36 @@
+bin/cpu-x
+bin/cpu-x_polkit
+share/applications/cpu-x.desktop
+share/applications/cpu-x-root.desktop
+share/icons/hicolor/16x16/apps/cpu-x.png
+share/icons/hicolor/22x22/apps/cpu-x.png
+share/icons/hicolor/24x24/apps/cpu-x.png
+share/icons/hicolor/32x32/apps/cpu-x.png
+share/icons/hicolor/36x36/apps/cpu-x.png
+share/icons/hicolor/48x48/apps/cpu-x.png
+share/icons/hicolor/64x64/apps/cpu-x.png
+share/icons/hicolor/72x72/apps/cpu-x.png
+share/icons/hicolor/96x96/apps/cpu-x.png
+share/icons/hicolor/128x128/apps/cpu-x.png
+share/icons/hicolor/192x192/apps/cpu-x.png
+share/icons/hicolor/256x256/apps/cpu-x.png
+share/icons/hicolor/384x384/apps/cpu-x.png
+share/icons/hicolor/512x512/apps/cpu-x.png
+share/locale/fr/LC_MESSAGES/cpu-x.mo
+share/locale/pt_BR/LC_MESSAGES/cpu-x.mo
+share/polkit-1/actions/org.pkexec.cpu-x.policy
+%%DATADIR%%/AMD.png
+%%DATADIR%%/CPU-X.png
+%%DATADIR%%/Centaur.png
+%%DATADIR%%/Cyrix.png
+%%DATADIR%%/Intel.png
+%%DATADIR%%/NSC.png
+%%DATADIR%%/NexGen.png
+%%DATADIR%%/Rise.png
+%%DATADIR%%/SiS.png
+%%DATADIR%%/Transmeta.png
+%%DATADIR%%/UMC.png
+%%DATADIR%%/Unknown.png
+%%DATADIR%%/cpu-x-gtk-3.12.css
+%%DATADIR%%/cpu-x-gtk-3.12.ui
+%%DATADIR%%/cpu-x-gtk-3.20.css