aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/gmastermind/Makefile26
-rw-r--r--games/gmastermind/distinfo3
-rw-r--r--games/gmastermind/pkg-descr11
-rw-r--r--games/gmastermind/pkg-plist10
5 files changed, 51 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 8723e41a4e81..65d4db915b30 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -254,6 +254,7 @@
SUBDIR += glpuzzle
SUBDIR += gltron
SUBDIR += gma
+ SUBDIR += gmastermind
SUBDIR += gnarr
SUBDIR += gnmm
SUBDIR += gno3dtet
diff --git a/games/gmastermind/Makefile b/games/gmastermind/Makefile
new file mode 100644
index 000000000000..c7ca1355c8c9
--- /dev/null
+++ b/games/gmastermind/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gmastermind
+# Date created: 28 Oct 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmastermind
+PORTVERSION= 0.2
+CATEGORIES= games
+MASTER_SITES= http://www.gnustep.it/marko/GMastermind/
+DISTNAME= GMastermind2
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= The well-known mastermind game
+
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE=
+
+.include <bsd.port.mk>
diff --git a/games/gmastermind/distinfo b/games/gmastermind/distinfo
new file mode 100644
index 000000000000..f85647c485d8
--- /dev/null
+++ b/games/gmastermind/distinfo
@@ -0,0 +1,3 @@
+MD5 (GMastermind2.tgz) = fc1a2f60eef59de870d629db3578d8c1
+SHA256 (GMastermind2.tgz) = 0b3275a50f3e1864f5d2b1a42902a7456dac2f71e8cfbcda6dcb852f7836b752
+SIZE (GMastermind2.tgz) = 17484
diff --git a/games/gmastermind/pkg-descr b/games/gmastermind/pkg-descr
new file mode 100644
index 000000000000..912134a63ef8
--- /dev/null
+++ b/games/gmastermind/pkg-descr
@@ -0,0 +1,11 @@
+The well-known mastermind game.
+Drag-and-drop colors from the palette or from the board itself. The
+object is to determine the hidden combination of four colors. The game
+may be played in two modes: with replacement, which means that colors
+may repeat, and without replacement, which means that colors are
+unique. The user selects a choice of four colors and "commits" them.
+The program replies with an evaluation -- a black peg for a color that
+is placed correctly, and a white peg for a color that is in the wrong
+position. The user may make a total of eight queries.
+
+WWW: http://www.gnustep.it/marko/GMastermind/
diff --git a/games/gmastermind/pkg-plist b/games/gmastermind/pkg-plist
new file mode 100644
index 000000000000..6f4b956121d7
--- /dev/null
+++ b/games/gmastermind/pkg-plist
@@ -0,0 +1,10 @@
+Local/Applications/GMastermind2.app/GMastermind2
+Local/Applications/GMastermind2.app/Resources/French.lproj/Localizable.strings
+Local/Applications/GMastermind2.app/Resources/GMastermind2.desktop
+Local/Applications/GMastermind2.app/Resources/GMastermind2.tiff
+Local/Applications/GMastermind2.app/Resources/Info-gnustep.plist
+Local/Applications/GMastermind2.app/library_paths.openapp
+Local/Applications/GMastermind2.app/stamp.make
+@dirrm Local/Applications/GMastermind2.app/Resources/French.lproj
+@dirrm Local/Applications/GMastermind2.app/Resources
+@dirrm Local/Applications/GMastermind2.app