aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/guis/Makefile40
-rw-r--r--x11-toolkits/guis/distinfo2
-rw-r--r--x11-toolkits/guis/pkg-descr7
4 files changed, 50 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 4162da4ca3c2..59a43e925e6f 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -84,6 +84,7 @@
SUBDIR += gtoolkit
SUBDIR += guile-gnome
SUBDIR += guile-gtk
+ SUBDIR += guis
SUBDIR += hs-frantk
SUBDIR += hs-gio
SUBDIR += hs-gtk+hs
diff --git a/x11-toolkits/guis/Makefile b/x11-toolkits/guis/Makefile
new file mode 100644
index 000000000000..5cd2d543a451
--- /dev/null
+++ b/x11-toolkits/guis/Makefile
@@ -0,0 +1,40 @@
+# ex:ts=8
+# Ports collection makefile for: guis
+# Date created: Apr 13, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= guis
+PORTVERSION= 1.4
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://www.starynkevitch.net/Basile/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A GUI widget server
+
+USE_PYTHON= 2.3
+USE_RUBY= yes
+USE_GNOME= pkgconfig gtk20 pango libglade2 pygtk2
+USE_GMAKE= yes
+MAKEFILE= Makefile_guis
+MAKE_ENV= PYTHONCFLAGS="-I${LOCALBASE}/include/python${USE_PYTHON}" \
+ PYTHONLDFLAGS="-L${LOCALBASE}/lib -lpython${USE_PYTHON}" \
+ RUBY="ruby18"
+ALL_TARGET= prog
+
+PLIST_FILES= bin/pyguis bin/ruguis bin/pyguis-scripter bin/ruguis-scripter
+MAN1= pyguis.1
+MLINKS= pyguis.1 ruguis.1 \
+ pyguis.1 pyguis-scripter.1 \
+ pyguis.1 ruguis-scripter.1
+
+do-install:
+.for lang in py ru
+ ${INSTALL_PROGRAM} ${WRKSRC}/${lang}guis ${PREFIX}/bin
+ ${LN} -fs ${PREFIX}/bin/${lang}guis ${PREFIX}/bin/${lang}guis-scripter
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/pyguis.man ${MAN1PREFIX}/man/man1/pyguis.1
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/guis/distinfo b/x11-toolkits/guis/distinfo
new file mode 100644
index 000000000000..31dadb4f6516
--- /dev/null
+++ b/x11-toolkits/guis/distinfo
@@ -0,0 +1,2 @@
+MD5 (guis-1.4.tar.gz) = 5b5e5666a0b878adb170c626b44b5f87
+SIZE (guis-1.4.tar.gz) = 518832
diff --git a/x11-toolkits/guis/pkg-descr b/x11-toolkits/guis/pkg-descr
new file mode 100644
index 000000000000..17f5ff1f47c0
--- /dev/null
+++ b/x11-toolkits/guis/pkg-descr
@@ -0,0 +1,7 @@
+Guis is a small widget server. It is a gtk2 based program listening on a pipe
+for widget requests (requests are Python [or Ruby] scripts) and outputting
+events or replies Guis is useful for programs (in particular, setuid programs
+or (ruby,ocaml,perl...) scripts) which do not want to link in a full widget
+toolkit but prefer to delegate the user interface to another process.
+
+WWW: http://www.starynkevitch.net/Basile/guisdoc.html