aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES6
-rw-r--r--Mk/bsd.options.mk6
2 files changed, 12 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 9ad17a5f4a5d..a8009a509215 100644
--- a/CHANGES
+++ b/CHANGES
@@ -41,6 +41,12 @@ AUTHOR: bapt@FreeBSD.org
${OPT}_DISTFILES will append the specified distiles to DISTFILES if OPT in 'on'
+ ${OPT}_CMAKE_ON=<something> will automatically add:
+ CMAKE_ARGS+=<something> in case OPT is activated
+
+ ${OPT_CMAKE_OFF=<something> will automatically add:
+ CMAKE_ARGS+=<something> in case OPT is deactivated
+
20130614:
AUTHOR: bapt@FreeBSD.org
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 8f6d3666a8d1..562e0fe9392e 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -309,6 +309,9 @@ CONFIGURE_ARGS+= --enable-${${opt}_CONFIGURE_ENABLE}
. if defined(${opt}_CONFIGURE_ON)
CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ON}
. endif
+. if defined(${opt}_CMAKE_ON)
+CMAKE_ARGS+= ${${opt}_CMAKE_ON}
+. endif
. for flags in CFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ENV USES DISTFILES
. if defined(${opt}_${flags})
${flags}+= ${${opt}_${flags}}
@@ -326,6 +329,9 @@ CONFIGURE_ARGS+= --disable-${${opt}_CONFIGURE_ENABLE}
. if defined(${opt}_CONFIGURE_OFF)
CONFIGURE_ARGS+= ${${opt}_CONFIGURE_OFF}
. endif
+. if defined(${opt}_CMAKE_OFF)
+CMAKE_ARGS+= ${${opt}_CMAKE_OFF}
+. endif
. endif
.endfor