aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/geist/Makefile26
-rw-r--r--graphics/geist/distinfo1
-rw-r--r--graphics/geist/files/patch-aa40
-rw-r--r--graphics/geist/files/patch-ab11
-rw-r--r--graphics/geist/pkg-comment1
-rw-r--r--graphics/geist/pkg-descr3
-rw-r--r--graphics/geist/pkg-plist27
8 files changed, 110 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 89707fb972db..a6a9d7ee6444 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -44,6 +44,7 @@
SUBDIR += gd
SUBDIR += gdk-pixbuf
SUBDIR += gdtclft
+ SUBDIR += geist
SUBDIR += geomview
SUBDIR += gfont
SUBDIR += gif2png
diff --git a/graphics/geist/Makefile b/graphics/geist/Makefile
new file mode 100644
index 000000000000..c005acbef2fe
--- /dev/null
+++ b/graphics/geist/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: geist
+# Date created: 24 Oct 2000
+# Whom: Jeremy Norris <ishmael27@home.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= geist
+PORTVERSION= 0.0.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.linuxbrit.co.uk/downloads/
+
+MAINTAINER= ishmael27@home.com
+
+LIB_DEPENDS= Imlib2.1:${PORTSDIR}/graphics/imlib2-tmp \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
+XML_CONFIG?= ${LOCALBASE}/bin/xml2-config
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+USE_GTK= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LIBS="-L${X11BASE}/lib" \
+ XML_CONFIG="${XML_CONFIG}"
+
+.include <bsd.port.mk>
diff --git a/graphics/geist/distinfo b/graphics/geist/distinfo
new file mode 100644
index 000000000000..ccfbd392c906
--- /dev/null
+++ b/graphics/geist/distinfo
@@ -0,0 +1 @@
+MD5 (geist-0.0.3.tar.gz) = 16cc0769138481e9ca3c049d6e2b4d79
diff --git a/graphics/geist/files/patch-aa b/graphics/geist/files/patch-aa
new file mode 100644
index 000000000000..6a99676d9ff7
--- /dev/null
+++ b/graphics/geist/files/patch-aa
@@ -0,0 +1,40 @@
+--- Makefile.in.orig Thu Oct 26 21:29:01 2000
++++ Makefile.in Thu Oct 26 22:25:07 2000
+@@ -71,10 +71,10 @@
+ XML_CFLAGS = @XML_CFLAGS@
+ XML_LIBS = @XML_LIBS@
+
+-SUBDIRS = pixmaps src
++SUBDIRS = src
+
+ docs_DATA = README AUTHORS ChangeLog TODO
+-docsdir = $(prefix)/doc/geist
++docsdir = $(datadir)/doc/geist
+
+ EXTRA_DIST = geist.spec $(docs_DATA)
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+@@ -384,15 +384,15 @@
+
+
+ install-data-local:
+- @$(NORMAL_INSTALL)
+- if test -d $(srcdir)/pixmaps; then \
+- $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/pixmaps; \
+- for pixmap in $(srcdir)/pixmaps/*; do \
+- if test -f $$pixmap; then \
+- $(INSTALL_DATA) $$pixmap $(DESTDIR)$(pkgdatadir)/pixmaps; \
+- fi \
+- done \
+- fi
++# @$(NORMAL_INSTALL)
++# if test -d $(srcdir)/pixmaps; then \
++# $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/pixmaps; \
++# for pixmap in $(srcdir)/pixmaps/*; do \
++# if test -f $$pixmap; then \
++# $(INSTALL_DATA) $$pixmap $(DESTDIR)$(pkgdatadir)/pixmaps; \
++# fi \
++# done \
++# fi
+
+ dist-hook:
+ if test -d pixmaps; then \
diff --git a/graphics/geist/files/patch-ab b/graphics/geist/files/patch-ab
new file mode 100644
index 000000000000..bad9775994aa
--- /dev/null
+++ b/graphics/geist/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/testimages/Makefile.in.orig Thu Oct 26 21:29:04 2000
++++ src/testimages/Makefile.in Thu Oct 26 22:38:54 2000
+@@ -76,7 +76,7 @@
+ # A list of all the files in the current directory which can be regenerated
+ MAINTAINERCLEANFILES = Makefile.in
+
+-testimages_DATA = bg.png bulb.png elogo.png globe.png mail.png mush.png paper.png laet.jpg
++testimages_DATA = bg.png bulb.png elogo.png globe.png mail.png mush.png paper.png
+
+
+ testimagesdir = $(prefix)/share/geist/images
diff --git a/graphics/geist/pkg-comment b/graphics/geist/pkg-comment
new file mode 100644
index 000000000000..0bc9119aca79
--- /dev/null
+++ b/graphics/geist/pkg-comment
@@ -0,0 +1 @@
+An object-based image creation/layout application
diff --git a/graphics/geist/pkg-descr b/graphics/geist/pkg-descr
new file mode 100644
index 000000000000..e26ec63bf55d
--- /dev/null
+++ b/graphics/geist/pkg-descr
@@ -0,0 +1,3 @@
+An object-based image creation/layout application which utilizes Imlib2.
+
+WWW: http://www.linuxbrit.co.uk/geist/
diff --git a/graphics/geist/pkg-plist b/graphics/geist/pkg-plist
new file mode 100644
index 000000000000..1083281eab19
--- /dev/null
+++ b/graphics/geist/pkg-plist
@@ -0,0 +1,27 @@
+bin/geist
+share/doc/geist/AUTHORS
+share/doc/geist/ChangeLog
+share/doc/geist/README
+share/doc/geist/TODO
+share/geist/fonts/20thcent.ttf
+share/geist/fonts/cinema.ttf
+share/geist/fonts/droid.ttf
+share/geist/fonts/goodtime.ttf
+share/geist/fonts/grunge.ttf
+share/geist/fonts/joystix.ttf
+share/geist/fonts/morpheus.ttf
+share/geist/fonts/notepad.ttf
+share/geist/fonts/soulpapa.ttf
+share/geist/images/bg.png
+share/geist/images/bulb.png
+share/geist/images/elogo.png
+share/geist/images/globe.png
+share/geist/images/mail.png
+share/geist/images/mush.png
+share/geist/images/paper.png
+share/geist/test.xml
+share/geist/text_test.xml
+@dirrm share/doc/geist
+@dirrm share/geist/fonts
+@dirrm share/geist/images
+@dirrm share/geist