aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/vim/Makefile4
-rw-r--r--editors/vim/options10
2 files changed, 14 insertions, 0 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index d63e69489cc8..e1bf86b8b5fd 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -29,6 +29,10 @@ COMMENT?= Vi "workalike", with many additional features
SLAVEDIRS= editors/vim-lite
+.if defined(WITH_OPTIONS) || defined(WITH_VIM_OPTIONS)
+.include "${.CURDIR}/options"
+.endif
+
.if defined(PACKAGE_BUILDING) && !defined(LITE)
#WITH_TCL= yes
WITH_PERL= yes
diff --git a/editors/vim/options b/editors/vim/options
new file mode 100644
index 000000000000..c07389f4725e
--- /dev/null
+++ b/editors/vim/options
@@ -0,0 +1,10 @@
+OPTIONS= PERL "Enable Perl interpreter" off \
+ PYTHON "Enable Python interpreter" off \
+ RUBY "Enable Ruby interpreter" off \
+ CSCOPE "Enable cscope" off \
+ EXUBERANT_CTAGS "Use exctags instead of ctags" off \
+ ATHENA "Athena GUI" off \
+ GTK2 "GTK2 GUI" off \
+ GNOME "Gnome1 GUI" off \
+ MOTIF "Motif GUI" off \
+ XTERM_SAVE "" off