aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--security/Makefile1
-rw-r--r--security/engine_pkcs11/Makefile30
-rw-r--r--security/engine_pkcs11/distinfo2
-rw-r--r--security/engine_pkcs11/pkg-descr7
-rw-r--r--security/engine_pkcs11/pkg-plist1
-rw-r--r--security/libp11/Makefile28
-rw-r--r--security/libp11/distinfo4
-rw-r--r--security/libp11/files/patch-configure.ac11
-rw-r--r--security/libp11/files/patch-src_Makefile.am10
-rw-r--r--security/libp11/pkg-plist7
11 files changed, 45 insertions, 57 deletions
diff --git a/MOVED b/MOVED
index 65d09f1e8bfa..e0fc6d85af5d 100644
--- a/MOVED
+++ b/MOVED
@@ -8281,3 +8281,4 @@ devel/libmcs||2016-04-13|Development no longer active and is not used any more
www/node-devel|www/node|2016-04-13|Upstream no longer releases a development version
graphics/kipi-plugin-googledrive||2016-04-14|Merged into graphics/kipi-plugin-googleservices
graphics/kipi-plugin-picasawebexport||2016-04-14|Merged into graphics/kipi-plugin-googleservices
+security/engine_pkcs11|security/libp11|2016-04-20|Merged
diff --git a/security/Makefile b/security/Makefile
index f169f9fc24f7..b643eb859eb6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -119,7 +119,6 @@
SUBDIR += elixir-comeonin
SUBDIR += elixir-comeonin_i18n
SUBDIR += elixir-jose
- SUBDIR += engine_pkcs11
SUBDIR += erlang-jose
SUBDIR += erlang-p1tls
SUBDIR += esteidfirefoxplugin
diff --git a/security/engine_pkcs11/Makefile b/security/engine_pkcs11/Makefile
deleted file mode 100644
index 529929123589..000000000000
--- a/security/engine_pkcs11/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# Created by: Alex Dupre <ale@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= engine_pkcs11
-PORTVERSION= 0.1.8
-PORTREVISION= 2
-CATEGORIES= security
-MASTER_SITES= SF/opensc/${PORTNAME}
-
-MAINTAINER= ale@FreeBSD.org
-COMMENT= Implementation of a PKCS\#11 engine for OpenSSL
-
-LICENSE= BSD2CLAUSE
-
-LIB_DEPENDS= libp11.so:security/libp11
-
-OPTIONS_DEFINE= DOCS
-
-USES= libtool pkgconfig
-USE_OPENSSL= yes
-GNU_CONFIGURE= yes
-
-CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
- OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
-
-PORTDOCS= *
-
-DOCS_CONFIGURE_ON= --enable-doc
-
-.include <bsd.port.mk>
diff --git a/security/engine_pkcs11/distinfo b/security/engine_pkcs11/distinfo
deleted file mode 100644
index 0536dd97eb4b..000000000000
--- a/security/engine_pkcs11/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (engine_pkcs11-0.1.8.tar.gz) = de7d7e41e7c42deef40c53e10ccc3f88d2c036d6656ecee7e82e8be07b06a2e5
-SIZE (engine_pkcs11-0.1.8.tar.gz) = 320799
diff --git a/security/engine_pkcs11/pkg-descr b/security/engine_pkcs11/pkg-descr
deleted file mode 100644
index d6f617ac2b0e..000000000000
--- a/security/engine_pkcs11/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-Engine_pkcs11 is an implementation of an engine for OpenSSL.
-It can be loaded using code, config file or command line and
-will pass any function call by openssl to a PKCS#11 module.
-Engine_pkcs11 is meant to be used with smart cards and software
-for using smart cards in PKCS#11 format, such as OpenSC.
-
-WWW: https://github.com/OpenSC/OpenSC/wiki/OpenSSL-engine-for-PKCS%2311-modules
diff --git a/security/engine_pkcs11/pkg-plist b/security/engine_pkcs11/pkg-plist
deleted file mode 100644
index b808e668dbda..000000000000
--- a/security/engine_pkcs11/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-lib/engines/engine_pkcs11.so
diff --git a/security/libp11/Makefile b/security/libp11/Makefile
index eb76971fcbfb..abb85d8df1f6 100644
--- a/security/libp11/Makefile
+++ b/security/libp11/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= libp11
-PORTVERSION= 0.2.8
-PORTREVISION= 2
+PORTVERSION= 0.4.0
CATEGORIES= security devel
-MASTER_SITES= SF/opensc/${PORTNAME}
MAINTAINER= ale@FreeBSD.org
COMMENT= Small layer on top of PKCS\#11 API
@@ -16,28 +14,32 @@ LIB_DEPENDS= libltdl.so:devel/libltdl
OPTIONS_DEFINE= DOCS EXAMPLES
+USE_GITHUB= yes
+GH_ACCOUNT= OpenSC
+GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
+
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USES= libtool pkgconfig
+USES= autoreconf libtool pkgconfig
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
+
CONFIGURE_ENV= LTLIB_CFLAGS="-I${LOCALBASE}/include" \
LTLIB_LIBS="-L${LOCALBASE}/lib -lltdl" \
OPENSSL_CFLAGS="-I${OPENSSLINC}" \
- OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
-PORTDOCS= *
+CONFIGURE_ARGS= --with-enginesdir=${PREFIX}/lib/engines
-DOCS_CONFIGURE_ON= --enable-doc
+INSTALL_TARGET= install-strip
-post-patch:
- @${REINPLACE_CMD} 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} 's|install-data-am: install-apidocDATA install-dist_docDATA|install-data-am: install-dist_docDATA|' \
- ${WRKSRC}/doc/Makefile.in
+PORTDOCS= *
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/README ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/Makefile ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.c ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/security/libp11/distinfo b/security/libp11/distinfo
index 9d2d9ec90e0b..6fb1db2e8a40 100644
--- a/security/libp11/distinfo
+++ b/security/libp11/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libp11-0.2.8.tar.gz) = a4121015503ade98074b5e2a2517fc8a139f8b28aed10021db2bb77283f40691
-SIZE (libp11-0.2.8.tar.gz) = 377508
+SHA256 (OpenSC-libp11-0.4.0-libp11-0.4.0_GH0.tar.gz) = a825db152add1a80f1d538ae91fee55178e2f597520d958ca128aa5bca5f1300
+SIZE (OpenSC-libp11-0.4.0-libp11-0.4.0_GH0.tar.gz) = 101829
diff --git a/security/libp11/files/patch-configure.ac b/security/libp11/files/patch-configure.ac
new file mode 100644
index 000000000000..f30e1cf171c2
--- /dev/null
+++ b/security/libp11/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2016-03-28 16:04:04 UTC
++++ configure.ac
+@@ -191,7 +191,7 @@ if test -n "${pkcs11_module}"; then
+ [Default PKCS#11 module.])
+ fi
+
+-pkgconfigdir="\$(libdir)/pkgconfig"
++pkgconfigdir="\$(prefix)/libdata/pkgconfig"
+
+ AC_SUBST([pkgconfigdir])
+ AC_SUBST([apidocdir])
diff --git a/security/libp11/files/patch-src_Makefile.am b/security/libp11/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..82d47056e750
--- /dev/null
+++ b/security/libp11/files/patch-src_Makefile.am
@@ -0,0 +1,10 @@
+--- src/Makefile.am.orig 2016-03-28 16:04:04 UTC
++++ src/Makefile.am
+@@ -40,6 +40,7 @@ pkcs11_la_LDFLAGS = $(AM_LDFLAGS) -modul
+ all-local:
+ cd .libs && $(LN_S) -f pkcs11$(SHARED_EXT) libpkcs11$(SHARED_EXT)
+ install-exec-hook:
++ $(MKDIR_P) '$(DESTDIR)$(enginesdir)'
+ cd '$(DESTDIR)$(enginesdir)' && $(LN_S) -f pkcs11$(SHARED_EXT) libpkcs11$(SHARED_EXT)
+
+ if WIN32
diff --git a/security/libp11/pkg-plist b/security/libp11/pkg-plist
index 70ba9339652e..4e547837690f 100644
--- a/security/libp11/pkg-plist
+++ b/security/libp11/pkg-plist
@@ -1,11 +1,16 @@
include/libp11.h
+lib/engines/libpkcs11.so
+lib/engines/pkcs11.so
+lib/engines/pkcs11.so.0
+lib/engines/pkcs11.so.0.0.0
lib/libp11.a
lib/libp11.so
lib/libp11.so.2
-lib/libp11.so.2.2.0
+lib/libp11.so.2.4.0
libdata/pkgconfig/libp11.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/auth.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/decrypt.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getrandom.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/listkeys.c