aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/dspam/Makefile8
-rw-r--r--security/maia/Makefile11
-rw-r--r--sysutils/froxlor/Makefile8
3 files changed, 5 insertions, 22 deletions
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index d62c4b8bca1a..328c71ed5490 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -32,7 +32,7 @@ OPTIONS_MULTI_DB= HASH MYSQL MYSQL_COMPRESS MYSQL_LOCAL \
PGSQL PGSQL_LOCAL SQLITE2 SQLITE3
OPTIONS_RADIO= LDA
-OPTIONS_RADIO_LDA= CYRUS23 CYRUS24 DOVECOT1 \
+OPTIONS_RADIO_LDA= CYRUS23 CYRUS24 \
DOVECOT2 EXIM MAILDROP PROCMAIL SAFECAT SENDMAIL
OPTIONS_DEFAULT= SYSLOG DEBUG DAEMON CLAMAV CLAMAV_LOCAL \
@@ -61,7 +61,6 @@ LARGE_SCALE_DESC= File structure for large scale
DOMAIN_SCALE_DESC= File structure for multiple domains
CYRUS23_DESC= Cyrus's 2.3 deliver as LDA
CYRUS24_DESC= Cyrus's 2.4 deliver as LDA
-DOVECOT1_DESC= Dovecot 1.2 deliver as LDA
DOVECOT2_DESC= Dovecot 2.2 dovecot-lda as LDA
EXIM_DESC= Exim as local delivery agent
MAILDROP_DESC= Maildrop as local delivery agent
@@ -340,11 +339,6 @@ RUN_DEPENDS+= ${LOCALBASE}/cyrus/bin/deliver:mail/cyrus-imapd24
CONFIGURE_ARGS+= --with-delivery-agent='${LOCALBASE}/cyrus/bin/deliver'
.endif
-.if ${PORT_OPTIONS:MDOVECOT1}
-RUN_DEPENDS+= ${LOCALBASE}/libexec/dovecot/deliver:mail/dovecot
-CONFIGURE_ARGS+= --with-delivery-agent='${LOCALBASE}/libexec/dovecot/deliver'
-.endif
-
.if ${PORT_OPTIONS:MDOVECOT2}
RUN_DEPENDS+= ${LOCALBASE}/libexec/dovecot/dovecot-lda:mail/dovecot2
CONFIGURE_ARGS+= --with-delivery-agent='${LOCALBASE}/libexec/dovecot/dovecot-lda'
diff --git a/security/maia/Makefile b/security/maia/Makefile
index 694e96f4ce29..d8d0c54784b4 100644
--- a/security/maia/Makefile
+++ b/security/maia/Makefile
@@ -39,7 +39,7 @@ MAIAQUARANTINE?= /var/maiad/virusmails
PEAR_DIR?= ${LOCALBASE}/share/pear
PLIST_SUB+= USERS="${USERS}" GROUPS="${GROUPS}" WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
-OPTIONS_DEFINE= APACHE LIGHTTPD WEBHOST MYSQL MYSQLSERVER PGSQL PGSQLSERVER DOVECOT DOVECOT2 \
+OPTIONS_DEFINE= APACHE LIGHTTPD WEBHOST MYSQL MYSQLSERVER PGSQL PGSQLSERVER DOVECOT2 \
POSTFIX PFA FUZZYOCR CLAMAV SPAMASSASSIN BDB ALTERMIME CRYPT \
IPCOUNTRY DOMAINKEYS SPF DKIM FILE RAR ARJ UNARJ LHA ARC NOMARCH CAB \
RPM ZOO UNZOO LZOP FREEZE P7ZIP TNEF DOCS
@@ -53,7 +53,6 @@ MYSQL_DESC= Use MySQL datebase
MYSQLSERVER_DESC= Install MySQL Server
PGSQL_DESC= Use PgSQL database
PGSQLSERVER_DESC= Install PGSQL Server
-DOVECOT_DESC= Use Dovecot 1.x IMAP/POP3
DOVECOT2_DESC= Use Dovecot 2.x IMAP/POP3
POSTFIX_DESC= Use Postfix MTA
PFA_DESC= Use Postfixadmin
@@ -168,14 +167,6 @@ USES:= ${USES:Npgsql} pgsql
WANT_PGSQL= server
.endif
-.if ${PORT_OPTIONS:MDOVECOT} && ${PORT_OPTIONS:MDOVECOT2}
-BROKEN= please run 'make config' again and choose only one version of Dovecot (versions 1.x and 2.x cannot coexist)
-.endif
-
-.if ${PORT_OPTIONS:MDOVECOT}
-RUN_DEPENDS+= dovecot:mail/dovecot
-.endif
-
.if ${PORT_OPTIONS:MDOVECOT2}
RUN_DEPENDS+= dovecot:mail/dovecot2
.endif
diff --git a/sysutils/froxlor/Makefile b/sysutils/froxlor/Makefile
index c1d7aa8d1d42..0a5a23e2b2d1 100644
--- a/sysutils/froxlor/Makefile
+++ b/sysutils/froxlor/Makefile
@@ -3,6 +3,7 @@
PORTNAME= froxlor
PORTVERSION= 0.9.38.7
+PORTREVIION= 1
CATEGORIES= sysutils www
MASTER_SITES= http://files.froxlor.org/releases/
@@ -29,7 +30,7 @@ OPTIONS_DEFINE= LIBNSS LOGROTATE MYSQLS DKIM PCNTL NLS
OPTIONS_RADIO= WEB SMTP IMAPPOP3 FTP DNS
OPTIONS_RADIO_WEB= APACHE LIGHTTPD NGINX
OPTIONS_RADIO_SMTP= POSTFIX EXIM
-OPTIONS_RADIO_IMAPPOP3= DOVECOT DOVECOT2 COURIER
+OPTIONS_RADIO_IMAPPOP3= DOVECOT2 COURIER
OPTIONS_RADIO_FTP= PROFTPD PUREFTPD
OPTIONS_RADIO_DNS= POWERDNS ISCDNS
OPTIONS_MULTI= WWWST
@@ -49,7 +50,6 @@ MYSQLS_DESC= MySQL database server and client
POSTFIX_DESC= Postfix as SMTP server
EXIM_DESC= Exim as SMTP server
DKIM_DESC= OpenDKIM for DomainKeys Identified Mail
-DOVECOT_DESC= Dovecot 1.x as IMAP/POP3 server
DOVECOT2_DESC= Dovecot 2.x as IMAP/POP3 server
COURIER_DESC= Courier as IMAP/POP3 server
PROFTPD_DESC= ProFTPd as FTP server
@@ -64,7 +64,7 @@ LOGROTATE_DESC= Logrotate for log rotation
MYSQLS_DESC= Depend on MySQL server
NLS_DESC= Enable NLS support (required for webFTP frontend)
-OPTIONS_DEFAULT= APACHE MYSQLS POSTFIX DOVECOT PROFTPD WEBALIZER MYSQLS PCNTL
+OPTIONS_DEFAULT= APACHE MYSQLS POSTFIX DOVECOT2 PROFTPD WEBALIZER MYSQLS PCNTL
POSTFIX_RUN_DEPENDS= postfix:mail/postfix
@@ -72,8 +72,6 @@ EXIM_RUN_DEPENDS= exim:mail/exim
DKIM_RUN_DEPENDS= opendkim:mail/opendkim
-DOVECOT_RUN_DEPENDS= dovecot>1:mail/dovecot
-
DOVECOT2_RUN_DEPENDS= dovecot2>=2:mail/dovecot2
COURIER_RUN_DEPENDS= courier:mail/courier