aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/openmsx/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/emulators/openmsx/Makefile b/emulators/openmsx/Makefile
index 4747628582f8..b9ff6127956a 100644
--- a/emulators/openmsx/Makefile
+++ b/emulators/openmsx/Makefile
@@ -25,7 +25,7 @@ MAKE_ARGS+= INSTALL_BINARY_DIR=${PREFIX}/bin \
MAKEFILE= GNUmakefile
USE_GMAKE= yes
-USE_GCC= 3.2+
+USE_GCC= 3.3+
USE_TCL= 84
USE_TCL_BUILD= 84
USE_SDL= sdl image
@@ -35,4 +35,11 @@ USE_SDL= sdl image
MAKE_ARGS+= INSTALL_DOC_DIR=${WRKSRC}/dummy
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 503000
+ @${REINPLACE_CMD} -e 's/round/rint/' ${WRKSRC}/src/Math.hh
+.endif
+
+.include <bsd.port.post.mk>