aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.gecko.mk2
-rw-r--r--devel/codeblocks/Makefile4
-rw-r--r--devel/lokalize/Makefile4
-rw-r--r--editors/codelite/Makefile4
-rw-r--r--editors/codelite/files/patch-SpellChecker_CMakeLists.txt2
-rw-r--r--editors/focuswriter/Makefile3
-rw-r--r--editors/libreoffice/Makefile2
-rw-r--r--editors/libreoffice/Makefile.common2
-rw-r--r--editors/libreoffice4/Makefile4
-rw-r--r--editors/openoffice-4/Makefile4
-rw-r--r--editors/openoffice-devel/Makefile4
-rw-r--r--editors/tea/Makefile4
-rw-r--r--editors/texmaker/Makefile4
-rw-r--r--editors/texstudio/Makefile4
-rw-r--r--editors/textroom/Makefile4
-rw-r--r--editors/texworks/Makefile2
-rw-r--r--german/hunspell/Makefile1
-rw-r--r--korean/hunspell/Makefile2
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--multimedia/aegisub/Makefile4
-rw-r--r--net-im/licq-qt-gui/Makefile6
-rw-r--r--print/lyx/Makefile4
-rw-r--r--print/scribus/Makefile4
-rw-r--r--print/scribus/files/patch-cmake_modules_FindHUNSPELL.cmake5
-rw-r--r--textproc/enchant/Makefile4
-rw-r--r--textproc/goldendict/Makefile4
-rw-r--r--textproc/hunspell/Makefile17
-rw-r--r--textproc/hunspell/distinfo6
-rw-r--r--textproc/hunspell/files/patch-add-const22
-rw-r--r--textproc/kf5-sonnet/Makefile3
-rw-r--r--textproc/kf5-sonnet/files/patch-cmake_FindHUNSPELL.cmake12
-rw-r--r--textproc/mythes/Makefile4
-rw-r--r--textproc/py-hunspell/Makefile3
-rw-r--r--textproc/sigil/Makefile6
-rw-r--r--textproc/te-hunspell/Makefile2
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/libxul/Makefile2
-rw-r--r--www/otter-browser/Makefile3
-rw-r--r--www/qupzilla-qt4/Makefile4
-rw-r--r--www/qupzilla-qt5/Makefile4
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--x11/kdelibs4/files/patch-z-cmake_modules_FindHUNSPELL.cmake12
-rw-r--r--x11/leechcraft/Makefile4
-rw-r--r--x11/leechcraft/files/patch-plugins_rosenthal_cmake_FindHunspell.cmake2
45 files changed, 109 insertions, 92 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 9b1c71decfa6..f7746622ed3a 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -183,7 +183,7 @@ harfbuzz_LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
harfbuzz_MOZ_OPTIONS= --with-system-harfbuzz
.endif
-hunspell_LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+hunspell_LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
hunspell_MOZ_OPTIONS= --enable-system-hunspell
icu_LIB_DEPENDS= libicui18n.so:devel/icu
diff --git a/devel/codeblocks/Makefile b/devel/codeblocks/Makefile
index 142211ac3ab2..0297d8aa7e0f 100644
--- a/devel/codeblocks/Makefile
+++ b/devel/codeblocks/Makefile
@@ -3,7 +3,7 @@
PORTNAME= codeblocks
PORTVERSION= 16.01
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/Sources/${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -18,7 +18,7 @@ BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libhunspell-1.5.so:textproc/hunspell
+ libhunspell-1.6.so:textproc/hunspell
USES= autoreconf compiler desktop-file-utils fam:gamin localbase \
gettext-runtime libtool pathfix pkgconfig shared-mime-info
diff --git a/devel/lokalize/Makefile b/devel/lokalize/Makefile
index f6fb0401901f..51ebe16d7149 100644
--- a/devel/lokalize/Makefile
+++ b/devel/lokalize/Makefile
@@ -2,13 +2,13 @@
PORTNAME= lokalize
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel kde kde-kde4
MAINTAINER= kde@FreeBSD.org
COMMENT= Computer-aided translation system
-LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
USES= cmake:outsource kde:4 tar:xz
USE_KDE= kdelibs automoc4
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index d73ebfdd6206..b90b246bb841 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -3,7 +3,7 @@
PORTNAME= codelite
PORTVERSION= 9.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors devel
MAINTAINER= mokhi64@gmail.com
@@ -12,7 +12,7 @@ COMMENT= Open Source IDE for C/C++
LICENSE= GPLv2+
RUN_DEPENDS= xterm:x11/xterm
-LIB_DEPENDS+= libhunspell-1.5.so:textproc/hunspell
+LIB_DEPENDS+= libhunspell-1.6.so:textproc/hunspell
USE_GITHUB= yes
GH_ACCOUNT= eranif
diff --git a/editors/codelite/files/patch-SpellChecker_CMakeLists.txt b/editors/codelite/files/patch-SpellChecker_CMakeLists.txt
index 61fae7302533..28bd16af9919 100644
--- a/editors/codelite/files/patch-SpellChecker_CMakeLists.txt
+++ b/editors/codelite/files/patch-SpellChecker_CMakeLists.txt
@@ -5,7 +5,7 @@
find_library(LIBHUNSPELL
# Fedora doesn't create a hunspell->hunspell-1.3 symlink, so explicitly look for (the current) full name
- NAMES hunspell hunspell-1.3
-+ NAMES hunspell hunspell-1.5 hunspell-1.4 hunspell-1.3
++ NAMES hunspell-1.6 hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell
PATH_SUFFIXES lib)
find_path( HUNSPELL_H
diff --git a/editors/focuswriter/Makefile b/editors/focuswriter/Makefile
index 11f7a7748799..49490450cfe5 100644
--- a/editors/focuswriter/Makefile
+++ b/editors/focuswriter/Makefile
@@ -4,6 +4,7 @@
PORTNAME= focuswriter
PORTVERSION= 1.6.3
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= editors
MAINTAINER= lightside@gmx.com
@@ -14,7 +15,7 @@ LICENSE_COMB= multi
LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL3= ${WRKSRC}/resources/images/icons/oxygen/COPYING
-LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
USE_GITHUB= yes
GH_ACCOUNT= gottcode
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 3b4a45e2dd12..ce28204bb807 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -54,7 +54,7 @@ LIB_DEPENDS= libapr-1.so:devel/apr1 \
libnss3.so:security/nss \
libclucene-core.so:textproc/clucene \
libexpat.so:textproc/expat2 \
- libhunspell-1.5.so:textproc/hunspell \
+ libhunspell-1.6.so:textproc/hunspell \
libhyphen.so:textproc/hyphen \
libabw-0.1.so:textproc/libabw \
libe-book-0.1.so:textproc/libe-book \
diff --git a/editors/libreoffice/Makefile.common b/editors/libreoffice/Makefile.common
index 3b6863b98dce..8fd90062ae33 100644
--- a/editors/libreoffice/Makefile.common
+++ b/editors/libreoffice/Makefile.common
@@ -2,7 +2,7 @@
PORTNAME= libreoffice
PORTVERSION= 5.2.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= editors
MAINTAINER= office@FreeBSD.org
diff --git a/editors/libreoffice4/Makefile b/editors/libreoffice4/Makefile
index 83fd6d748838..081ae65ac1ee 100644
--- a/editors/libreoffice4/Makefile
+++ b/editors/libreoffice4/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libreoffice
PORTVERSION= 4.3.7
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= editors
MASTER_SITES= http://download.documentfoundation.org/libreoffice/src/${PORTVERSION}/ \
http://dev-www.libreoffice.org/extern/:ext \
@@ -55,7 +55,7 @@ LIB_DEPENDS= libapr-1.so:devel/apr1 \
libnss3.so:security/nss \
libclucene-core.so:textproc/clucene \
libexpat.so:textproc/expat2 \
- libhunspell-1.5.so:textproc/hunspell \
+ libhunspell-1.6.so:textproc/hunspell \
libhyphen.so:textproc/hyphen \
libabw-0.1.so:textproc/libabw \
libe-book-0.1.so:textproc/libe-book \
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 19a83042ffd9..2ef135c72049 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 4
+PORTREVISION= 5
#PORTREVISION= 1
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
@@ -82,7 +82,7 @@ LIB_DEPENDS= \
libfreetype.so:print/freetype2 \
libnss3.so:security/nss \
libexpat.so:textproc/expat2 \
- libhunspell-1.5.so:textproc/hunspell \
+ libhunspell-1.6.so:textproc/hunspell \
libhyphen.so:textproc/hyphen \
libtextcat.so:textproc/libtextcat \
libmythes-1.2.so:textproc/mythes \
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index dc35c0737ed8..b58833f0d9f9 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION1}.${AOOVERSION2}.${SVNREVISION}
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 4
CATEGORIES= editors java
MASTER_SITES= https://dist.apache.org/repos/dist/dev/openoffice/${AOOVERSION}-${AOORC}-r${SVNREVISION}/source/ \
@@ -82,7 +82,7 @@ LIB_DEPENDS= \
libfreetype.so:print/freetype2 \
libnss3.so:security/nss \
libexpat.so:textproc/expat2 \
- libhunspell-1.5.so:textproc/hunspell \
+ libhunspell-1.6.so:textproc/hunspell \
libhyphen.so:textproc/hyphen \
libtextcat.so:textproc/libtextcat \
libmythes-1.2.so:textproc/mythes \
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 00ab12650fe8..d35ac3403782 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tea
PORTVERSION= 43.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= http://semiletov.org/tea/dloads/
@@ -33,7 +33,7 @@ DESKTOP_ENTRIES="TEA" "" "${PREFIX}/share/pixmaps/tea_icon_v2.png" \
ASPELL_LIB_DEPENDS= libaspell.so:textproc/aspell
ASPELL_QMAKE_ON= CONFIG+=nohunspell
-HUNSPELL_LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+HUNSPELL_LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
HUNSPELL_QMAKE_ON= CONFIG+=noaspell
post-patch:
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 95cc721b56c0..798fe1afe906 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -3,7 +3,7 @@
PORTNAME= texmaker
PORTVERSION= 4.5
-PORTREVISION= 8
+PORTREVISION= 9
PORTEPOCH= 3
CATEGORIES= editors
MASTER_SITES= http://www.xm1math.net/texmaker/
@@ -13,7 +13,7 @@ COMMENT= LaTeX Development Environment
LICENSE= GPLv2
-LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell \
+LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell \
libpoppler.so:graphics/poppler
USES= desktop-file-utils ghostscript:x11,run pkgconfig qmake tar:bzip2
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index 655624354b30..2c3863d8c2c2 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -2,14 +2,14 @@
PORTNAME= texstudio
PORTVERSION= 2.11.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= editors
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/TeXstudio%20${PORTVERSION}
MAINTAINER= abiliojr@gmail.com
COMMENT= Integrated writing environment for LaTeX documents
-LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell \
+LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell \
libpoppler.so:graphics/poppler
USES= desktop-file-utils dos2unix execinfo ghostscript:run \
diff --git a/editors/textroom/Makefile b/editors/textroom/Makefile
index e770a17961ef..105b13045e23 100644
--- a/editors/textroom/Makefile
+++ b/editors/textroom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= textroom
PORTVERSION= 0.8.2
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= editors
MASTER_SITES= SF
@@ -13,7 +13,7 @@ COMMENT= Full screen text editor
LICENSE= GPLv3
LIB_DEPENDS= libcurl.so:ftp/curl \
- libhunspell-1.5.so:textproc/hunspell \
+ libhunspell-1.6.so:textproc/hunspell \
libxml++-2.6.so:textproc/libxml++26
USES= desktop-file-utils pkgconfig qmake
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index 0be276d46758..bea9e694122a 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -4,7 +4,7 @@
PORTNAME= texworks
PORTVERSION= 0.4.6
DISTVERSIONPREFIX= release-
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= editors
MAINTAINER= hrs@FreeBSD.org
diff --git a/german/hunspell/Makefile b/german/hunspell/Makefile
index b021282e8c50..e31a79e1adfb 100644
--- a/german/hunspell/Makefile
+++ b/german/hunspell/Makefile
@@ -2,6 +2,7 @@
PORTNAME= hunspell
PORTVERSION= 20161207
+PORTREVISION= 1
CATEGORIES= german textproc
MASTER_SITES= http://www.j3e.de/ispell/igerman98/dict/ \
LOCAL/sunpoet/${PORTNAME}
diff --git a/korean/hunspell/Makefile b/korean/hunspell/Makefile
index 81b5c9a496d6..a087b9ce5f8c 100644
--- a/korean/hunspell/Makefile
+++ b/korean/hunspell/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hunspell
PORTVERSION= 0.5.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= korean textproc
MAINTAINER= jkim@FreeBSD.org
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index b318de955a01..e97fc098cfd7 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 45.6.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/multimedia/aegisub/Makefile b/multimedia/aegisub/Makefile
index 6a076ec05ff2..5149d355292c 100644
--- a/multimedia/aegisub/Makefile
+++ b/multimedia/aegisub/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aegisub
PORTVERSION= 3.2.2
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= multimedia
MASTER_SITES= http://ftp.aegisub.org/pub/archives/releases/source/ \
ftp://ftp.aegisub.org/pub/archives/releases/source/ \
@@ -53,7 +53,7 @@ FFMPEG_LIB_DEPENDS= libffms2.so:multimedia/ffms2
FFMPEG_CONFIGURE_OFF= --without-ffms
FFTW_LIB_DEPENDS= libfftw3.so:math/fftw3
FFTW_CONFIGURE_OFF= --without-fftw3
-HUNSPELL_LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+HUNSPELL_LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
HUNSPELL_CONFIGURE_OFF= --without-hunspell
OPENAL_USES= openal
OPENAL_CONFIGURE_OFF= --without-openal
diff --git a/net-im/licq-qt-gui/Makefile b/net-im/licq-qt-gui/Makefile
index 234e25a51af2..d6bde30efcc9 100644
--- a/net-im/licq-qt-gui/Makefile
+++ b/net-im/licq-qt-gui/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qt4-gui
PORTVERSION= 1.8.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-im
PKGNAMESUFFIX?= ${KDE_SUFFIX}${PKGNAMESUFFIX2}
@@ -25,9 +25,9 @@ OPTIONS_DEFAULT=HUNSPELL
LICQ_PORT?= net-im/licq
-HUNSPELL_LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+HUNSPELL_LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
HUNSPELL_CMAKE_ON= -DHUNSPELL_INCLUDE_DIRS=${LOCALBASE}/include/hunspell \
- -DHUNSPELL_LIBRARIES=${LOCALBASE}/lib/libhunspell-1.5.so \
+ -DHUNSPELL_LIBRARIES=${LOCALBASE}/lib/libhunspell-1.6.so \
-DHUNSPELL_FOUND:BOOL=ON
HUNSPELL_CMAKE_OFF= -DHUNSPELL_FOUND:BOOL=OFF
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index e610420458bb..75ae2074fbea 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lyx
PORTVERSION= ${MAJOR_VERSION}.${MINOR_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print editors
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${MAJOR_VERSION}.x/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/${MAJOR_VERSION}.x/ \
@@ -46,7 +46,7 @@ ASPELL_LIB_DEPENDS= libaspell.so:textproc/aspell
ENCHANT_CONFIGURE_OFF= --without-enchant
ENCHANT_LIB_DEPENDS= libenchant.so:textproc/enchant
HUNSPELL_CONFIGURE_OFF= --without-hunspell
-HUNSPELL_LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+HUNSPELL_LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
NLS_CONFIGURE_OFF= --disable-nls
NLS_USES= gettext
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index 71882f23cae7..4a75168a1aa4 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scribus
PORTVERSION= 1.4.6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= print editors
MASTER_SITES= SF \
http://www.scribus.net/downloads/${PORTVERSION}/
@@ -18,7 +18,7 @@ LIB_DEPENDS= liblcms.so:graphics/lcms \
libfreetype.so:print/freetype2 \
libpodofo.so:graphics/podofo \
libboost_thread.so:devel/boost-libs \
- libhunspell-1.5.so:textproc/hunspell \
+ libhunspell-1.6.so:textproc/hunspell \
libcairo.so:graphics/cairo \
libhyphen.so:textproc/hyphen \
libfontconfig.so:x11-fonts/fontconfig
diff --git a/print/scribus/files/patch-cmake_modules_FindHUNSPELL.cmake b/print/scribus/files/patch-cmake_modules_FindHUNSPELL.cmake
index 99800ad9f7ef..0de78edc9a0e 100644
--- a/print/scribus/files/patch-cmake_modules_FindHUNSPELL.cmake
+++ b/print/scribus/files/patch-cmake_modules_FindHUNSPELL.cmake
@@ -1,11 +1,12 @@
--- cmake/modules/FindHUNSPELL.cmake.orig 2012-04-10 20:15:53 UTC
+++ cmake/modules/FindHUNSPELL.cmake
-@@ -9,7 +9,8 @@
+@@ -9,7 +9,9 @@
#Based on examples at http://www.vtk.org/Wiki/CMake:How_To_Find_Libraries
FIND_PATH(HUNSPELL_INCLUDE_DIR hunspell/hunspell.hxx )
-FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.3 hunspell-1.2 PATHS /opt/local/lib /usr/local/lib /usr/lib )
-+FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell-1.2
++FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.6
++ hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell-1.2 hunspell
+ PATHS /opt/local/lib /usr/local/lib /usr/lib )
INCLUDE(FindPackageHandleStandardArgs)
diff --git a/textproc/enchant/Makefile b/textproc/enchant/Makefile
index 29a6f6ed5bbf..357acb23fde1 100644
--- a/textproc/enchant/Makefile
+++ b/textproc/enchant/Makefile
@@ -3,7 +3,7 @@
PORTNAME= enchant
PORTVERSION= 1.6.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= textproc gnome
MASTER_SITES= http://www.abisource.com/downloads/${PORTNAME}/${PORTVERSION}/
DIST_SUBDIR= gnome2
@@ -39,7 +39,7 @@ HSPELL_BUILD_DEPENDS= ${LOCALBASE}/lib/libhspell.a:hebrew/hspell
HSPELL_CONFIGURE_ENABLE= hspell
HSPELL_CONFIGURE_ON= --with-hspell-prefix=${LOCALBASE}
-HUNSPELL_LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+HUNSPELL_LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
HUNSPELL_CONFIGURE_ENABLE= myspell
HUNSPELL_CONFIGURE_ON= --with-system-myspell=yes \
--with-myspell-dir=${LOCALBASE}/share/hunspell
diff --git a/textproc/goldendict/Makefile b/textproc/goldendict/Makefile
index 4473f1deabcb..71a528cfdc36 100644
--- a/textproc/goldendict/Makefile
+++ b/textproc/goldendict/Makefile
@@ -3,7 +3,7 @@
PORTNAME= goldendict
PORTVERSION= 1.0.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:C|(.*)\.[0-9]*$|\1|}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -13,7 +13,7 @@ COMMENT= Feature-rich Qt4 based dictionary lookup program
LICENSE= GPLv3
-LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell \
+LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell \
libvorbis.so:audio/libvorbis
NO_WRKSUBDIR= yes
diff --git a/textproc/hunspell/Makefile b/textproc/hunspell/Makefile
index bed986105b3d..e027c9ad797c 100644
--- a/textproc/hunspell/Makefile
+++ b/textproc/hunspell/Makefile
@@ -2,22 +2,25 @@
# $FreeBSD$
PORTNAME= hunspell
-PORTVERSION= 1.5.4
+PORTVERSION= 1.6.0
DISTVERSIONPREFIX= v
CATEGORIES= textproc
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= office@FreeBSD.org
COMMENT= Improved spell-checker for Hungarian and other languages
-LICENSE= GPLv2 LGPL21 MPL
+LICENSE= GPLv2+ LGPL21+ MPL
LICENSE_COMB= dual
-LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LGPL
+LICENSE_FILE_GPLv2+ = ${_LICENSE_STORE}/GPLv2
+LICENSE_FILE_LGPL21+ = ${_LICENSE_STORE}/LGPL21
LICENSE_FILE_MPL= ${WRKSRC}/COPYING.MPL
CONFLICTS_INSTALL= tinker-[0-9]*
CONFIGURE_ARGS= --disable-nls ${ICONV_CONFIGURE_ARG} --with-readline --with-ui
GNU_CONFIGURE= yes
-USES= libtool:keepla pathfix iconv ncurses readline shebangfix perl5
+USES= autoreconf libtool:keepla pathfix iconv ncurses \
+ readline shebangfix perl5
USE_GITHUB= yes
SHEBANG_FILES= src/tools/ispellaff2myspell
USE_LDCONFIG= yes
@@ -29,4 +32,10 @@ PLIST_SUB= SHLIB_VER=${PORTVERSION:R}
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/src/tools/hunspell.cxx
+makepatch-clean:
+ @${RM} ${WRKSRC}/tests/suggestiontest/Makefile.orig
+
.include <bsd.port.mk>
+
+# XXX Don't override definition in Mk/bsd.port.mk
+makepatch: makepatch-clean
diff --git a/textproc/hunspell/distinfo b/textproc/hunspell/distinfo
index 78b26ff658c3..66b8c01359f4 100644
--- a/textproc/hunspell/distinfo
+++ b/textproc/hunspell/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480524200
-SHA256 (hunspell-hunspell-v1.5.4_GH0.tar.gz) = 852c01a2e3b87eb1f2adb5261466608ba79f1f950202e18a2a1735de5098fc59
-SIZE (hunspell-hunspell-v1.5.4_GH0.tar.gz) = 1110858
+TIMESTAMP = 1482369634
+SHA256 (hunspell/hunspell-hunspell-v1.6.0_GH0.tar.gz) = 512e7d2ee69dad0b35ca011076405e56e0f10963a02d4859dbcc4faf53ca68e2
+SIZE (hunspell/hunspell-hunspell-v1.6.0_GH0.tar.gz) = 699377
diff --git a/textproc/hunspell/files/patch-add-const b/textproc/hunspell/files/patch-add-const
index d8c7bd38cf37..b43c48b95b84 100644
--- a/textproc/hunspell/files/patch-add-const
+++ b/textproc/hunspell/files/patch-add-const
@@ -66,25 +66,3 @@ reverting https://github.com/hunspell/hunspell/commit/dd4b14899bfb
/* morphological functions */
---- src/win_api/hunspelldll.c.orig 2016-11-28 10:34:55 UTC
-+++ src/win_api/hunspelldll.c
-@@ -73,7 +73,7 @@ LIBHUNSPELL_DLL_EXPORTED void hunspell_f
- pMS->free_list(slst, len);
- }
-
--LIBHUNSPELL_DLL_EXPORTED char* hunspell_get_dic_encoding(Hunspell* pMS) {
-+LIBHUNSPELL_DLL_EXPORTED const char* hunspell_get_dic_encoding(Hunspell* pMS) {
- return pMS->get_dic_encoding();
- }
-
---- src/win_api/hunspelldll.h.orig 2016-11-28 10:34:55 UTC
-+++ src/win_api/hunspelldll.h
-@@ -59,7 +59,7 @@ LIBHUNSPELL_DLL_EXPORTED void hunspell_f
- char*** slst,
- int len);
- // make local copy of returned string!!
--LIBHUNSPELL_DLL_EXPORTED char* hunspell_get_dic_encoding(Hunspell* pMS);
-+LIBHUNSPELL_DLL_EXPORTED const char* hunspell_get_dic_encoding(Hunspell* pMS);
-
- // add word to dict (word is valid until spell object is not destroyed)
- LIBHUNSPELL_DLL_EXPORTED int hunspell_add(Hunspell* pMS, char* word);
diff --git a/textproc/kf5-sonnet/Makefile b/textproc/kf5-sonnet/Makefile
index bb7efc49215f..1445c919eeb4 100644
--- a/textproc/kf5-sonnet/Makefile
+++ b/textproc/kf5-sonnet/Makefile
@@ -3,13 +3,14 @@
PORTNAME= sonnet
PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= textproc kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 plugin-based spell checking library
LIB_DEPENDS= libaspell.so:textproc/aspell \
- libhunspell-1.5.so:textproc/hunspell
+ libhunspell-1.6.so:textproc/hunspell
USES= cmake:outsource compiler:c++11-lib kde:5 tar:xz
USE_KDE= ecm
diff --git a/textproc/kf5-sonnet/files/patch-cmake_FindHUNSPELL.cmake b/textproc/kf5-sonnet/files/patch-cmake_FindHUNSPELL.cmake
new file mode 100644
index 000000000000..00e5a0848cd8
--- /dev/null
+++ b/textproc/kf5-sonnet/files/patch-cmake_FindHUNSPELL.cmake
@@ -0,0 +1,12 @@
+--- cmake/FindHUNSPELL.cmake.orig 2016-12-03 21:15:34 UTC
++++ cmake/FindHUNSPELL.cmake
+@@ -14,7 +14,8 @@ ENDIF (HUNSPELL_INCLUDE_DIR AND HUNSPELL
+
+ FIND_PATH(HUNSPELL_INCLUDE_DIR hunspell/hunspell.hxx )
+
+-FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell-1.2)
++FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.6
++ hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell-1.2 hunspell)
+
+ # handle the QUIETLY and REQUIRED arguments and set HUNSPELL_FOUND to TRUE if
+ # all listed variables are TRUE
diff --git a/textproc/mythes/Makefile b/textproc/mythes/Makefile
index 5f68a665351d..23dbc153b0fa 100644
--- a/textproc/mythes/Makefile
+++ b/textproc/mythes/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mythes
PORTVERSION= 1.2.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= SF/hunspell/MyThes/${PORTVERSION}/
DIST_SUBDIR= ${PORTNAME}
@@ -13,7 +13,7 @@ COMMENT= Simple thesaurus library
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
USES= libtool pathfix perl5 pkgconfig shebangfix
USE_LDCONFIG= yes
diff --git a/textproc/py-hunspell/Makefile b/textproc/py-hunspell/Makefile
index c1646750d195..0bd14252ac17 100644
--- a/textproc/py-hunspell/Makefile
+++ b/textproc/py-hunspell/Makefile
@@ -3,6 +3,7 @@
PORTNAME= hunspell
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= textproc devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,7 +19,7 @@ USES?= python
USES+= localbase
USE_PYTHON= distutils
-HSPLVER= 1.5
+HSPLVER= 1.6
PLIST_FILES= %%PYTHON_SITELIBDIR%%/hunspell.so
pre-configure:
diff --git a/textproc/sigil/Makefile b/textproc/sigil/Makefile
index a37f21589a88..6af714759fb5 100644
--- a/textproc/sigil/Makefile
+++ b/textproc/sigil/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sigil
PORTVERSION= 0.9.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MAINTAINER= ports@FreeBSD.org
@@ -13,7 +13,7 @@ LICENSE= GPLv3+
LIB_DEPENDS= libminizip.so:archivers/minizip \
libpcre.so:devel/pcre \
- libhunspell-1.5.so:textproc/hunspell
+ libhunspell-1.6.so:textproc/hunspell
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py3-lxml
USE_GITHUB= yes
@@ -32,7 +32,7 @@ CMAKE_ARGS= -DUSE_SYSTEM_LIBS:BOOL=1 \
-DINSTALL_BUNDLED_DICTS:BOOL=0
USE_LDCONFIG= ${PREFIX}/lib/sigil
-# Upstream uses pkg-config output to pass libhunspell-1.5.so and
+# Upstream uses pkg-config output to pass libhunspell-1.6.so and
# libpcre16.so to the linker. pkg-config output does not include full
# paths, so add a workaround to keep the port linking for now.
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/textproc/te-hunspell/Makefile b/textproc/te-hunspell/Makefile
index 44ac453894a0..c89bd38b9b1d 100644
--- a/textproc/te-hunspell/Makefile
+++ b/textproc/te-hunspell/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hunspell
DISTVERSION= 0.01-2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= GNU/aspell/dict/te
PKGNAMEPREFIX= te-
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 0d6d319757fd..741139e80508 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 45.6.0
DISTVERSIONSUFFIX=esr.source
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 93f88216927b..6fd8aa3703f3 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 50.1.0
DISTVERSIONSUFFIX=.source
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 186f2058622f..b353282a69c5 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libxul
DISTVERSION= 45.6.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
MOZILLA/firefox/candidates/${DISTVERSION}esr-candidates/build1/source
diff --git a/www/otter-browser/Makefile b/www/otter-browser/Makefile
index e1fe6fdda26d..aede25ce2a7e 100644
--- a/www/otter-browser/Makefile
+++ b/www/otter-browser/Makefile
@@ -3,6 +3,7 @@
PORTNAME= otter-browser
PORTVERSION= 0.9.12
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= kde@FreeBSD.org
@@ -11,7 +12,7 @@ COMMENT= Browser based on Qt 5
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
USES= cmake:outsource compiler:c++11-lib desktop-file-utils
USE_QT5= concurrent core dbus gui multimedia network printsupport \
diff --git a/www/qupzilla-qt4/Makefile b/www/qupzilla-qt4/Makefile
index eb61f153107e..9098660fa9b2 100644
--- a/www/qupzilla-qt4/Makefile
+++ b/www/qupzilla-qt4/Makefile
@@ -2,7 +2,7 @@
PORTNAME= qupzilla
PORTVERSION= 1.8.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= https://github.com/QupZilla/${PORTNAME}/releases/download/v${PORTVERSION}/
PKGNAMESUFFIX= -qt4
@@ -13,7 +13,7 @@ COMMENT= Web browser based on WebKit engine and Qt Framework
LICENSE= GPLv3
-LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
CONFLICTS_INSTALL= ${PORTNAME}-qt5*
diff --git a/www/qupzilla-qt5/Makefile b/www/qupzilla-qt5/Makefile
index 004e330fe029..7273ca67b7f3 100644
--- a/www/qupzilla-qt5/Makefile
+++ b/www/qupzilla-qt5/Makefile
@@ -2,7 +2,7 @@
PORTNAME= qupzilla
PORTVERSION= 1.8.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= https://github.com/QupZilla/${PORTNAME}/releases/download/v${PORTVERSION}/
PKGNAMESUFFIX= -qt5
@@ -13,7 +13,7 @@ COMMENT= Web browser based on WebKit engine and Qt Framework
LICENSE= GPLv3
-LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
CONFLICTS_INSTALL= ${PORTNAME}-qt4*
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 90bfa3f4c5c7..9c01309a0a36 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -4,7 +4,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.46
MOZILLA_VER= 49 # above + 3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build9/source
diff --git a/x11/kdelibs4/files/patch-z-cmake_modules_FindHUNSPELL.cmake b/x11/kdelibs4/files/patch-z-cmake_modules_FindHUNSPELL.cmake
new file mode 100644
index 000000000000..2c25a58de6b4
--- /dev/null
+++ b/x11/kdelibs4/files/patch-z-cmake_modules_FindHUNSPELL.cmake
@@ -0,0 +1,12 @@
+--- cmake/modules/FindHUNSPELL.cmake.orig 2015-06-26 03:14:18 UTC
++++ cmake/modules/FindHUNSPELL.cmake
+@@ -14,7 +14,8 @@ ENDIF (HUNSPELL_INCLUDE_DIR AND HUNSPELL
+
+ FIND_PATH(HUNSPELL_INCLUDE_DIR hunspell/hunspell.hxx )
+
+-FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-2.0 hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell-1.2)
++FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-2.0 hunspell-1.6
++ hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell-1.2 hunspell)
+
+ # handle the QUIETLY and REQUIRED arguments and set HUNSPELL_FOUND to TRUE if
+ # all listed variables are TRUE
diff --git a/x11/leechcraft/Makefile b/x11/leechcraft/Makefile
index 6263171b01e4..298c0d42b910 100644
--- a/x11/leechcraft/Makefile
+++ b/x11/leechcraft/Makefile
@@ -3,7 +3,7 @@
PORTNAME= leechcraft
PORTVERSION= 0.6.70
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= x11
MASTER_SITES= http://dist.leechcraft.org/LeechCraft/0.6.70/
@@ -287,7 +287,7 @@ QROSP_LIB_DEPENDS= libqrosscore.so:devel/qross
ROSENTHAL_DESC= Spellchecking support
ROSENTHAL_CMAKE_ON= -DENABLE_ROSENTHAL:BOOL=true
ROSENTHAL_CMAKE_OFF= -DENABLE_ROSENTHAL:BOOL=false
-ROSENTHAL_LIB_DEPENDS= libhunspell-1.5.so:textproc/hunspell
+ROSENTHAL_LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
SB2_DESC= Sidebar for LeechCraft with combined launcher and tab switcher
SB2_CMAKE_ON= -DENABLE_SB2:BOOL=true
diff --git a/x11/leechcraft/files/patch-plugins_rosenthal_cmake_FindHunspell.cmake b/x11/leechcraft/files/patch-plugins_rosenthal_cmake_FindHunspell.cmake
index d8848d5afbe9..d6ee719a2747 100644
--- a/x11/leechcraft/files/patch-plugins_rosenthal_cmake_FindHunspell.cmake
+++ b/x11/leechcraft/files/patch-plugins_rosenthal_cmake_FindHunspell.cmake
@@ -5,7 +5,7 @@
endif ()
-find_library (HUNSPELL_LIBRARIES NAMES hunspell-1.3 hunspell-1.2 libhunspell HINTS ${HUNSPELL_DIR} ${PROBE_DIR})
-+find_library (HUNSPELL_LIBRARIES NAMES hunspell-1.5 hunspell-1.4
++find_library (HUNSPELL_LIBRARIES NAMES hunspell-1.6 hunspell-1.5 hunspell-1.4
+ hunspell-1.3 hunspell-1.2 libhunspell HINTS ${HUNSPELL_DIR} ${PROBE_DIR})
find_path (HUNSPELL_INCLUDE_DIR hunspell/hunspell.hxx HINTS ${HUNSPELL_DIR} ${HUNSPELL_INCLUDE_WIN32})