aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--print/cups-base/Makefile74
-rw-r--r--print/cups-base/distinfo4
-rw-r--r--print/cups-base/pkg-plist58
-rw-r--r--print/cups-base/pkg-plist.image2
4 files changed, 62 insertions, 76 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 64f6944b49c3..04f6b7ae1a15 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cups
-PORTVERSION= 1.4.8
+PORTVERSION= 1.5.0
DISTVERSIONSUFFIX= -source
CATEGORIES= print
MASTER_SITES= EASYSW/${PORTNAME}/${DISTVERSION}
@@ -124,10 +124,10 @@ CONFIGURE_ARGS+= --with-printcap=${PREFIX}/etc/printcap
.endif
.if defined(WITH_GNUTLS)
-BROKEN= gnutls does not support threads yet; disable the GNUTLS
CONFIGURE_ARGS+= --disable-openssl --enable-gnutls
CONFIGURE_ENV+= PKGCONFIG="${LOCALBASE}/bin/pkg-config"
-LIB_DEPENDS+= gnutls-openssl.27:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= gcrypt.18:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
.else
CONFIGURE_ARGS+= --disable-gnutls --enable-openssl
@@ -228,6 +228,7 @@ MAN1= cups-config.1
MAN1= cancel.1 \
cupstestdsc.1 \
cupstestppd.1 \
+ ipptool.1 \
lp.1 \
lpoptions.1 \
lppasswd.1 \
@@ -244,6 +245,7 @@ MAN5= classes.conf.5 \
client.conf.5 \
cups-snmp.conf.5 \
cupsd.conf.5 \
+ ipptoolfile.5 \
mailto.conf.5 \
mime.convs.5 \
mime.types.5 \
@@ -276,10 +278,6 @@ MLINKS= accept.8 reject.8 \
SUB_FILES+= ulpt-cupsd.conf ulpt-cupsd.sh
.endif
-pre-configure::
- @${ECHO_MSG} Configuring CUPS with options:
- @${ECHO_MSG} ${CONFIGURE_ARGS} | fmt
-
post-patch:
.if (${OSVERSION} >= 700000) || defined(WITH_PIEAMD64)
.if ${ARCH} == "amd64" || defined(WITH_PIEAMD64)
@@ -297,34 +295,48 @@ post-patch:
${WRKSRC}/${CONFIGURE_SCRIPT}
.if defined(CUPS_CLIENT)
@${REINPLACE_CMD} \
+ -e 's|cups test|cups|' \
-e 's|cups filter |cups |' \
- -e 's|backend berkeley cgi-bin driver locale man monitor||' \
- -e 's|notifier ppdc scheduler systemv test ||' \
- -e 's|$$.PHPDIR. ||' \
- -e 's|conf data doc $$.FONTS.ppd templates||' \
- -e 's|/usr/share|${PREFIX}/share|g' \
+ -e 's|driver ppdc scheduler||' \
+ -e 's|$$.PHPDIR. $$.FONTS.||' \
${WRKSRC}/Makefile
.elif defined(CUPS_IMAGE)
@${REINPLACE_CMD} \
+ -e 's|cups test||' \
-e 's|cups filter |filter |' \
- -e 's|backend berkeley cgi-bin driver locale man monitor||' \
- -e 's|notifier ppdc scheduler systemv test ||' \
- -e 's|$$.PHPDIR. ||' \
- -e 's|conf data doc $$.FONTS.ppd templates||' \
- -e 's|/usr/share|${PREFIX}/share|g' \
+ -e 's|driver ppdc scheduler||' \
+ -e 's|$$.PHPDIR. $$.FONTS.||' \
${WRKSRC}/Makefile
.else
@${REINPLACE_CMD} \
- -e 's|cups filter backend|backend|' \
+ -e 's|cups test|test|' \
+ -e 's|cups filter driver|driver|' \
-e 's|$$.INSTALL_SCRIPT. cups-config|echo skip: cups-config|' \
- -e 's|/usr/share|${PREFIX}/share|g' \
- -e 's|installhdrs$$||' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} \
-e 's|cups-config.$$.MAN1EXT. ||' \
${WRKSRC}/man/Makefile
.endif
+pre-configure::
+ @${ECHO_MSG} Configuring CUPS with options:
+ @${ECHO_MSG} ${CONFIGURE_ARGS} | fmt
+
+post-configure:
+.if defined(CUPS_CLIENT)
+ @${REINPLACE_CMD} \
+ -e 's|filter .* templates||' \
+ ${WRKSRC}/Makedefs
+.elif defined(CUPS_IMAGE)
+ @${REINPLACE_CMD} \
+ -e 's|filter .* templates|filter|' \
+ ${WRKSRC}/Makedefs
+.else
+ @${REINPLACE_CMD} \
+ -e 's|filter backend|backend|' \
+ ${WRKSRC}/Makedefs
+.endif
+
.if !defined(CUPS_CLIENT)
pre-build:
${CP} -p ${LOCALBASE}/lib/libcups.a ${WRKSRC}/cups/
@@ -336,15 +348,12 @@ pre-build:
.endif
.endif
-.if defined(CUPS_IMAGE)
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/cups/raster.h ${PREFIX}/include/cups/
-.endif
-
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE)
post-build:
cd ${WRKSRC}/filter && ${MAKE} pdftops
+.endif
+.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE)
pre-su-install:
@${INSTALL} -d ${DESKTOPDIR}/
if ! pw groupshow ${CUPSGRP}; then pw groupadd ${CUPSGRP} -g 193; fi
@@ -357,8 +366,16 @@ pre-su-install:
if test -e /usr/bin/lprm; then ${CHMOD} -h 0 /usr/bin/lprm; fi
if test -e /usr/sbin/lpc; then ${CHMOD} -h 0 /usr/sbin/lpc; fi
.endif
+.endif
post-install:
+.if defined(CUPS_CLIENT)
+ ${INSTALL_SCRIPT} ${WRKSRC}/cups-config ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/cups/libcups.a ${PREFIX}/lib/
+ ${INSTALL_MAN} ${WRKSRC}/man/cups-config.man ${PREFIX}/man/man1/cups-config.1
+.elif defined(CUPS_IMAGE)
+ ${INSTALL_DATA} ${WRKSRC}/cups/raster.h ${PREFIX}/include/cups/
+.else
.if !defined(WITHOUT_GHOSTSCRIPT) || defined(WITH_XPDF)
${INSTALL_PROGRAM} ${WRKSRC}/filter/pdftops ${PREFIX}/libexec/cups/filter/
.endif
@@ -384,11 +401,4 @@ post-install:
${INSTALL} -d -m 775 -g ${CUPSGRP} ${CUPS_CACHEDIR}
.endif
-.if defined(CUPS_CLIENT)
-post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/cups-config ${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/cups/libcups.a ${PREFIX}/lib/
- ${INSTALL_MAN} ${WRKSRC}/man/cups-config.man ${PREFIX}/man/man1/cups-config.1
-.endif
-
.include <bsd.port.post.mk>
diff --git a/print/cups-base/distinfo b/print/cups-base/distinfo
index d83e4247a852..f7ee87312eb9 100644
--- a/print/cups-base/distinfo
+++ b/print/cups-base/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cups-1.4.8-source.tar.bz2) = 6bd27e1213c139ed0bbadc5c29f97cf1e8f7f8f5b0bb29b227ecaff32aafa9a6
-SIZE (cups-1.4.8-source.tar.bz2) = 4547162
+SHA256 (cups-1.5.0-source.tar.bz2) = c6f99b68a558f4d626e9a5076d664f38e9925715dc541b07f0328c9aeb02ec33
+SIZE (cups-1.5.0-source.tar.bz2) = 4090210
diff --git a/print/cups-base/pkg-plist b/print/cups-base/pkg-plist
index ff7e60c60005..d4edfc9bb590 100644
--- a/print/cups-base/pkg-plist
+++ b/print/cups-base/pkg-plist
@@ -44,6 +44,7 @@ etc/cups/snmp.conf.N
bin/cancel
bin/cupstestdsc
bin/cupstestppd
+bin/ipptool
bin/lp
bin/lpoptions
bin/lppasswd
@@ -73,10 +74,11 @@ lib/libcupsppdc.so
lib/libcupsppdc.so.1
%%PHP%%lib/php/%%PHP_EXT_DIR%%/phpcups.so
libexec/cups/backend/http
+libexec/cups/backend/https
libexec/cups/backend/ipp
+libexec/cups/backend/ipps
libexec/cups/backend/lpd
libexec/cups/backend/parallel
-libexec/cups/backend/scsi
libexec/cups/backend/serial
libexec/cups/backend/snmp
libexec/cups/backend/socket
@@ -88,6 +90,7 @@ libexec/cups/cgi-bin/jobs.cgi
libexec/cups/cgi-bin/printers.cgi
libexec/cups/daemon/cups-deviced
libexec/cups/daemon/cups-driverd
+libexec/cups/daemon/cups-exec
libexec/cups/daemon/cups-lpd
libexec/cups/daemon/cups-polld
libexec/cups/filter/commandtoescpx
@@ -121,46 +124,7 @@ sbin/reject
%%DATADIR%%/banners/standard
%%DATADIR%%/banners/topsecret
%%DATADIR%%/banners/unclassified
-%%DATADIR%%/charmaps/euc-cn.txt
-%%DATADIR%%/charmaps/euc-jp.txt
-%%DATADIR%%/charmaps/euc-kr.txt
-%%DATADIR%%/charmaps/euc-tw.txt
-%%DATADIR%%/charmaps/iso-8859-1.txt
-%%DATADIR%%/charmaps/iso-8859-10.txt
-%%DATADIR%%/charmaps/iso-8859-11.txt
-%%DATADIR%%/charmaps/iso-8859-13.txt
-%%DATADIR%%/charmaps/iso-8859-14.txt
-%%DATADIR%%/charmaps/iso-8859-15.txt
-%%DATADIR%%/charmaps/iso-8859-16.txt
-%%DATADIR%%/charmaps/iso-8859-2.txt
-%%DATADIR%%/charmaps/iso-8859-3.txt
-%%DATADIR%%/charmaps/iso-8859-4.txt
-%%DATADIR%%/charmaps/iso-8859-5.txt
-%%DATADIR%%/charmaps/iso-8859-6.txt
-%%DATADIR%%/charmaps/iso-8859-7.txt
-%%DATADIR%%/charmaps/iso-8859-8.txt
-%%DATADIR%%/charmaps/iso-8859-9.txt
-%%DATADIR%%/charmaps/jis-x0213.txt
-%%DATADIR%%/charmaps/koi8-r.txt
-%%DATADIR%%/charmaps/koi8-u.txt
-%%DATADIR%%/charmaps/mac-roman.txt
-%%DATADIR%%/charmaps/windows-1250.txt
-%%DATADIR%%/charmaps/windows-1251.txt
-%%DATADIR%%/charmaps/windows-1252.txt
-%%DATADIR%%/charmaps/windows-1253.txt
-%%DATADIR%%/charmaps/windows-1254.txt
-%%DATADIR%%/charmaps/windows-1255.txt
-%%DATADIR%%/charmaps/windows-1256.txt
-%%DATADIR%%/charmaps/windows-1257.txt
-%%DATADIR%%/charmaps/windows-1258.txt
-%%DATADIR%%/charmaps/windows-1361.txt
-%%DATADIR%%/charmaps/windows-874.txt
-%%DATADIR%%/charmaps/windows-932.txt
-%%DATADIR%%/charmaps/windows-936.txt
-%%DATADIR%%/charmaps/windows-949.txt
-%%DATADIR%%/charmaps/windows-950.txt
%%DATADIR%%/charsets/utf-8
-%%DATADIR%%/data/HPGLprolog
%%DATADIR%%/data/psglyphs
%%DATADIR%%/data/testprint
%%DATADIR%%/drv/sample.drv
@@ -851,6 +815,8 @@ sbin/reject
%%DOCSDIR%%/help/man-cupstestdsc.html
%%DOCSDIR%%/help/man-cupstestppd.html
%%DOCSDIR%%/help/man-filter.html
+%%DOCSDIR%%/help/man-ipptool.html
+%%DOCSDIR%%/help/man-ipptoolfile.html
%%DOCSDIR%%/help/man-lp.html
%%DOCSDIR%%/help/man-lpadmin.html
%%DOCSDIR%%/help/man-lpc.html
@@ -923,6 +889,16 @@ sbin/reject
%%DOCSDIR%%/images/unsel.gif
%%DOCSDIR%%/images/wait.gif
%%DOCSDIR%%/index.html
+%%DATADIR%%/ipptool/create-printer-subscription.test
+%%DATADIR%%/ipptool/get-completed-jobs.test
+%%DATADIR%%/ipptool/get-jobs.test
+%%DATADIR%%/ipptool/ipp-1.1.test
+%%DATADIR%%/ipptool/ipp-2.0.test
+%%DATADIR%%/ipptool/ipp-2.1.test
+%%DATADIR%%/ipptool/testfile.jpg
+%%DATADIR%%/ipptool/testfile.pdf
+%%DATADIR%%/ipptool/testfile.ps
+%%DATADIR%%/ipptool/testfile.txt
%%DOCSDIR%%/it/index.html
%%DOCSDIR%%/ja/index.html
%%DOCSDIR%%/pl/index.html
@@ -968,6 +944,7 @@ share/locale/zh_TW/cups_zh_TW.po
@dirrm %%DOCSDIR%%/pl
@dirrm %%DOCSDIR%%/ja
@dirrm %%DOCSDIR%%/it
+@dirrm %%DATADIR%%/ipptool
@dirrm %%DOCSDIR%%/images
@dirrm %%DOCSDIR%%/id
@dirrm %%DOCSDIR%%/help
@@ -996,7 +973,6 @@ share/locale/zh_TW/cups_zh_TW.po
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%/drv
@dirrm %%DATADIR%%/charsets
-@dirrm %%DATADIR%%/charmaps
@dirrm %%DATADIR%%/banners
@dirrmtry %%DATADIR%%
@dirrm libexec/cups/notifier
diff --git a/print/cups-base/pkg-plist.image b/print/cups-base/pkg-plist.image
index efb4eb0e6d2e..07a786ab4c5d 100644
--- a/print/cups-base/pkg-plist.image
+++ b/print/cups-base/pkg-plist.image
@@ -5,7 +5,6 @@ lib/libcupsimage.so.2
libexec/cups/filter/bannertops
libexec/cups/filter/commandtops
libexec/cups/filter/gziptoany
-libexec/cups/filter/hpgltops
libexec/cups/filter/imagetops
libexec/cups/filter/imagetoraster
libexec/cups/filter/pstops
@@ -13,6 +12,7 @@ libexec/cups/filter/rastertodymo
libexec/cups/filter/rastertoepson
libexec/cups/filter/rastertohp
libexec/cups/filter/rastertolabel
+libexec/cups/filter/rastertopwg
libexec/cups/filter/texttops
@dirrm libexec/cups/filter
@dirrm libexec/cups