aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/opencv/Makefile2
-rw-r--r--math/py-python-fcl/Makefile8
2 files changed, 4 insertions, 6 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index f8a55ba52b0c..1163f5da2a2d 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -179,7 +179,7 @@ EXAMPLES_CMAKE_BOOL= INSTALL_C_EXAMPLES
PERFORMANCE_DESC= Performance enhancing libraries
EIGEN3_DESC= Eigen 3 support
-EIGEN3_BUILD_DEPENDS= ${LOCALBASE}/include/eigen3/Eigen/Eigen:math/eigen3
+EIGEN3_USES= eigen:3
EIGEN3_CMAKE_BOOL= WITH_EIGEN
OPENCL_DESC= OpenCL support
diff --git a/math/py-python-fcl/Makefile b/math/py-python-fcl/Makefile
index 266e2393c3a9..c4e0f60320de 100644
--- a/math/py-python-fcl/Makefile
+++ b/math/py-python-fcl/Makefile
@@ -12,14 +12,12 @@ COMMENT= Python bindings for the Flexible Collision Library
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-NEEDED_DEPENDS= ${PYNUMPY} \
- eigen>0:math/eigen3
LIB_DEPENDS= libfcl05.so:math/fcl05 \
liboctomap.so:math/octomap
-BUILD_DEPENDS= ${NEEDED_DEPENDS}
-RUN_DEPENDS= ${NEEDED_DEPENDS}
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY}
-USES= compiler:c++11-lang python
+USES= compiler:c++11-lang eigen:3 python
USE_PYTHON= distutils autoplist concurrent cython