aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libcrm114/Makefile35
-rw-r--r--textproc/libcrm114/distinfo2
-rw-r--r--textproc/libcrm114/files/patch-Makefile65
-rw-r--r--textproc/libcrm114/pkg-descr7
5 files changed, 110 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index df79bb4828d3..572a2e03889c 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -357,6 +357,7 @@
SUBDIR += lemmatizer
SUBDIR += lemmatizer2
SUBDIR += lexxia
+ SUBDIR += libcrm114
SUBDIR += libcroco
SUBDIR += libcsv
SUBDIR += libcue
diff --git a/textproc/libcrm114/Makefile b/textproc/libcrm114/Makefile
new file mode 100644
index 000000000000..862a224b06b6
--- /dev/null
+++ b/textproc/libcrm114/Makefile
@@ -0,0 +1,35 @@
+# Created: Martin Schuette <info@mschuette.name>
+# $FreeBSD$
+
+PORTNAME= libcrm114
+PORTVERSION= 20100726
+CATEGORIES= textproc
+MASTER_SITES= http://crm114.sourceforge.net/tarballs/
+
+MAINTAINER= info@mschuette.name
+COMMENT= CRM114 C-callable Library
+
+LIB_DEPENDS= tre:${PORTSDIR}/textproc/libtre
+
+LICENCE= LGPL3
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+# pass stuff to gmake
+CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -DNO_LOGL -DDO_INLINES
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_JOBS_UNSAFE=yes
+
+PLIST_FILES= lib/libcrm114.so \
+ lib/libcrm114.so.0 \
+ include/crm114_config.h \
+ include/crm114_lib.h \
+ include/crm114_structs.h \
+ include/crm114_sysincludes.h \
+ share/doc/libcrm114/HOWTO.txt \
+ share/doc/libcrm114/simple_demo.c
+PLIST_DIRS= share/doc/libcrm114
+
+.include <bsd.port.mk>
diff --git a/textproc/libcrm114/distinfo b/textproc/libcrm114/distinfo
new file mode 100644
index 000000000000..065911737053
--- /dev/null
+++ b/textproc/libcrm114/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libcrm114-20100726.tar.gz) = e37e74e61b960dee031b9a396d2d6a3b46ddc9a45d88eca1512d7de33eb03cc6
+SIZE (libcrm114-20100726.tar.gz) = 1573807
diff --git a/textproc/libcrm114/files/patch-Makefile b/textproc/libcrm114/files/patch-Makefile
new file mode 100644
index 000000000000..12e5b73d104d
--- /dev/null
+++ b/textproc/libcrm114/files/patch-Makefile
@@ -0,0 +1,65 @@
+--- Makefile.orig 2010-05-06 20:14:55.000000000 +0200
++++ Makefile 2012-05-19 21:10:00.000000000 +0200
+@@ -31,7 +31,7 @@
+ #CFLAGS += -O3 -DDO_INLINES
+ #
+ #GCC flags for debugging, no optimization
+-CFLAGS += -g
++#CFLAGS += -g
+ #
+ #GCC and LD flags for debugging, no optimization, and profile for speed
+ #CFLAGS += -g -pg
+@@ -45,6 +45,8 @@
+ CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wpointer-arith -Wstrict-prototypes
+ #well, pretty carefully
+ CFLAGS += -Wno-sign-compare -Wno-overlength-strings
++# to build shared library
++CFLAGS += -fPIC
+
+ #These are optional.
+
+@@ -97,8 +99,8 @@
+ crm114_util.o \
+ crm114_regex_tre.o
+
+-
+-all: test simple_demo
++# .tar.gz includes linux object files -- so clean first
++all: clean libcrm114.so test simple_demo
+
+ test: test.o libcrm114.a
+ $(CC) -o test $(LDFLAGS) -Wl,-M -Wl,--cref test.o libcrm114.a -ltre -lm >test.map
+@@ -115,6 +117,24 @@
+ libcrm114.a: $(LIBOBJS) Makefile
+ ar rc libcrm114.a $(LIBOBJS)
+
++# added for FreeBSD port patch
++libcrm114.so.0: $(LIBOBJS) Makefile
++ $(CC) -o libcrm114.so.0 -shared $(LIBOBJS)
++
++libcrm114.so: libcrm114.so.0
++ ln -fs libcrm114.so.0 libcrm114.so
++
++install: libcrm114.so.0
++ $(BSD_INSTALL_LIB) libcrm114.so.0 $(PREFIX)/lib
++ ln -fs libcrm114.so.0 $(PREFIX)/lib/libcrm114.so
++ $(BSD_INSTALL_DATA) crm114_config.h $(PREFIX)/include
++ $(BSD_INSTALL_DATA) crm114_lib.h $(PREFIX)/include
++ $(BSD_INSTALL_DATA) crm114_structs.h $(PREFIX)/include
++ $(BSD_INSTALL_DATA) crm114_sysincludes.h $(PREFIX)/include
++ $(BSD_INSTALL_DATA) -d $(PREFIX)/share/doc/libcrm114
++ $(BSD_INSTALL_DATA) HOWTO.txt $(PREFIX)/share/doc/libcrm114
++ $(BSD_INSTALL_DATA) simple_demo.c $(PREFIX)/share/doc/libcrm114
++
+ $(LIBOBJS): $(LIBHDRS)
+
+ clean: clean_test clean_simple_demo clean_lib clean_profiling
+@@ -126,7 +146,7 @@
+ rm -f simple_demo simple_demo.map simple_demo.o simple_demo_datablock.txt
+
+ clean_lib:
+- rm -f libcrm114.a $(LIBOBJS)
++ rm -f libcrm114.a libcrm114.so $(LIBOBJS)
+
+ clean_profiling:
+ rm -f gmon.out *.gcov *.gcno *.gcda
diff --git a/textproc/libcrm114/pkg-descr b/textproc/libcrm114/pkg-descr
new file mode 100644
index 000000000000..ec13ddac6d37
--- /dev/null
+++ b/textproc/libcrm114/pkg-descr
@@ -0,0 +1,7 @@
+This is the callable library version of CRM114. It has most of the classifiers
+as the standalone language. This version is LGPLed (Library GPL) so you can
+link it with your own code, whether open-source or proprietary.
+You still need TRE. Note that with improvements come costs:
+libcrm114 classifiers are NOT compatible with standalone CRM114 class files.
+
+WWW: http://crm114.sourceforge.net/