aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/xfce4-weather-plugin/Makefile3
-rw-r--r--misc/xfce4-weather-plugin/distinfo6
-rw-r--r--misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c33
-rw-r--r--misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.h10
4 files changed, 4 insertions, 48 deletions
diff --git a/misc/xfce4-weather-plugin/Makefile b/misc/xfce4-weather-plugin/Makefile
index 6b700fd157cb..18a570b5376d 100644
--- a/misc/xfce4-weather-plugin/Makefile
+++ b/misc/xfce4-weather-plugin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-weather-plugin
-PORTVERSION= 0.10.0
-PORTREVISION= 1
+PORTVERSION= 0.10.1
CATEGORIES= misc xfce geography
MASTER_SITES= XFCE/panel-plugins
DIST_SUBDIR= xfce4
diff --git a/misc/xfce4-weather-plugin/distinfo b/misc/xfce4-weather-plugin/distinfo
index 83eb76a346c6..cd0fc4b09ac5 100644
--- a/misc/xfce4-weather-plugin/distinfo
+++ b/misc/xfce4-weather-plugin/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1565601326
-SHA256 (xfce4/xfce4-weather-plugin-0.10.0.tar.bz2) = 4423a0c27830fd1f08e063aaefbf70f31d89235d75549ca841d677ab2e409572
-SIZE (xfce4/xfce4-weather-plugin-0.10.0.tar.bz2) = 3032575
+TIMESTAMP = 1582560801
+SHA256 (xfce4/xfce4-weather-plugin-0.10.1.tar.bz2) = afb2af5f3effc2ea6181636ed0e82e6dafd556ec1b8478100802f85a5d167a89
+SIZE (xfce4/xfce4-weather-plugin-0.10.1.tar.bz2) = 3026945
diff --git a/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c b/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c
deleted file mode 100644
index a2fa2abc3f7c..000000000000
--- a/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- panel-plugin/weather.c.orig 2019-08-11 19:23:40 UTC
-+++ panel-plugin/weather.c
-@@ -588,6 +588,7 @@ cb_weather_update(SoupSession *session,
- static gboolean
- update_handler(plugin_data *data)
- {
-+ gchar *api_version = FORECAST_API;
- gchar *url;
- gboolean night_time;
- time_t now_t;
-@@ -653,9 +654,10 @@ update_handler(plugin_data *data)
- data->weather_update->started = TRUE;
-
- /* build url */
-- url = g_strdup_printf("https://api.met.no/weatherapi"
-- "/locationforecastlts/1.3/?lat=%s&lon=%s&"
-- "msl=%d",
-+ url = g_strdup_printf("https://api.met.no"
-+ "/weatherapi/locationforecast/%s/"
-+ "?lat=%s&lon=%s&msl=%d",
-+ api_version,
- data->lat, data->lon, data->msl);
-
- /* start receive thread */
-@@ -1928,7 +1930,7 @@ xfceweather_create_control(XfcePanelPlugin *plugin)
- data->labels = g_array_new(FALSE, TRUE, sizeof(data_types));
-
- /* create panel toggle button which will contain all other widgets */
-- data->button = xfce_create_panel_toggle_button();
-+ data->button = xfce_panel_create_toggle_button();
- gtk_container_add(GTK_CONTAINER(plugin), data->button);
- xfce_panel_plugin_add_action_widget(plugin, data->button);
- gtk_widget_show(data->button);
diff --git a/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.h b/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.h
deleted file mode 100644
index 923c83960650..000000000000
--- a/misc/xfce4-weather-plugin/files/patch-panel-plugin_weather.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- panel-plugin/weather.h.orig 2019-08-11 19:23:40 UTC
-+++ panel-plugin/weather.h
-@@ -31,6 +31,7 @@
- #define MAX_FORECAST_DAYS 10
- #define DEFAULT_FORECAST_DAYS 5
- #define MAX_SCROLLBOX_LINES 10
-+#define FORECAST_API "1.9"
-
- G_BEGIN_DECLS
-