aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/nagios-check_smartmon/Makefile25
-rw-r--r--net-mgmt/nagios-check_smartmon/distinfo3
-rw-r--r--net-mgmt/nagios-check_smartmon/pkg-descr2
-rw-r--r--net-mgmt/nagios-check_smartmon/pkg-plist2
5 files changed, 33 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index f029ba3db92f..4cb04b4be8df 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -111,6 +111,7 @@
SUBDIR += nagios-check_clamav
SUBDIR += nagios-check_ports
SUBDIR += nagios-check_puppet
+ SUBDIR += nagios-check_smartmon
SUBDIR += nagios-devel
SUBDIR += nagios-geom
SUBDIR += nagios-pf-plugin
diff --git a/net-mgmt/nagios-check_smartmon/Makefile b/net-mgmt/nagios-check_smartmon/Makefile
new file mode 100644
index 000000000000..97d41c8db512
--- /dev/null
+++ b/net-mgmt/nagios-check_smartmon/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: nagios-check_smartmon
+# Date created: 2009-07-10
+# Whom: steinex
+#
+# $FreeBSD$
+
+PORTNAME= check_smartmon
+PORTVERSION= 20060324
+CATEGORIES= net-mgmt
+MASTER_SITES= http://nognu.de/s/FreeBSD/distfiles/
+PKGNAMEPREFIX= nagios-
+
+MAINTAINER= steinex@nognu.de
+COMMENT= Nagios plug-in to get status from smartmontools
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/smartctl:${PORTSDIR}/sysutils/smartmontools
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_smartmon ${PREFIX}/libexec/nagios
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-check_smartmon/distinfo b/net-mgmt/nagios-check_smartmon/distinfo
new file mode 100644
index 000000000000..ed195f15faf4
--- /dev/null
+++ b/net-mgmt/nagios-check_smartmon/distinfo
@@ -0,0 +1,3 @@
+MD5 (check_smartmon-20060324.tar.gz) = cd6ae86cc3eeff96c87d0d7e22fa761e
+SHA256 (check_smartmon-20060324.tar.gz) = e08b52a0bb5455a4dc00707e91a46328743ea04539f7911fec9d971c51f7a52d
+SIZE (check_smartmon-20060324.tar.gz) = 2668
diff --git a/net-mgmt/nagios-check_smartmon/pkg-descr b/net-mgmt/nagios-check_smartmon/pkg-descr
new file mode 100644
index 000000000000..44549179e017
--- /dev/null
+++ b/net-mgmt/nagios-check_smartmon/pkg-descr
@@ -0,0 +1,2 @@
+check_smartmon is a Nagios plug-in written in python that uses
+smartmontools to check disk health status and temperature.
diff --git a/net-mgmt/nagios-check_smartmon/pkg-plist b/net-mgmt/nagios-check_smartmon/pkg-plist
new file mode 100644
index 000000000000..69178cef66f9
--- /dev/null
+++ b/net-mgmt/nagios-check_smartmon/pkg-plist
@@ -0,0 +1,2 @@
+libexec/nagios/check_smartmon
+@dirrmtry libexec/nagios