aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--java/eclipse-webtools/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/java/eclipse-webtools/Makefile b/java/eclipse-webtools/Makefile
index 8ebf0226ace4..edf486b4f420 100644
--- a/java/eclipse-webtools/Makefile
+++ b/java/eclipse-webtools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= webtools
PORTVERSION= 2.0.3
+PORTREVISION= 1
CATEGORIES= java devel www
MASTER_SITES= ${MASTER_SITE_ECLIPSE:S,/eclipse/downloads/drops/,/webtools/downloads/drops/,}
MASTER_SITE_SUBDIR= R2.0/R-${PORTVERSION}-20080710044639/
@@ -21,8 +22,6 @@ RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
${LOCALBASE}/eclipse/features/org.eclipse.emf_2.3.2.v200802051830/feature.xml:${PORTSDIR}/java/eclipse-emf \
${LOCALBASE}/eclipse/features/org.eclipse.gef_3.3.2.v20080129/feature.xml:${PORTSDIR}/java/eclipse-gef
-BROKEN= deletes files installed by dependency on deinstall
-
CONFLICTS= eclipse-lomboz-3.*
NO_BUILD= yes
@@ -32,6 +31,18 @@ USE_JAVA= yes
JAVA_VERSION= 1.5+
JAVA_OS= native
+# remove files that already exist on the RUN_DEPENDS java/eclipse port
+REMOVE_DUPLICATE_FILES= \
+ eclipse/plugins/javax.servlet.jsp_2.0.0.v200706191603.jar \
+ eclipse/plugins/javax.servlet_2.4.0.v200706111738.jar \
+ eclipse/plugins/org.apache.commons.el_1.0.0.v200706111724.jar \
+ eclipse/plugins/org.apache.commons.logging_1.0.4.v200706111724.jar
+
+post-extract:
+.for file in ${REMOVE_DUPLICATE_FILES}
+ @${RM} -f ${WRKSRC}/${file}
+.endfor
+
do-install:
@${MKDIR} ${PREFIX}/eclipse
@${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse