aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING18
-rw-r--r--ports-mgmt/portsnap/Makefile12
-rw-r--r--ports-mgmt/portsnap/distinfo4
-rw-r--r--ports-mgmt/portsnap/pkg-message9
-rw-r--r--sysutils/portsnap/Makefile12
-rw-r--r--sysutils/portsnap/distinfo4
-rw-r--r--sysutils/portsnap/pkg-message9
7 files changed, 48 insertions, 20 deletions
diff --git a/UPDATING b/UPDATING
index 89d135a3b733..bbcefd5c5f49 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,24 @@ You should get into the habit of checking this file for changes each
time you update your ports collection, before attempting any port
upgrades.
+20050320:
+ AFFECTS: users of sysutils/portsnap
+ AUTHOR: cperciva@FreeBSD.org
+
+ As a result of shifting from SHA-1 to SHA-256, the structure of
+ portsnap's configuration file and compressed snapshot have both
+ changed. After upgrading to portsnap 0.9, you will have to
+ update your configuration file ($PREFIX/etc/portsnap.conf) and
+ delete your existing portsnap compressed snapshot:
+
+ # cd /usr/local/etc && cp portsnap.conf.sample portsnap.conf
+ # rm -r /usr/local/portsnap/*
+
+ In addition, be aware that the next runs of "portsnap fetch" and
+ "portsnap update" will take far longer than usual, since they
+ will need to download and extract a complete copy of the ports
+ tree.
+
20050319:
AFFECTS: users of databases/postgresql7[34]-server
AUTHOR: girgen@FreeBSD.org
diff --git a/ports-mgmt/portsnap/Makefile b/ports-mgmt/portsnap/Makefile
index 01b2a5dd3a49..e0756ecc9cb7 100644
--- a/ports-mgmt/portsnap/Makefile
+++ b/ports-mgmt/portsnap/Makefile
@@ -6,26 +6,25 @@
#
PORTNAME= portsnap
-PORTVERSION= 0.3.1
+PORTVERSION= 0.9
CATEGORIES= sysutils net
MASTER_SITES= http://www.daemonology.net/portsnap/
MAINTAINER= cperciva@daemonology.net
COMMENT= Provides secure snapshots of the ports directory
-RUN_DEPENDS= bspatch:${PORTSDIR}/misc/bsdiff \
- freebsd-update-verify:${PORTSDIR}/security/freebsd-update
+RUN_DEPENDS= bspatch:${PORTSDIR}/misc/bsdiff
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 491101 || ( ${OSVERSION} > 499999 && ${OSVERSION} < 502114 )
-RUN_DEPENDS+= sha1:${PORTSDIR}/sysutils/freebsd-sha1
+.if ${OSVERSION} < 600021
+RUN_DEPENDS+= sha256:${PORTSDIR}/sysutils/freebsd-sha256
.endif
MAN5= portsnap.conf.5
MAN8= portsnap.8
PLIST_FILES= etc/portsnap.conf.sample sbin/portsnap \
- portsnap/.package.this.directory
+ libexec/make_index portsnap/.package.this.directory
PLIST_DIRS= portsnap
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -39,6 +38,7 @@ post-extract:
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/portsnap ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/make_index ${PREFIX}/libexec
${INSTALL_MAN} ${WRKSRC}/portsnap.conf.5 ${PREFIX}/man/man5/
${INSTALL_MAN} ${WRKSRC}/portsnap.8 ${PREFIX}/man/man8/
${INSTALL_DATA} ${WRKSRC}/portsnap.conf \
diff --git a/ports-mgmt/portsnap/distinfo b/ports-mgmt/portsnap/distinfo
index e112c5f3d0f6..0cf6600b59ac 100644
--- a/ports-mgmt/portsnap/distinfo
+++ b/ports-mgmt/portsnap/distinfo
@@ -1,2 +1,2 @@
-MD5 (portsnap-0.3.1.tar.gz) = e5fe823c977d016e4891d882b0ddf0f0
-SIZE (portsnap-0.3.1.tar.gz) = 7626
+MD5 (portsnap-0.9.tar.gz) = dd7471355f4cb7027412f67e6575f5ca
+SIZE (portsnap-0.9.tar.gz) = 12214
diff --git a/ports-mgmt/portsnap/pkg-message b/ports-mgmt/portsnap/pkg-message
index 4bd5cc90c830..519591ac4336 100644
--- a/ports-mgmt/portsnap/pkg-message
+++ b/ports-mgmt/portsnap/pkg-message
@@ -1,7 +1,7 @@
Before you can use portsnap, you will have to create an update configuration
-file specifying the server from which to fetch snapshots and the sha1 hash
-of the RSA public key which is trusted to sign the snapshots.
+file specifying the server from which to fetch snapshots and the sha256 hash
+of the openssl public key which is trusted to sign the snapshots.
A sample configuration file has been installed in
@@ -13,3 +13,8 @@ use these updates, copy that file to
%%PREFIX%%/etc/portsnap.conf
otherwise, create that file as appropriate.
+
+NOTE TO USERS UPGRADING FROM PORTSNAP 0.3.1 OR EARLIER: The structure
+of the portsnap configuration file has changed; you will have to replace
+your existing portsnap.conf with a new version.
+
diff --git a/sysutils/portsnap/Makefile b/sysutils/portsnap/Makefile
index 01b2a5dd3a49..e0756ecc9cb7 100644
--- a/sysutils/portsnap/Makefile
+++ b/sysutils/portsnap/Makefile
@@ -6,26 +6,25 @@
#
PORTNAME= portsnap
-PORTVERSION= 0.3.1
+PORTVERSION= 0.9
CATEGORIES= sysutils net
MASTER_SITES= http://www.daemonology.net/portsnap/
MAINTAINER= cperciva@daemonology.net
COMMENT= Provides secure snapshots of the ports directory
-RUN_DEPENDS= bspatch:${PORTSDIR}/misc/bsdiff \
- freebsd-update-verify:${PORTSDIR}/security/freebsd-update
+RUN_DEPENDS= bspatch:${PORTSDIR}/misc/bsdiff
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 491101 || ( ${OSVERSION} > 499999 && ${OSVERSION} < 502114 )
-RUN_DEPENDS+= sha1:${PORTSDIR}/sysutils/freebsd-sha1
+.if ${OSVERSION} < 600021
+RUN_DEPENDS+= sha256:${PORTSDIR}/sysutils/freebsd-sha256
.endif
MAN5= portsnap.conf.5
MAN8= portsnap.8
PLIST_FILES= etc/portsnap.conf.sample sbin/portsnap \
- portsnap/.package.this.directory
+ libexec/make_index portsnap/.package.this.directory
PLIST_DIRS= portsnap
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -39,6 +38,7 @@ post-extract:
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/portsnap ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/make_index ${PREFIX}/libexec
${INSTALL_MAN} ${WRKSRC}/portsnap.conf.5 ${PREFIX}/man/man5/
${INSTALL_MAN} ${WRKSRC}/portsnap.8 ${PREFIX}/man/man8/
${INSTALL_DATA} ${WRKSRC}/portsnap.conf \
diff --git a/sysutils/portsnap/distinfo b/sysutils/portsnap/distinfo
index e112c5f3d0f6..0cf6600b59ac 100644
--- a/sysutils/portsnap/distinfo
+++ b/sysutils/portsnap/distinfo
@@ -1,2 +1,2 @@
-MD5 (portsnap-0.3.1.tar.gz) = e5fe823c977d016e4891d882b0ddf0f0
-SIZE (portsnap-0.3.1.tar.gz) = 7626
+MD5 (portsnap-0.9.tar.gz) = dd7471355f4cb7027412f67e6575f5ca
+SIZE (portsnap-0.9.tar.gz) = 12214
diff --git a/sysutils/portsnap/pkg-message b/sysutils/portsnap/pkg-message
index 4bd5cc90c830..519591ac4336 100644
--- a/sysutils/portsnap/pkg-message
+++ b/sysutils/portsnap/pkg-message
@@ -1,7 +1,7 @@
Before you can use portsnap, you will have to create an update configuration
-file specifying the server from which to fetch snapshots and the sha1 hash
-of the RSA public key which is trusted to sign the snapshots.
+file specifying the server from which to fetch snapshots and the sha256 hash
+of the openssl public key which is trusted to sign the snapshots.
A sample configuration file has been installed in
@@ -13,3 +13,8 @@ use these updates, copy that file to
%%PREFIX%%/etc/portsnap.conf
otherwise, create that file as appropriate.
+
+NOTE TO USERS UPGRADING FROM PORTSNAP 0.3.1 OR EARLIER: The structure
+of the portsnap configuration file has changed; you will have to replace
+your existing portsnap.conf with a new version.
+