aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/R-cran-purrr/Makefile23
-rw-r--r--devel/R-cran-purrr/distinfo3
-rw-r--r--devel/R-cran-purrr/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e2a81b4dc0d3..682dfa90abe2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -45,6 +45,7 @@
SUBDIR += R-cran-plyr
SUBDIR += R-cran-praise
SUBDIR += R-cran-proto
+ SUBDIR += R-cran-purrr
SUBDIR += R-cran-randomForest
SUBDIR += R-cran-registry
SUBDIR += R-cran-repr
diff --git a/devel/R-cran-purrr/Makefile b/devel/R-cran-purrr/Makefile
new file mode 100644
index 000000000000..2d8ec5aa2f00
--- /dev/null
+++ b/devel/R-cran-purrr/Makefile
@@ -0,0 +1,23 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= purrr
+PORTVERSION= 0.2.3
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Functional Programming Tools
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+CRAN_DEPENDS= R-cran-magrittr>=1.5:devel/R-cran-magrittr \
+ R-cran-tibble>0:devel/R-cran-tibble \
+ R-cran-rlang>=0.1:devel/R-cran-rlang
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= cran:auto-plist,compiles
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-purrr/distinfo b/devel/R-cran-purrr/distinfo
new file mode 100644
index 000000000000..261970d96f5a
--- /dev/null
+++ b/devel/R-cran-purrr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1504623721
+SHA256 (purrr_0.2.3.tar.gz) = aace6ae2f3429d0e453bfa73c02f6c5133aaff5a9cb0f860d29149ba97053e48
+SIZE (purrr_0.2.3.tar.gz) = 126170
diff --git a/devel/R-cran-purrr/pkg-descr b/devel/R-cran-purrr/pkg-descr
new file mode 100644
index 000000000000..a2a7b9ed4ee4
--- /dev/null
+++ b/devel/R-cran-purrr/pkg-descr
@@ -0,0 +1,3 @@
+A complete and consistent functional programming toolkit for R.
+
+WWW: https://cran.r-project.org/web/packages/purrr/