aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rtfx/Makefile29
-rw-r--r--textproc/rtfx/distinfo2
-rw-r--r--textproc/rtfx/files/extra-patch-src::domhelpers.h-gcc29518
-rw-r--r--textproc/rtfx/pkg-descr11
-rw-r--r--textproc/rtfx/pkg-plist1
6 files changed, 62 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index bfb2131539d5..55baf7d07da7 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -493,6 +493,7 @@
SUBDIR += rot
SUBDIR += rotix
SUBDIR += rtfreader
+ SUBDIR += rtfx
SUBDIR += rubber
SUBDIR += ruby-amatch
SUBDIR += ruby-amrita
diff --git a/textproc/rtfx/Makefile b/textproc/rtfx/Makefile
new file mode 100644
index 000000000000..c1ff42c24397
--- /dev/null
+++ b/textproc/rtfx/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: rtfx
+# Date created: 2004-07-29
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rtfx
+PORTVERSION= 0.9.3
+CATEGORIES= textproc
+MASTER_SITES= http://memberwebs.com/nielsen/software/rtfx/
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= An RTF to XML converter
+
+LIB_DEPENDS= sablot.70:${PORTSDIR}/textproc/sablotron
+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN1= rtfx.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} <= 500035
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src::domhelpers.h-gcc295
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/rtfx/distinfo b/textproc/rtfx/distinfo
new file mode 100644
index 000000000000..a8180c5681ad
--- /dev/null
+++ b/textproc/rtfx/distinfo
@@ -0,0 +1,2 @@
+MD5 (rtfx-0.9.3.tar.gz) = da6f3c89e70a3f7e51188438dbf633f9
+SIZE (rtfx-0.9.3.tar.gz) = 350221
diff --git a/textproc/rtfx/files/extra-patch-src::domhelpers.h-gcc295 b/textproc/rtfx/files/extra-patch-src::domhelpers.h-gcc295
new file mode 100644
index 000000000000..bbdf15cc1325
--- /dev/null
+++ b/textproc/rtfx/files/extra-patch-src::domhelpers.h-gcc295
@@ -0,0 +1,18 @@
+--- src/domhelpers.h.orig Sun Jul 25 06:37:15 2004
++++ src/domhelpers.h Thu Jul 29 07:56:00 2004
+@@ -44,6 +44,15 @@
+ #include <stack>
+ #include <set>
+
++template <class _Category, class _Tp, class _Distance = ptrdiff_t,
++ class _Pointer = _Tp*, class _Reference = _Tp&>
++struct iterator {
++typedef _Category iterator_category;
++typedef _Tp value_type;
++typedef _Distance difference_type;
++typedef _Pointer pointer;
++typedef _Reference reference;
++};
+ /*
+ * DOMHelpers
+ *
diff --git a/textproc/rtfx/pkg-descr b/textproc/rtfx/pkg-descr
new file mode 100644
index 000000000000..a3180e72f3ac
--- /dev/null
+++ b/textproc/rtfx/pkg-descr
@@ -0,0 +1,11 @@
+rtfx converts RTF files into a generic XML format. It majors on keeping
+meta data like style names, etc... rather than every bit of formatting.
+This makes it handy for converting RTF documents into a custom XML
+format (using XSL or an additional processing step).
+
+RTF features supported: page breaks, section breaks, style names,
+lists (various types), tables, footnotes, info block, bold, italic,
+underline, super/sub script, hidden text, strike out, text color, fonts.
+
+Author: Nielsen <nielsen at memberwebs.com>
+WWW: http://memberwebs.com/nielsen/software/rtfx/
diff --git a/textproc/rtfx/pkg-plist b/textproc/rtfx/pkg-plist
new file mode 100644
index 000000000000..d7fd1e655e9d
--- /dev/null
+++ b/textproc/rtfx/pkg-plist
@@ -0,0 +1 @@
+bin/rtfx