aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/python.mk10
-rw-r--r--biology/bcftools/Makefile3
-rw-r--r--biology/samtools/Makefile3
-rw-r--r--security/metasploit/Makefile3
4 files changed, 13 insertions, 6 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 0c6730cbf32f..86d2defec52a 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -28,6 +28,11 @@
# it to RUN_DEPENDS.
# test Indicates that Python is needed at test time and adds
# it to TEST_DEPENDS.
+# env Indicates that the port does not require a dependency on Python
+# itself but needs the environment set up. This is mainly used
+# when depending on flavored python ports, or when a correct
+# PYTHON_CMD is required. It has the same effect than setting
+# PYTHON_NO_DEPENDS.
#
# If build, run and test are omitted, Python will be added as BUILD_DEPENDS,
# RUN_DEPENDS and TEST_DEPENDS. PYTHON_NO_DEPENDS can be set to not add any
@@ -282,6 +287,11 @@ _PYTHON_ARGS:= ${_PYTHON_ARGS:Nrun}
_PYTHON_TEST_DEP= yes
_PYTHON_ARGS:= ${_PYTHON_ARGS:Ntest}
.endif
+.if ${_PYTHON_ARGS:Menv}
+PYTHON_NO_DEPENDS= yes
+_PYTHON_ARGS:= ${_PYTHON_ARGS:Nenv}
+.endif
+.endif
# The port does not specify a build, run or test dependency, assume all are
# required.
diff --git a/biology/bcftools/Makefile b/biology/bcftools/Makefile
index 7f3f88d1a42c..de067fb8093b 100644
--- a/biology/bcftools/Makefile
+++ b/biology/bcftools/Makefile
@@ -20,9 +20,8 @@ CONFLICTS_BUILD=openssl
USE_GITHUB= yes
GH_ACCOUNT= samtools
-USES= autoreconf gmake perl5 python shebangfix
+USES= autoreconf gmake perl5 python:env shebangfix
USE_PERL5= test
-PYTHON_NO_DEPENDS= yes
GNU_CONFIGURE= yes
SUB_FILES= pkg-message
SHEBANG_FILES= misc/* test/test.pl
diff --git a/biology/samtools/Makefile b/biology/samtools/Makefile
index da12548a1714..c8e8578e92f7 100644
--- a/biology/samtools/Makefile
+++ b/biology/samtools/Makefile
@@ -17,9 +17,8 @@ TEST_DEPENDS= bash:shells/bash
USE_GITHUB= yes
-USES= autoreconf gmake ncurses perl5 python shebangfix
+USES= autoreconf gmake ncurses perl5 python:env shebangfix
USE_PERL5= test
-PYTHON_NO_DEPENDS= yes
GNU_CONFIGURE= yes
SUB_FILES= pkg-message
SHEBANG_FILES= misc/*.pl misc/*.py misc/plot-bamstats test/test.pl
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index 0e689b5df08d..e1d73b04b6ad 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -86,9 +86,8 @@ NO_ARCH= yes
NO_ARCH_IGNORE= template_x64_bsd.bin template_x86_bsd.bin CVE-2013-2171.bin
STRIP=
-USES= python shebangfix
+USES= python:env shebangfix
USE_RUBY= yes
-PYTHON_NO_DEPENDS= yes
SHEBANG_FILES= data/exploits/CVE-2017-7494/build.sh \
data/exploits/CVE-2017-7494/install-deps.sh \
external/source/shellcode/windows/build.sh \