aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--benchmarks/p5-Benchmark-Forking/Makefile3
-rw-r--r--devel/p5-Benchmark-Timer/Makefile3
-rw-r--r--devel/p5-File-Append-TempFile/Makefile3
-rw-r--r--devel/stlfilt/Makefile3
-rw-r--r--mail/p5-Net-SMTP-SSL/Makefile3
-rw-r--r--math/p5-Math-Round/Makefile3
-rw-r--r--net-mgmt/p5-Net-IP/Makefile3
-rw-r--r--sysutils/stalepid/Makefile3
-rw-r--r--textproc/p5-Time-Human/Makefile3
9 files changed, 18 insertions, 9 deletions
diff --git a/benchmarks/p5-Benchmark-Forking/Makefile b/benchmarks/p5-Benchmark-Forking/Makefile
index dc388591e3c9..ca8ebb251cd5 100644
--- a/benchmarks/p5-Benchmark-Forking/Makefile
+++ b/benchmarks/p5-Benchmark-Forking/Makefile
@@ -12,7 +12,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= eadler@FreeBSD.org
COMMENT= Run benchmarks in separate processes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Benchmark::Forking.3
diff --git a/devel/p5-Benchmark-Timer/Makefile b/devel/p5-Benchmark-Timer/Makefile
index a4344f73b569..0f1ec36829f5 100644
--- a/devel/p5-Benchmark-Timer/Makefile
+++ b/devel/p5-Benchmark-Timer/Makefile
@@ -14,7 +14,8 @@ LICENSE= GPLv2
BUILD_DEPENDS= p5-Module-Install>0:${PORTSDIR}/devel/p5-Module-Install
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Benchmark::Timer.3 Benchmark::delta.3
diff --git a/devel/p5-File-Append-TempFile/Makefile b/devel/p5-File-Append-TempFile/Makefile
index 1f494286f6b4..c0a760311236 100644
--- a/devel/p5-File-Append-TempFile/Makefile
+++ b/devel/p5-File-Append-TempFile/Makefile
@@ -13,7 +13,8 @@ COMMENT= Append data to files using a temporary copy
TEST_DEPENDS= p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= File::Append::TempFile.3
diff --git a/devel/stlfilt/Makefile b/devel/stlfilt/Makefile
index f225af5e2086..db9788bb01b6 100644
--- a/devel/stlfilt/Makefile
+++ b/devel/stlfilt/Makefile
@@ -11,10 +11,11 @@ EXTRACT_SUFX= .tar
MAINTAINER= eadler@FreeBSD.org
COMMENT= STL Error Message Decryptor for C++
+USES= perl5
EXTRACT_CMD= ${TAR}
EXTRACT_BEFORE_ARGS= -xf
EXTRACT_AFTER_ARGS= # empty
-USE_PERL5_RUN= yes
+USE_PERL5= run
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/mail/p5-Net-SMTP-SSL/Makefile b/mail/p5-Net-SMTP-SSL/Makefile
index ac5f8198abad..70069e95c293 100644
--- a/mail/p5-Net-SMTP-SSL/Makefile
+++ b/mail/p5-Net-SMTP-SSL/Makefile
@@ -12,7 +12,8 @@ COMMENT= SMTP client supporting SSL
BUILD_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::SMTP::SSL.3
diff --git a/math/p5-Math-Round/Makefile b/math/p5-Math-Round/Makefile
index c84c106c7bd8..114f97f0a143 100644
--- a/math/p5-Math-Round/Makefile
+++ b/math/p5-Math-Round/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= eadler@FreeBSD.org
COMMENT= Perl extension for rounding numbers
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Math::Round.3
diff --git a/net-mgmt/p5-Net-IP/Makefile b/net-mgmt/p5-Net-IP/Makefile
index e9c7ef73c650..4dc3a5101411 100644
--- a/net-mgmt/p5-Net-IP/Makefile
+++ b/net-mgmt/p5-Net-IP/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= eadler@FreeBSD.org
COMMENT= Perl extension for manipulating IPv4/IPv6 addresses
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::IP.3
diff --git a/sysutils/stalepid/Makefile b/sysutils/stalepid/Makefile
index 6b6462ad8142..b1138ddcadaa 100644
--- a/sysutils/stalepid/Makefile
+++ b/sysutils/stalepid/Makefile
@@ -12,7 +12,8 @@ COMMENT= Check for stale pid files and remove them
RUN_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/textproc/p5-Time-Human/Makefile b/textproc/p5-Time-Human/Makefile
index 3a5b3edc54a5..7ffaaac87de0 100644
--- a/textproc/p5-Time-Human/Makefile
+++ b/textproc/p5-Time-Human/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= eadler@FreeBSD.org
COMMENT= Convert localtime() format to "speaking clock" time
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Time::Human.3