aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/geary/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/mail/geary/Makefile b/mail/geary/Makefile
index ea162f75f24d..da389ca0ffa8 100644
--- a/mail/geary/Makefile
+++ b/mail/geary/Makefile
@@ -11,6 +11,9 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Mail client for GNOME 3
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= vapigen:lang/vala \
bash:shells/bash
LIB_DEPENDS= libgmime-2.6.so:mail/gmime26 \
@@ -21,19 +24,17 @@ LIB_DEPENDS= libgmime-2.6.so:mail/gmime26 \
libgcr-3.so:security/gcr
USES= cmake desktop-file-utils gettext \
- libtool pkgconfig shebangfix tar:xz
+ libtool localbase:ldflags pkgconfig shebangfix tar:xz
USE_GNOME= gnomedocutils gnomeprefix gtk30 intlhack
SHEBANG_FILES= desktop/geary-attach
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
CMAKE_ARGS= -DNO_FATAL_WARNINGS:BOOL=ON
GLIB_SCHEMAS= org.yorba.geary.gschema.xml
post-patch:
- @${REINPLACE_CMD} -e 's|abort $$option||g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|abort $$option||g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>