aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/gcpio/Makefile10
-rw-r--r--archivers/gtar/Makefile14
-rw-r--r--archivers/xz/Makefile4
-rw-r--r--audio/flac/Makefile19
-rw-r--r--audio/libogg/Makefile14
-rw-r--r--audio/libvorbis/Makefile14
-rw-r--r--audio/vorbis-tools/Makefile10
-rw-r--r--audio/xmms-shn/Makefile10
-rw-r--r--audio/xmms-xf86audio/Makefile4
9 files changed, 49 insertions, 50 deletions
diff --git a/archivers/gcpio/Makefile b/archivers/gcpio/Makefile
index 67633ed95779..b624f80be354 100644
--- a/archivers/gcpio/Makefile
+++ b/archivers/gcpio/Makefile
@@ -18,7 +18,12 @@ CONFIGURE_ARGS= --program-prefix=g \
--disable-silent-rules \
--with-rmt=/etc/rmt
-.if !defined(WITHOUT_NLS)
+INFO= cpio
+MAN1= gcpio.1
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CONFIGURE_ARGS+=--with-libintl-prefix="${LOCALBASE}"
@@ -27,9 +32,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-INFO= cpio
-MAN1= gcpio.1
-
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
diff --git a/archivers/gtar/Makefile b/archivers/gtar/Makefile
index e576eb1be08c..a44b733892c3 100644
--- a/archivers/gtar/Makefile
+++ b/archivers/gtar/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gtar
-# Date created: Sa 6 Jun 1998 10:24:51 CEST
-# Whom: Andreas Klemm <andreas@klemm.gtn.com>
-#
+# Created by: Andreas Klemm <andreas@klemm.gtn.com>
# $FreeBSD$
-#
PORTNAME= tar
PORTVERSION= 1.26
@@ -32,14 +28,18 @@ LDFLAGS+= -L${LOCALBASE}/lib ${LDSTATIC}
CONFIGURE_ENV= DEFAULT_ARCHIVE=/dev/sa0 \
DEFAULT_RMT_COMMAND=/etc/rmt
-.if defined(WANT_STATIC)
+OPTIONS_DEFINE= STATIC
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSTATIC}
LDSTATIC= -static
MAKE_ARGS+= LIBINTL='$$(LTLIBINTL)' LIBICONV='$$(LTLIBICONV)'
.else
LDSTATIC=
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
diff --git a/archivers/xz/Makefile b/archivers/xz/Makefile
index d7242c9022b5..e30092e755a3 100644
--- a/archivers/xz/Makefile
+++ b/archivers/xz/Makefile
@@ -25,7 +25,9 @@ CONFIGURE_ARGS= --disable-nls
# pick up assembly language optimizations
CONFIGURE_TARGET= ${ARCH:S/amd64/x86_64/}-portbld-freebsd${OSREL}
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
INSTALL_TARGET= install install-dist_docDATA install-dist_examplesDATA
.endif
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index 3de689327bc1..9a8a4b878abc 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: flac
-# Date created: Mar 18, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= flac
PORTVERSION= 1.2.1
@@ -25,7 +21,12 @@ CONFIGURE_ARGS= --enable-sse \
CPPFLAGS+= -I${WRKSRC}/include
MAKE_JOBS_SAFE= yes
-.if !defined(WITHOUT_ICONV)
+OPTIONS_DEFINE= ICONV
+OPTIONS_DEFAULT=ICONV
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MICONV}
USE_ICONV= yes
CONFIGURE_ARGS+=--with-libiconv-prefix="${LOCALBASE}"
.else
@@ -33,10 +34,10 @@ CONFIGURE_ARGS+=--without-libiconv-prefix
.endif
MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
-.if defined(NOPORTDOCS)
-MAKE_ENV+= DOC=""
-.else
+.if ${PORT_OPTIONS:MDOCS}
MAKE_ENV+= DOC=doc
+.else
+MAKE_ENV+= DOC=""
.endif
USE_LDCONFIG= yes
diff --git a/audio/libogg/Makefile b/audio/libogg/Makefile
index 64be16a70ccb..367b411d1c41 100644
--- a/audio/libogg/Makefile
+++ b/audio/libogg/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libogg
-# Date created: 18 October 2000
-# Whom: t.vanklaveren@student.utwente.nl
-#
+# Created by: t.vanklaveren@student.utwente.nl
# $FreeBSD$
-#
PORTNAME= libogg
PORTVERSION= 1.3.0
@@ -20,10 +16,12 @@ USE_GNOME= gnomehack
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-.if defined(NOPORTDOCS)
-MAKE_ENV= DOC=""
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
MAKE_ENV= DOC=doc
+.else
+MAKE_ENV= DOC=""
.endif
regression-test: build
diff --git a/audio/libvorbis/Makefile b/audio/libvorbis/Makefile
index 7f1a51bda798..7572d10142d3 100644
--- a/audio/libvorbis/Makefile
+++ b/audio/libvorbis/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libvorbis
-# Date created: 18 October 2000
-# Whom: t.vanklaveren@student.utwente.nl
-#
+# Created by: t.vanklaveren@student.utwente.nl
# $FreeBSD$
-#
PORTNAME= libvorbis
PORTVERSION= 1.3.3
@@ -27,10 +23,12 @@ CONFIGURE_ARGS= --with-ogg=${LOCALBASE} \
--disable-docs # don't rebuild
MAKE_JOBS_SAFE= yes
-.if defined(NOPORTDOCS)
-MAKE_ENV= DOC=""
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
MAKE_ENV= DOC=doc
+.else
+MAKE_ENV= DOC=""
.endif
regression-test: build
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index c7391fe9f80f..63264fb14766 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: vorbis-tools
-# Date created: 18 October 2000
-# Whom: t.vanklaveren@student.utwente.nl
-#
+# Created by: t.vanklaveren@student.utwente.nl
# $FreeBSD$
-#
PORTNAME= vorbis-tools
PORTVERSION= 1.4.0
@@ -29,7 +25,9 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
diff --git a/audio/xmms-shn/Makefile b/audio/xmms-shn/Makefile
index 2ad42843b172..be0a18afb333 100644
--- a/audio/xmms-shn/Makefile
+++ b/audio/xmms-shn/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: shntool
-# Date created: 2 November 2000
-# Whom: Bill Fenner <fenner@FreeBSD.Org>
-#
+# Created by: Bill Fenner <fenner@FreeBSD.Org>
# $FreeBSD$
-#
PORTNAME= xmms-shn
PORTVERSION= 2.4.1
@@ -21,8 +17,10 @@ USE_GNOME= gtk12
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/audio/xmms-xf86audio/Makefile b/audio/xmms-xf86audio/Makefile
index 7dd023c94aa0..299228558958 100644
--- a/audio/xmms-xf86audio/Makefile
+++ b/audio/xmms-xf86audio/Makefile
@@ -12,10 +12,12 @@ LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
MAKE_ARGS= CC="${CC}" OPT="${CFLAGS}" DEBUG=""
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_DATA} ${WRKSRC}/libxf86audio.so \
`xmms-config --general-plugin-dir`
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif