aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/openggsn/Makefile28
-rw-r--r--net/openggsn/distinfo2
-rw-r--r--net/openggsn/pkg-descr6
-rw-r--r--net/openggsn/pkg-plist10
5 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2ba8ac57420d..973582faf671 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -451,6 +451,7 @@
SUBDIR += openam
SUBDIR += openbgpd
SUBDIR += opendpi
+ SUBDIR += openggsn
SUBDIR += openh323
SUBDIR += openldap24-client
SUBDIR += openldap24-sasl-client
diff --git a/net/openggsn/Makefile b/net/openggsn/Makefile
new file mode 100644
index 000000000000..51640bcd61bf
--- /dev/null
+++ b/net/openggsn/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= openggsn
+PORTVERSION= 0.91
+CATEGORIES= net
+MASTER_SITES= http://chaosophia.net/downloads/osmocom/${PORTNAME}/ \
+ http://ns1.chaosophia.net/downloads/osmocom/${PORTNAME}/
+
+MAINTAINER= koue@chaosophia.net
+COMMENT= Implementation of the Gateway GPRS Support Node element
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake libtool
+
+USE_AUTOTOOLS= aclocal autoconf automake libtoolize autoheader
+AUTOMAKE_ARGS= --gnu --add-missing --copy
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|pkgconfigdir.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.am
+ ${ECHO_CMD} ${PORTVERSION} > ${WRKSRC}/.tarball-version
+
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgtp.so.0
+
+.include <bsd.port.mk>
diff --git a/net/openggsn/distinfo b/net/openggsn/distinfo
new file mode 100644
index 000000000000..8abe9d1ac085
--- /dev/null
+++ b/net/openggsn/distinfo
@@ -0,0 +1,2 @@
+SHA256 (openggsn-0.91.tar.gz) = a4b11714069af4211daf7297480562ed9aae7a65647c02d52a3c3c6a1ae64d81
+SIZE (openggsn-0.91.tar.gz) = 145300
diff --git a/net/openggsn/pkg-descr b/net/openggsn/pkg-descr
new file mode 100644
index 000000000000..674d6f1abc6b
--- /dev/null
+++ b/net/openggsn/pkg-descr
@@ -0,0 +1,6 @@
+OpenGGSN is an implementation of the Gateway GPRS Support Node element
+in the GPRS core network.
+OpenGGSN was developed in 2002 to 2004 by Mondru AB and was abandoned
+for some years before adopted by the Osmocom project.
+
+WWW: http://openbsc.osmocom.org/trac/wiki/OpenGGSN
diff --git a/net/openggsn/pkg-plist b/net/openggsn/pkg-plist
new file mode 100644
index 000000000000..f111a2d6b694
--- /dev/null
+++ b/net/openggsn/pkg-plist
@@ -0,0 +1,10 @@
+bin/ggsn
+bin/sgsnemu
+include/gtp.h
+include/pdp.h
+lib/libgtp.a
+lib/libgtp.so
+lib/libgtp.so.0
+lib/libgtp.so.0.0.0
+man/man8/ggsn.8.gz
+man/man8/sgsnemu.8.gz