aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/squeezeboxserver/Makefile1
-rw-r--r--databases/fireprofile/Makefile2
-rw-r--r--databases/gtksql/Makefile7
-rw-r--r--databases/mysql-connector-odbc/Makefile2
-rw-r--r--databases/mysql-proxy/Makefile2
-rw-r--r--databases/mysql-udf/Makefile1
-rw-r--r--databases/mysql-workbench51/Makefile2
-rw-r--r--databases/p5-Mysql/Makefile1
-rw-r--r--databases/phpmyadmin/Makefile2
-rw-r--r--deskutils/sugarcrm/Makefile1
-rw-r--r--devel/bugzilla/Makefile1
-rw-r--r--devel/bugzilla3/Makefile1
-rw-r--r--games/mkgichessclub/Makefile1
-rw-r--r--lang/php5/Makefile.ext1
-rw-r--r--lang/php52/Makefile.ext1
-rw-r--r--lang/php53/Makefile.ext1
-rw-r--r--mail/phplist/Makefile1
-rw-r--r--net/mediatomb/Makefile2
-rw-r--r--ports-mgmt/tinderbox/Makefile3
-rw-r--r--textproc/modlogan/Makefile7
-rw-r--r--www/drupal7/Makefile2
-rw-r--r--www/groupoffice/Makefile1
-rw-r--r--www/mediawiki/Makefile1
-rw-r--r--www/mediawiki116/Makefile1
-rw-r--r--www/mediawiki118/Makefile1
-rw-r--r--www/pivotx/Makefile1
-rw-r--r--www/rnews/Makefile1
-rw-r--r--www/vtiger/Makefile2
28 files changed, 10 insertions, 40 deletions
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index d89f1dcff8b1..d2950e664600 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -61,7 +61,6 @@ RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
.endif
USE_MYSQL= server
-IGNORE_WITH_MYSQL= 323 40
.if !defined(WITHOUT_APE)
RUN_DEPENDS+= mac:${PORTSDIR}/audio/mac
diff --git a/databases/fireprofile/Makefile b/databases/fireprofile/Makefile
index 3852ffcab45e..751ee97de710 100644
--- a/databases/fireprofile/Makefile
+++ b/databases/fireprofile/Makefile
@@ -23,8 +23,6 @@ PLIST_FILES= lib/libfireprofile.so.0 lib/libfireprofile.so
USE_LDCONFIG= yes
USE_MYSQL= yes
-DEFAULT_MYSQL_VER= 323
-WANT_MYSQL_VER= 323
post-install:
$(LN) ${PREFIX}/lib/libfireprofile.so ${PREFIX}/lib/libfireprofile.so.0
diff --git a/databases/gtksql/Makefile b/databases/gtksql/Makefile
index d3107eb5bf66..2d6ed5669b84 100644
--- a/databases/gtksql/Makefile
+++ b/databases/gtksql/Makefile
@@ -24,8 +24,7 @@ USE_GNOME= gtk12
.if defined(WITH_MYSQL) || (exists(${LOCALBASE}/lib/mysql/libmysqlclient.a) \
&& !defined(WITHOUT_MYSQL))
-HAVE_MYSQL= yes
-LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+USE_MYSQL= yes
.endif
.if defined(WITH_PGSQL) || (exists(${LOCALBASE}/lib/libpq.a) \
&& !defined(WITHOUT_PGSQL))
@@ -34,7 +33,7 @@ USE_PGSQL= yes
.endif
pre-patch:
-.if !defined(HAVE_MYSQL) && !defined(HAVE_PGSQL)
+.if !defined(USE_MYSQL) && !defined(HAVE_PGSQL)
@${ECHO} "You must specify which database to use, possible are:"
@${ECHO}
@${ECHO} "make WITH_MYSQL=yes (for MySQL support)"
@@ -44,7 +43,7 @@ pre-patch:
.endif
do-configure:
-.if defined(HAVE_MYSQL)
+.if defined(USE_MYSQL)
@${REINPLACE_CMD} -e "s/^#MYSQL/MYSQL/g" ${WRKSRC}/Makefile
.endif
.if defined(HAVE_PGSQL)
diff --git a/databases/mysql-connector-odbc/Makefile b/databases/mysql-connector-odbc/Makefile
index f218eeb8ed6a..bb1962cbcd72 100644
--- a/databases/mysql-connector-odbc/Makefile
+++ b/databases/mysql-connector-odbc/Makefile
@@ -19,7 +19,7 @@ COMMENT= ODBC driver for MySQL${MYSQL_VER} / ${DRIVER_MANAGER}
USE_MYSQL= yes
DEFAULT_MYSQL_VER= 51
-IGNORE_WITH_MYSQL= 323 55
+IGNORE_WITH_MYSQL= 55
USE_GMAKE= yes
USE_AUTOTOOLS= libtool libltdl
diff --git a/databases/mysql-proxy/Makefile b/databases/mysql-proxy/Makefile
index 49163a0aa712..d3baeaa9f1f9 100644
--- a/databases/mysql-proxy/Makefile
+++ b/databases/mysql-proxy/Makefile
@@ -28,6 +28,6 @@ USE_LDCONFIG= yes
USE_LUA= 5.1+
USE_MYSQL= yes
USE_RC_SUBR= mysql-proxy
-IGNORE_WITH_MYSQL= 323 40 41
+IGNORE_WITH_MYSQL= 41
.include <bsd.port.mk>
diff --git a/databases/mysql-udf/Makefile b/databases/mysql-udf/Makefile
index 116467f7bf47..d9a0bc2206c1 100644
--- a/databases/mysql-udf/Makefile
+++ b/databases/mysql-udf/Makefile
@@ -17,7 +17,6 @@ COMMENT= Set of user-defined functions for the MySQL server
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_MYSQL= yes
-IGNORE_WITH_MYSQL_VER= 323
MODULES= colwidth confidence_higher confidence_lower correlation \
faculty geomean intercept kurtosis longest median noverm \
diff --git a/databases/mysql-workbench51/Makefile b/databases/mysql-workbench51/Makefile
index 72960fd1e737..8522c5fca6b9 100644
--- a/databases/mysql-workbench51/Makefile
+++ b/databases/mysql-workbench51/Makefile
@@ -62,7 +62,7 @@ CONFIGURE_ENV= GNOME2_DIR="${LOCALBASE}" LUA_LIBS="-llua"
USE_MYSQL= client
DEFAULT_MYSQL_VER= 51
-IGNORE_WITH_MYSQL= 323 40 41 55
+IGNORE_WITH_MYSQL= 41 55
.if defined(WITH_PYTHON)
CONFIGURE_ARGS+= --enable-python-modules
diff --git a/databases/p5-Mysql/Makefile b/databases/p5-Mysql/Makefile
index adf7c3f30dca..8968059d02d7 100644
--- a/databases/p5-Mysql/Makefile
+++ b/databases/p5-Mysql/Makefile
@@ -22,7 +22,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
CONFLICTS= p5-DBD-mysql-* p5-DBD-mysql4[0-9]-* p5-DBD-mysql5[0-9]-*
USE_MYSQL= yes
-DEFAULT_MYSQL_VER= 323
PERL_CONFIGURE= yes
CONFIGURE_ARGS= PREFIX=${PREFIX} CC="${CC}" CCFLAGS="${CFLAGS}" \
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
index 026df305f4a2..74dd1a1d1649 100644
--- a/databases/phpmyadmin/Makefile
+++ b/databases/phpmyadmin/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv2
USE_MYSQL= compat
IGNORE_WITH_PHP= 4
-IGNORE_WITH_MYSQL= 323 40 41
+IGNORE_WITH_MYSQL= 41
USE_BZIP2= yes
NO_BUILD= yes
.if !defined(WITHOUT_PHP_DEPENDS)
diff --git a/deskutils/sugarcrm/Makefile b/deskutils/sugarcrm/Makefile
index 8ff0680fe38f..d53da443878e 100644
--- a/deskutils/sugarcrm/Makefile
+++ b/deskutils/sugarcrm/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= nick@foobar.org
COMMENT= A web based customer relationship management suite
FETCH_ARGS= -pRr
-IGNORE_WITH_MYSQL= 323 40
USE_PHP= gd mysql session pcre xml zlib mbstring curl imap spl posix
USE_ZIP= yes
NO_BUILD= yes
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index e9a2b582a5ab..1e1ade040d7f 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -68,7 +68,6 @@ RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
.ifdef WITH_MYSQL
RUN_DEPENDS+= p5-DBD-mysql>=2.9003:${PORTSDIR}/databases/p5-DBD-mysql
USE_MYSQL= yes
-IGNORE_WITH_MYSQL= 323
.endif
.ifdef WITH_PGSQL
diff --git a/devel/bugzilla3/Makefile b/devel/bugzilla3/Makefile
index e5cd85d4f986..fb6704931018 100644
--- a/devel/bugzilla3/Makefile
+++ b/devel/bugzilla3/Makefile
@@ -67,7 +67,6 @@ RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
.ifdef WITH_MYSQL
RUN_DEPENDS+= p5-DBD-mysql>=2.9003:${PORTSDIR}/databases/p5-DBD-mysql
USE_MYSQL= yes
-IGNORE_WITH_MYSQL= 323
.endif
.ifdef WITH_PGSQL
diff --git a/games/mkgichessclub/Makefile b/games/mkgichessclub/Makefile
index 413f6e6ebec3..05ae963a3bf3 100644
--- a/games/mkgichessclub/Makefile
+++ b/games/mkgichessclub/Makefile
@@ -23,7 +23,6 @@ NO_BUILD= yes
SUB_FILES= pkg-message
USE_MYSQL= server
-IGNORE_WITH_MYSQL= 323
USE_PHP= mysql pcre session
USE_PYTHON= yes
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 3bd8be6799aa..e57f760adcae 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -512,7 +512,6 @@ CONFIGURE_ARGS+=--with-mysqli=mysqlnd
CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
USE_MYSQL= yes
-BROKEN_WITH_MYSQL= 323 40
. endif
.endif
diff --git a/lang/php52/Makefile.ext b/lang/php52/Makefile.ext
index a4f8159b0022..03658932796b 100644
--- a/lang/php52/Makefile.ext
+++ b/lang/php52/Makefile.ext
@@ -214,7 +214,6 @@ USE_MYSQL= yes
CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
USE_MYSQL= yes
-BROKEN_WITH_MYSQL= 323 40
USE_PHP= spl
USE_PHP_BUILD= yes
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 3bd8be6799aa..e57f760adcae 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -512,7 +512,6 @@ CONFIGURE_ARGS+=--with-mysqli=mysqlnd
CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
USE_MYSQL= yes
-BROKEN_WITH_MYSQL= 323 40
. endif
.endif
diff --git a/mail/phplist/Makefile b/mail/phplist/Makefile
index b74f410135cc..08d1538bbca4 100644
--- a/mail/phplist/Makefile
+++ b/mail/phplist/Makefile
@@ -13,7 +13,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@bsdserwis.com
COMMENT= A full-featured open-source newsletter manager
-IGNORE_WITH_MYSQL= 323
USE_PHP= session mysql imap xml pcre zlib
NO_BUILD= yes
diff --git a/net/mediatomb/Makefile b/net/mediatomb/Makefile
index 89260c12e0d0..f6227a31d61b 100644
--- a/net/mediatomb/Makefile
+++ b/net/mediatomb/Makefile
@@ -79,7 +79,7 @@ CONFIGURE_ARGS+= --disable-sqlite3
CONFIGURE_ARGS+= --enable-mysql \
--with-mysql-cfg="${LOCALBASE}/bin/mysql_config"
USE_MYSQL= yes
-IGNORE_WITH_MYSQL= 323 40 41
+IGNORE_WITH_MYSQL= 41
.else
CONFIGURE_ARGS+= --disable-mysql
.endif
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 62568ddf0942..9d26359f67fa 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -66,8 +66,7 @@ RUN_DEPENDS+= ${LOCALBASE}/share/pear/MDB2/Driver/mysql.php:${PORTSDIR}/database
USE_PHP+= mysql
.endif
USE_MYSQL= yes
-IGNORE_WITH_MYSQL= 323 40
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER:S/323//}
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
.endif
.if defined(WITH_CVSUP)
diff --git a/textproc/modlogan/Makefile b/textproc/modlogan/Makefile
index f2c32464bd43..be2b73636c7c 100644
--- a/textproc/modlogan/Makefile
+++ b/textproc/modlogan/Makefile
@@ -21,13 +21,6 @@ LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns \
USE_AUTOTOOLS= libtool
USE_GETTEXT= yes
-.if defined(WITH_MYSQL)
-# To quote the author:
-# It is used by src/processor/telecom/... for a commercial project. The
-# project itself is opensource but not documented.
-# Therefore no testing if it works is made in the FreeBSD port.
-LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-.endif
# Please don't remove the comments, as soon as autoconf/libtool get's
# updated in the ports collection the comments may be removed.
diff --git a/www/drupal7/Makefile b/www/drupal7/Makefile
index a6f6111d6a96..afdbad77386b 100644
--- a/www/drupal7/Makefile
+++ b/www/drupal7/Makefile
@@ -42,7 +42,7 @@ USE_PHP+= pdo_sqlite
.endif
.if defined(WITH_MYSQL)
USE_MYSQL= yes
-IGNORE_WITH_MYSQL= 323 40 41
+IGNORE_WITH_MYSQL= 41
USE_PHP+= pdo_mysql
.endif
.if defined(WITH_PGSQL)
diff --git a/www/groupoffice/Makefile b/www/groupoffice/Makefile
index c2ccd4b1c920..9cbc6e2b68c6 100644
--- a/www/groupoffice/Makefile
+++ b/www/groupoffice/Makefile
@@ -18,7 +18,6 @@ NO_BUILD= yes
USE_PHP= mysql session mbstring pcre xml
WANT_PHP_WEB= yes
USE_MYSQL= yes
-IGNORE_WITH_MYSQL= 323
WWWDIR?= ${PREFIX}/www/${PORTNAME}3
diff --git a/www/mediawiki/Makefile b/www/mediawiki/Makefile
index 3f35563a89b8..add8dd9b51ec 100644
--- a/www/mediawiki/Makefile
+++ b/www/mediawiki/Makefile
@@ -33,7 +33,6 @@ OPTIONS= PGSQL "Use PostgreSQL (instead of MySQL)" off \
.if defined(WITH_PGSQL)
USE_PHP+= pgsql
.else
-IGNORE_WITH_MYSQL= 323
USE_MYSQL= yes
USE_PHP+= mysql
.endif
diff --git a/www/mediawiki116/Makefile b/www/mediawiki116/Makefile
index 2d113167270d..f88e01b972dc 100644
--- a/www/mediawiki116/Makefile
+++ b/www/mediawiki116/Makefile
@@ -33,7 +33,6 @@ OPTIONS= PGSQL "Use PostgreSQL (instead of MySQL)" off \
.if defined(WITH_PGSQL)
USE_PHP+= pgsql
.else
-IGNORE_WITH_MYSQL= 323
USE_MYSQL= yes
USE_PHP+= mysql
.endif
diff --git a/www/mediawiki118/Makefile b/www/mediawiki118/Makefile
index 3f35563a89b8..add8dd9b51ec 100644
--- a/www/mediawiki118/Makefile
+++ b/www/mediawiki118/Makefile
@@ -33,7 +33,6 @@ OPTIONS= PGSQL "Use PostgreSQL (instead of MySQL)" off \
.if defined(WITH_PGSQL)
USE_PHP+= pgsql
.else
-IGNORE_WITH_MYSQL= 323
USE_MYSQL= yes
USE_PHP+= mysql
.endif
diff --git a/www/pivotx/Makefile b/www/pivotx/Makefile
index 8ad476d75f18..506f33208c79 100644
--- a/www/pivotx/Makefile
+++ b/www/pivotx/Makefile
@@ -42,7 +42,6 @@ USE_PHP+= dom
.endif
.if defined(WITH_MYSQL)
-IGNORE_WITH_MYSQL=323 40
USE_MYSQL= yes
USE_PHP+= mysql
.endif
diff --git a/www/rnews/Makefile b/www/rnews/Makefile
index 494712d5b43a..34c90127f0b2 100644
--- a/www/rnews/Makefile
+++ b/www/rnews/Makefile
@@ -24,7 +24,6 @@ OPTIONS= GD "Enable Graphic (GD) support" ON \
USE_PHP= mysql mbstring pcre xml iconv
USE_MYSQL= yes
-IGNORE_WITH_MYSQL= 323 40
.if !defined(WITHOUT_GD)
USE_PHP+= gd
diff --git a/www/vtiger/Makefile b/www/vtiger/Makefile
index 28ce45a4d85b..8dc422567d65 100644
--- a/www/vtiger/Makefile
+++ b/www/vtiger/Makefile
@@ -28,8 +28,6 @@ OPTIONS= MYSQLSERVER "Use MySQL-Server on localhost" OFF
.include <bsd.port.pre.mk>
-IGNORE_WITH_MYSQL= 323 40
-
CONFLICTS= vtiger-4.*
.if !defined(WITHOUT_MYSQLSERVER)