aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile3
-rw-r--r--sysutils/rex/Makefile25
-rw-r--r--sysutils/rex/distinfo3
-rw-r--r--sysutils/rex/pkg-descr8
4 files changed, 38 insertions, 1 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 47efbef00bca..716e7a092077 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -663,12 +663,12 @@
SUBDIR += namefix
SUBDIR += nbosd
SUBDIR += ncdu
+ SUBDIR += ndmpd
SUBDIR += nepomuk-core
SUBDIR += nepomuk-widgets
SUBDIR += nfcutils
SUBDIR += nfsping
SUBDIR += nitrogen
- SUBDIR += ndmpd
SUBDIR += no-login
SUBDIR += node_exporter
SUBDIR += nomad
@@ -942,6 +942,7 @@
SUBDIR += respond
SUBDIR += restic
SUBDIR += retail
+ SUBDIR += rex
SUBDIR += rfstool
SUBDIR += rhc
SUBDIR += riak-cs
diff --git a/sysutils/rex/Makefile b/sysutils/rex/Makefile
new file mode 100644
index 000000000000..308d5e809bb9
--- /dev/null
+++ b/sysutils/rex/Makefile
@@ -0,0 +1,25 @@
+# Created by: Zeus Panchenko <zeus@gnu.org.ua>
+# $FreeBSD$
+
+PORTNAME= rex
+PORTVERSION= 4.0
+CATEGORIES= sysutils tcl
+MASTER_SITES= http://download.gnu.org.ua/pub/release/${PORTNAME}/
+
+MAINTAINER= zeus@gnu.org.ua
+COMMENT= Remote EXecution utility
+
+LICENSE= GPLv3+
+
+RUN_DEPENDS= expect:lang/expect
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/rex man/man8/rex.8.gz
+
+do-install:
+ cd ${WRKSRC} && ${WRKSRC}/install --prefix=${STAGEDIR}${PREFIX} \
+ --sysconfdir=${PREFIX}/etc \
+ --mandir=${STAGEDIR}${MANPREFIX}/man
+
+.include <bsd.port.mk>
diff --git a/sysutils/rex/distinfo b/sysutils/rex/distinfo
new file mode 100644
index 000000000000..44de47846078
--- /dev/null
+++ b/sysutils/rex/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475321371
+SHA256 (rex-4.0.tar.gz) = 52436b38e3f2ea8f780b24d80663ae4730b38da9c9b6bf546cdbc920cc0d05e8
+SIZE (rex-4.0.tar.gz) = 55222
diff --git a/sysutils/rex/pkg-descr b/sysutils/rex/pkg-descr
new file mode 100644
index 000000000000..3380d3b582a8
--- /dev/null
+++ b/sysutils/rex/pkg-descr
@@ -0,0 +1,8 @@
+REX is a remote execution utility that runs a supplied command or shell
+script on several hosts in succession. It is also able to copy a file
+(or files) to several hosts.
+
+Rex is written in Tcl and provides extensive scripting facilities. It
+provides a convenient way to administrate multiple servers.
+
+WWW: http://puszcza.gnu.org.ua/projects/rex