aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/incron/Makefile34
-rw-r--r--sysutils/incron/distinfo3
-rw-r--r--sysutils/incron/pkg-descr9
-rw-r--r--sysutils/incron/pkg-plist9
5 files changed, 56 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 9bd4094a3727..ff36d94e8932 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -472,6 +472,7 @@
SUBDIR += i7z
SUBDIR += iat
SUBDIR += immortal
+ SUBDIR += incron
SUBDIR += inotify-tools
SUBDIR += installwatch
SUBDIR += intel-nvmupdate
diff --git a/sysutils/incron/Makefile b/sysutils/incron/Makefile
new file mode 100644
index 000000000000..941b9df52247
--- /dev/null
+++ b/sysutils/incron/Makefile
@@ -0,0 +1,34 @@
+# Created by: mi@aldan.algebra.com
+# $FreeBSD$
+
+PORTNAME= incron
+DISTVERSION= 2017-10-30
+CATEGORIES= sysutils
+
+MAINTAINER= mi@aldan.algebra.com
+COMMENT= Handle finesystem-events the way cron handles time ones
+
+LICENSE= GPLv2 LGPL21 MIT
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv2= ${WRKSRC}/LICENSE-GPL
+LICENSE_FILE_LGPL21= ${WRKSRC}/LICENSE-LGPL
+LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-X11
+
+LIB_DEPENDS= libinotify.so:devel/libinotify
+
+USE_GITHUB= indeed
+GH_ACCOUNT= ar-
+GH_TAGNAME= e05b7c892f569cf7dadc3c02a464ec1824d27b8e
+CPPFLAGS+= -I${LOCALBASE}/include -D__NR_inotify_init
+LDFLAGS+= -L${LOCALBASE}/lib -linotify
+MAKE_ARGS= PREFIX="${PREFIX}" USER=${UID} \
+ DOCDIR="${PREFIX}/etc" \
+ MANPATH=${MANPREFIX}/man
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/etc/incron,${PREFIX}/etc/incron,' \
+ ${WRKSRC}/*conf* ${WRKSRC}/Makefile ${WRKSRC}/*.[158h] \
+ ${WRKSRC}/*.cpp
+ ${REINPLACE_CMD} -e '/INITDIR/d' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/sysutils/incron/distinfo b/sysutils/incron/distinfo
new file mode 100644
index 000000000000..1d41e8c48ea8
--- /dev/null
+++ b/sysutils/incron/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1510537921
+SHA256 (ar--incron-2017-10-30-e05b7c892f569cf7dadc3c02a464ec1824d27b8e_GH0.tar.gz) = 12e739de81f7a76189f1da36831de4f1f4ebdbfd38a3801ab4904cc6c89c4fde
+SIZE (ar--incron-2017-10-30-e05b7c892f569cf7dadc3c02a464ec1824d27b8e_GH0.tar.gz) = 339550
diff --git a/sysutils/incron/pkg-descr b/sysutils/incron/pkg-descr
new file mode 100644
index 000000000000..2d1e342b45fa
--- /dev/null
+++ b/sysutils/incron/pkg-descr
@@ -0,0 +1,9 @@
+This program is an "inotify cron" system. It consists of a daemon
+and a table manipulator. You can use it a similar way as the regular
+cron. The difference is that the inotify cron handles filesystem
+events rather than time periods.
+
+Written to use (and named after) Linux' "inotify", on BSD it uses
+the libinotify compatibility layer.
+
+WWW: http://inotify.aiken.cz/?section=incron&page=about
diff --git a/sysutils/incron/pkg-plist b/sysutils/incron/pkg-plist
new file mode 100644
index 000000000000..e4ea298f15ef
--- /dev/null
+++ b/sysutils/incron/pkg-plist
@@ -0,0 +1,9 @@
+bin/incrontab
+@sample etc/incron.conf.example
+sbin/incrond
+man/man1/incrontab.1.gz
+man/man5/incron.conf.5.gz
+man/man5/incrontab.5.gz
+man/man8/incrond.8.gz
+@dir etc/incron.d
+@dir /var/spool/incron