aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/bddsolve/Makefile2
-rw-r--r--science/bft/Makefile2
-rw-r--r--science/brian/Makefile2
-rw-r--r--science/ecs/Makefile3
-rw-r--r--science/fvm/Makefile2
-rw-r--r--science/liblinear/Makefile2
-rw-r--r--science/libsvm/Makefile2
-rw-r--r--science/ncs/Makefile3
-rw-r--r--science/psychopy/Makefile2
-rw-r--r--science/py-obspy/Makefile3
-rw-r--r--security/bsp_upektfmess/Makefile3
-rw-r--r--security/chntpw/Makefile3
-rw-r--r--security/cryptlib/Makefile2
-rw-r--r--security/cryptopp/Makefile3
-rw-r--r--security/dirbuster/Makefile2
-rw-r--r--security/httprint/Makefile2
-rw-r--r--security/iaikpkcs11wrapper/Makefile5
-rw-r--r--security/jbrofuzz/Makefile2
-rw-r--r--security/mindterm-binary/Makefile2
-rw-r--r--security/phpsecinfo/Makefile2
-rw-r--r--security/py-AccessControl/Makefile2
-rw-r--r--security/py-Products.PlonePAS/Makefile3
-rw-r--r--security/py-RestrictedPython/Makefile2
-rw-r--r--security/py-borg.localrole/Makefile2
-rw-r--r--security/py-keyring/Makefile2
-rw-r--r--security/py-plone.keyring/Makefile2
-rw-r--r--security/py-plone.openid/Makefile2
-rw-r--r--security/py-plone.protect/Makefile2
-rw-r--r--security/py-plone.session/Makefile2
-rw-r--r--security/py-zope.authentication/Makefile2
-rw-r--r--security/py-zope.login/Makefile2
-rw-r--r--security/quantis-kmod/Makefile2
-rw-r--r--security/quantis/Makefile3
-rw-r--r--security/webscarab/Makefile2
-rw-r--r--security/xml-security/Makefile2
-rw-r--r--security/xorsearch/Makefile2
-rw-r--r--security/yassl/Makefile2
-rw-r--r--sysutils/areca-cli/Makefile2
-rw-r--r--sysutils/daa2iso/Makefile2
-rw-r--r--sysutils/dupmerge/Makefile2
-rw-r--r--sysutils/hfsexplorer/Makefile2
-rw-r--r--sysutils/jdiskreport/Makefile2
-rw-r--r--sysutils/jtopen/Makefile2
-rw-r--r--sysutils/kshutdown-kde4/Makefile3
-rw-r--r--sysutils/ods2/Makefile2
-rw-r--r--sysutils/pdixtract/Makefile2
-rw-r--r--sysutils/rfstool/Makefile2
-rw-r--r--sysutils/rsyncbackup/Makefile3
-rw-r--r--sysutils/searchmonkey/Makefile3
-rw-r--r--sysutils/uif2iso/Makefile3
-rw-r--r--sysutils/vstrip/Makefile2
51 files changed, 52 insertions, 65 deletions
diff --git a/science/bddsolve/Makefile b/science/bddsolve/Makefile
index 39b4193bc421..a205eaacda7a 100644
--- a/science/bddsolve/Makefile
+++ b/science/bddsolve/Makefile
@@ -14,7 +14,7 @@ COMMENT= BDD-based satisfiability and reachability solver
LIB_DEPENDS+= libbdd.so:${PORTSDIR}/science/buddy \
libboost_program_options.so:${PORTSDIR}/devel/boost-libs
-USE_ZIP= yes
+USES= zip
NO_WRKSUBDIR= yes
NO_STAGE= yes
diff --git a/science/bft/Makefile b/science/bft/Makefile
index 4a8e4aa238d9..c23fe41fc9a1 100644
--- a/science/bft/Makefile
+++ b/science/bft/Makefile
@@ -14,7 +14,7 @@ LICENSE= LGPL21
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_ZIP= yes
+USES= zip
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/science/brian/Makefile b/science/brian/Makefile
index e1b2defefb88..dbd7d3e716fe 100644
--- a/science/brian/Makefile
+++ b/science/brian/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.1.0:${PORTSDIR}/math/py-numpy \
${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_ZIP= yes
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/science/ecs/Makefile b/science/ecs/Makefile
index f511bfd3a14b..a9108f2e7197 100644
--- a/science/ecs/Makefile
+++ b/science/ecs/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= med.5:${PORTSDIR}/french/med \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_ZIP= yes
+USES= gmake zip
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-bft=${LOCALBASE} \
--with-hdf5=${LOCALBASE} \
@@ -29,7 +29,6 @@ CONFIGURE_ARGS= --with-bft=${LOCALBASE} \
--with-metis=${LOCALBASE} \
--with-metis-include=${LOCALBASE}/include/metis
CONFIGURE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
-USE_GMAKE= yes
.if defined(WITH_CCMIO)
LIB_DEPENDS+= adf.5:${PORTSDIR}/science/libccmio \
diff --git a/science/fvm/Makefile b/science/fvm/Makefile
index efc2c478d36b..5221c9fc99db 100644
--- a/science/fvm/Makefile
+++ b/science/fvm/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= med.5:${PORTSDIR}/french/med \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_ZIP= yes
+USES= zip
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-bft=${LOCALBASE} \
diff --git a/science/liblinear/Makefile b/science/liblinear/Makefile
index b26de0282872..38b22b23ba35 100644
--- a/science/liblinear/Makefile
+++ b/science/liblinear/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
OPTIONS_DEFINE= OPTIMIZED_CFLAGS
OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
-USE_ZIP= yes
+USES= zip
TXT_DOCS= COPYRIGHT README
diff --git a/science/libsvm/Makefile b/science/libsvm/Makefile
index 93b883a93bff..5f65e61e0398 100644
--- a/science/libsvm/Makefile
+++ b/science/libsvm/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
-USE_ZIP= yes
+USES= zip
USE_LDCONFIG= yes
ALL_TARGET= all lib
diff --git a/science/ncs/Makefile b/science/ncs/Makefile
index a9c882f161c0..c149ecb37e33 100644
--- a/science/ncs/Makefile
+++ b/science/ncs/Makefile
@@ -23,8 +23,7 @@ RUN_DEPENDS= xmgrace:${PORTSDIR}/math/grace \
xterm:${PORTSDIR}/x11/xterm \
cs_preprocess:${PORTSDIR}/science/ecs
-USE_ZIP= yes
-USES= fortran gettext gmake iconv
+USES= fortran gettext gmake iconv zip
USE_GNOME= libxml2
USE_PYTHON= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/science/psychopy/Makefile b/science/psychopy/Makefile
index d20e17e0287f..a46746b4dab1 100644
--- a/science/psychopy/Makefile
+++ b/science/psychopy/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.1.0:${PORTSDIR}/math/py-numpy \
${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_ZIP= yes
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= PsychoPy
diff --git a/science/py-obspy/Makefile b/science/py-obspy/Makefile
index ac915a9b69ff..31319faf09df 100644
--- a/science/py-obspy/Makefile
+++ b/science/py-obspy/Makefile
@@ -19,8 +19,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0:${PORTSDIR}/databases/py-sqlalchemy
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= fortran
-USE_ZIP= yes
+USES= fortran zip
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYEASYINSTALL_ARCHDEP= yes
diff --git a/security/bsp_upektfmess/Makefile b/security/bsp_upektfmess/Makefile
index c4eec4146690..b37933485c51 100644
--- a/security/bsp_upektfmess/Makefile
+++ b/security/bsp_upektfmess/Makefile
@@ -17,9 +17,8 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xext.pc:${PORTSDIR}/x11/libXext
PLIST_FILES= lib/libtfmessbsp.so
-USE_ZIP= yes
USE_LDCONFIG= yes
-USES= gettext iconv
+USES= gettext iconv zip
# Maintainer note
# Both the gui and the non-gui object are linked to libX11
USE_XORG= x11 xext
diff --git a/security/chntpw/Makefile b/security/chntpw/Makefile
index ac00e05d4c4a..0d9ac1293a1e 100644
--- a/security/chntpw/Makefile
+++ b/security/chntpw/Makefile
@@ -15,9 +15,8 @@ LICENSE= GPLv2
OPTIONS_DEFINE= DOCS
-USE_ZIP= yes
USE_OPENSSL= yes
-USES= gmake
+USES= gmake zip
ONLY_FOR_ARCHS= i386 amd64
diff --git a/security/cryptlib/Makefile b/security/cryptlib/Makefile
index 2f2a2b5b0f80..23ee7cca5bf1 100644
--- a/security/cryptlib/Makefile
+++ b/security/cryptlib/Makefile
@@ -14,7 +14,7 @@ ONLY_FOR_ARCHS= i386 amd64
OPTIONS_DEFINE= DOCS
-USE_ZIP= yes
+USES= zip
EXTRACT_BEFORE_ARGS= -aq
NO_WRKSUBDIR= yes
MAKEFILE= makefile
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 6bf3de48dd7f..556c6146b49a 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -20,9 +20,8 @@ GCC_DESC= Build with current GCC
.include <bsd.port.options.mk>
NO_WRKSUBDIR= yes
-USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aq
-USES= gmake
+USES= gmake zip
MAKEFILE= GNUmakefile
LIBVERSION= 0
diff --git a/security/dirbuster/Makefile b/security/dirbuster/Makefile
index 0c0448256c33..6c1d692f5dcd 100644
--- a/security/dirbuster/Makefile
+++ b/security/dirbuster/Makefile
@@ -10,7 +10,7 @@ DISTNAME= DirBuster-1.0-RC1
MAINTAINER= ports@FreeBSD.org
COMMENT= DirBuster allows file and directory brute forcing on web servers
-USE_ZIP= YES
+USES= zip
USE_JAVA= YES
JAVA_VERSION= 1.6+
NO_BUILD= yes
diff --git a/security/httprint/Makefile b/security/httprint/Makefile
index 068b67247d12..55a3053289f6 100644
--- a/security/httprint/Makefile
+++ b/security/httprint/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= onatan@gmail.com
COMMENT= Web server fingerprinting tool
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}/freebsd/
-USE_ZIP= yes
+USES= zip
RESTRICTED= No cost for personal, education and non-commercial use.
NO_BUILD= yes
diff --git a/security/iaikpkcs11wrapper/Makefile b/security/iaikpkcs11wrapper/Makefile
index 3664751748a6..cda85e003b46 100644
--- a/security/iaikpkcs11wrapper/Makefile
+++ b/security/iaikpkcs11wrapper/Makefile
@@ -13,12 +13,11 @@ COMMENT= PKCS\#11 Java wrapper
OPTIONS_DEFINE= DOCS EXAMPLES
-USE_ZIP= yes
+USES= dos2unix gmake zip
USE_JAVA= yes
-USE_DOS2UNIX= Makefile
+DOS2UNIX_FILES= Makefile
JAVA_VERSION= 1.6+
JAVA_OS= native
-USE_GMAKE= yes
ALL_TARGET= release
PLIST_FILES= lib/libpkcs11wrapper.so %%JAVAJARDIR%%/iaikPkcs11Wrapper.jar
diff --git a/security/jbrofuzz/Makefile b/security/jbrofuzz/Makefile
index 6f1d5e9070f6..5716d930d38a 100644
--- a/security/jbrofuzz/Makefile
+++ b/security/jbrofuzz/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}-jar-21
MAINTAINER= ports@FreeBSD.org
COMMENT= JBroFuzz is a web application fuzzer
-USE_ZIP= YES
+USES= zip
USE_JAVA= YES
NO_BUILD= YES
JAVA_VERSION= 1.6+
diff --git a/security/mindterm-binary/Makefile b/security/mindterm-binary/Makefile
index b9396b2e4645..69603f754eef 100644
--- a/security/mindterm-binary/Makefile
+++ b/security/mindterm-binary/Makefile
@@ -14,7 +14,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Full vt220 compatible Java SSH-1 client (not only for websites)
-USE_ZIP= yes
+USES= zip
NO_WRKSUBDIR= yes
NO_BUILD= yes
NO_CDROM= Do not sell for profit
diff --git a/security/phpsecinfo/Makefile b/security/phpsecinfo/Makefile
index d3003d8b1315..f8ec73eb7b7e 100644
--- a/security/phpsecinfo/Makefile
+++ b/security/phpsecinfo/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= LOCAL/chinsan
MAINTAINER= ports@FreeBSD.org
COMMENT= PHP environment security auditing tool
-USE_ZIP= yes
+USES= zip
USE_PHP= pcre
WANT_PHP_WEB= yes
NO_BUILD= yes
diff --git a/security/py-AccessControl/Makefile b/security/py-AccessControl/Makefile
index f856a23ba7c8..044cd3ded4dc 100644
--- a/security/py-AccessControl/Makefile
+++ b/security/py-AccessControl/Makefile
@@ -31,9 +31,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Acquisition>=0:${PORTSDIR}/devel/py-Acquisit
${PYTHON_PKGNAMEPREFIX}zope.security>=0:${PORTSDIR}/security/py-zope.security \
${PYTHON_PKGNAMEPREFIX}zope.testing>=0:${PORTSDIR}/devel/py-zope.testing
+USES= zip
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/security/py-Products.PlonePAS/Makefile b/security/py-Products.PlonePAS/Makefile
index fe53249bb88c..404b2164af96 100644
--- a/security/py-Products.PlonePAS/Makefile
+++ b/security/py-Products.PlonePAS/Makefile
@@ -23,7 +23,6 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}plone.memoize>=0:${PORTSDIR}/www/py-plone.me
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
-USES= zope
+USES= zope zip
.include <bsd.port.mk>
diff --git a/security/py-RestrictedPython/Makefile b/security/py-RestrictedPython/Makefile
index a7a49062594e..a32636989507 100644
--- a/security/py-RestrictedPython/Makefile
+++ b/security/py-RestrictedPython/Makefile
@@ -13,9 +13,9 @@ COMMENT= Restricted execution environment for Python
LICENSE= ZPL21
+USES= zip
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/security/py-borg.localrole/Makefile b/security/py-borg.localrole/Makefile
index 7f1ea3f31bde..379f24ef3051 100644
--- a/security/py-borg.localrole/Makefile
+++ b/security/py-borg.localrole/Makefile
@@ -24,10 +24,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.annotation>=0:${PORTSDIR}/devel/py-zope
${PYTHON_PKGNAMEPREFIX}plone.memoize>=0:${PORTSDIR}/www/py-plone.memoize \
${PYTHON_PKGNAMEPREFIX}Acquisition>=0:${PORTSDIR}/devel/py-Acquisition
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
#USE_ZOPE= yes
.include <bsd.port.mk>
diff --git a/security/py-keyring/Makefile b/security/py-keyring/Makefile
index 486b9f1bef4e..544a0dfcbfdf 100644
--- a/security/py-keyring/Makefile
+++ b/security/py-keyring/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:${PORTSDIR}/devel/py-pytes
LATEST_LINK= py-${PORTNAME}
-USE_ZIP= yes
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYDISTUTILS_AUTOPLIST= yes
diff --git a/security/py-plone.keyring/Makefile b/security/py-plone.keyring/Makefile
index be00d413605a..edd25f7e5347 100644
--- a/security/py-plone.keyring/Makefile
+++ b/security/py-plone.keyring/Makefile
@@ -18,9 +18,9 @@ RUN_DEPENDS= zodb${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/databases/zodb3 \
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
${PYTHON_PKGNAMEPREFIX}zope.location>=0:${PORTSDIR}/devel/py-zope.location
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/security/py-plone.openid/Makefile b/security/py-plone.openid/Makefile
index c4a282b020cd..7b29232e8f0f 100644
--- a/security/py-plone.openid/Makefile
+++ b/security/py-plone.openid/Makefile
@@ -19,10 +19,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openid>=0:${PORTSDIR}/security/py-openid \
${PYTHON_PKGNAMEPREFIX}Products.PluggableAuthService>=0:${PORTSDIR}/security/py-Products.PluggableAuthService \
zodb${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/databases/zodb3
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
#USES= zope
.include <bsd.port.mk>
diff --git a/security/py-plone.protect/Makefile b/security/py-plone.protect/Makefile
index f1ea4d9ab63c..1460c07d1064 100644
--- a/security/py-plone.protect/Makefile
+++ b/security/py-plone.protect/Makefile
@@ -17,10 +17,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}plone.keyring>1.0:${PORTSDIR}/security/py-pl
${PYTHON_PKGNAMEPREFIX}zope.component>=0:${PORTSDIR}/devel/py-zope.component \
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
#USES= zope
.include <bsd.port.mk>
diff --git a/security/py-plone.session/Makefile b/security/py-plone.session/Makefile
index 3a8660de8c57..43d24b892038 100644
--- a/security/py-plone.session/Makefile
+++ b/security/py-plone.session/Makefile
@@ -18,10 +18,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}plone.protect>=0:${PORTSDIR}/security/py-plo
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
${PYTHON_PKGNAMEPREFIX}Products.PluggableAuthService>=0:${PORTSDIR}/security/py-Products.PluggableAuthService
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
#USES= zope
.include <bsd.port.mk>
diff --git a/security/py-zope.authentication/Makefile b/security/py-zope.authentication/Makefile
index 99b5f665fe97..c82d1fe7b167 100644
--- a/security/py-zope.authentication/Makefile
+++ b/security/py-zope.authentication/Makefile
@@ -20,9 +20,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.browser>=0:${PORTSDIR}/devel/py-zope.br
${PYTHON_PKGNAMEPREFIX}zope.schema>=0:${PORTSDIR}/devel/py-zope.schema \
${PYTHON_PKGNAMEPREFIX}zope.security>=0:${PORTSDIR}/security/py-zope.security
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/security/py-zope.login/Makefile b/security/py-zope.login/Makefile
index 655050d63ac7..80176753d8a1 100644
--- a/security/py-zope.login/Makefile
+++ b/security/py-zope.login/Makefile
@@ -18,9 +18,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.authentication>=0:${PORTSDIR}/security/
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
${PYTHON_PKGNAMEPREFIX}zope.publisher>=0:${PORTSDIR}/devel/py-zope.publisher
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/security/quantis-kmod/Makefile b/security/quantis-kmod/Makefile
index b847735883e8..510d1b64af3f 100644
--- a/security/quantis-kmod/Makefile
+++ b/security/quantis-kmod/Makefile
@@ -17,7 +17,7 @@ LICENSE= BSD3CLAUSE GPLv2
LICENSE_COMB= dual
LICENSE_FILE= ${WRKDIR}/Quantis-${DISTVERSION}/License.txt
-USE_ZIP= yes
+USES= zip:infozip
EXTRACT_BEFORE_ARGS= -aqo
WRKSRC= ${WRKDIR}/Quantis-${DISTVERSION}/Drivers/Unix/QuantisPci
diff --git a/security/quantis/Makefile b/security/quantis/Makefile
index 77848398ff19..0ce1a1294c40 100644
--- a/security/quantis/Makefile
+++ b/security/quantis/Makefile
@@ -27,9 +27,8 @@ COMPAT_DESC= Build API v1 compatibility libraries
TOOL_DESC= Build EasyQuantis application
GUI_DESC= Build QT4 GUI for EasyQuantis application
-USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aqo
-USES= cmake
+USES= cmake zip:infozip
USE_QT4= # empty but required
USE_LDCONFIG= yes
diff --git a/security/webscarab/Makefile b/security/webscarab/Makefile
index 0cf77aa6be59..f23673168ad0 100644
--- a/security/webscarab/Makefile
+++ b/security/webscarab/Makefile
@@ -11,7 +11,7 @@ MASTER_SITE_SUBDIR= niels
MAINTAINER= ports@FreeBSD.org
COMMENT= Framework for analysing HTTP and HTTPS web application traffic
-USE_ZIP= YES
+USES= zip
USE_JAVA= YES
JAVA_VERSION= 1.6+
NO_BUILD= yes
diff --git a/security/xml-security/Makefile b/security/xml-security/Makefile
index 323cef707aa6..e0703fdbed8c 100644
--- a/security/xml-security/Makefile
+++ b/security/xml-security/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-
LICENSE= APACHE20
OPTIONS_DEFINE= DOCS EXAMPLES
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/./_/g}
diff --git a/security/xorsearch/Makefile b/security/xorsearch/Makefile
index c1edbb98bacd..2f290977a854 100644
--- a/security/xorsearch/Makefile
+++ b/security/xorsearch/Makefile
@@ -10,7 +10,7 @@ DISTNAME= XORSearch_V1_2_0
MAINTAINER= edwin@mavetju.org
COMMENT= Search for a given string in an XOR or ROL encoded binary file
-USE_ZIP= yes
+USES= zip
WRKSRC= ${WRKDIR}
PLIST_FILES= bin/xorsearch
diff --git a/security/yassl/Makefile b/security/yassl/Makefile
index 087375d8cace..ab5872354a2c 100644
--- a/security/yassl/Makefile
+++ b/security/yassl/Makefile
@@ -10,7 +10,7 @@ COMMENT= Embedded SSL C-Library
LICENSE= GPLv2
-USE_ZIP= yes
+USES= zip
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking \
diff --git a/sysutils/areca-cli/Makefile b/sysutils/areca-cli/Makefile
index 1d8f9d5e6adc..ede471341033 100644
--- a/sysutils/areca-cli/Makefile
+++ b/sysutils/areca-cli/Makefile
@@ -17,7 +17,7 @@ ONLY_FOR_ARCHS= i386 amd64
PERIODICSCRIPT= 407.status-areca-raid
-USE_ZIP= yes
+USES= zip
NO_BUILD= yes
CLI_VER= 1.9.0
diff --git a/sysutils/daa2iso/Makefile b/sysutils/daa2iso/Makefile
index 764fad58941c..0c72dd429df5 100644
--- a/sysutils/daa2iso/Makefile
+++ b/sysutils/daa2iso/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}
MAINTAINER= sylvio@FreeBSD.org
COMMENT= Convert PowerISO DAA files to ISO9660
-USE_ZIP= yes
+USES= zip
WRKSRC= ${WRKDIR}/src
diff --git a/sysutils/dupmerge/Makefile b/sysutils/dupmerge/Makefile
index 37e0a96f43b2..02f06390524f 100644
--- a/sysutils/dupmerge/Makefile
+++ b/sysutils/dupmerge/Makefile
@@ -9,7 +9,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Searches for files with equal content
-USE_ZIP= yes
+USES= zip
MAKE_FLAGS=
MAKEFILE=
LDFLAGS+= -lroken -lcrypt
diff --git a/sysutils/hfsexplorer/Makefile b/sysutils/hfsexplorer/Makefile
index 35d28538f2b2..00106bfe5dc6 100644
--- a/sysutils/hfsexplorer/Makefile
+++ b/sysutils/hfsexplorer/Makefile
@@ -19,7 +19,7 @@ DESKTOP_ENTRIES="hfsexplorer" "reader Mac-formatted harddisk" \
"${DATADIR}/res/icon.png" "${PORTNAME}" \
"System;Utility;Java;" false
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6
diff --git a/sysutils/jdiskreport/Makefile b/sysutils/jdiskreport/Makefile
index 66d40bad8fc5..980db31eb4d2 100644
--- a/sysutils/jdiskreport/Makefile
+++ b/sysutils/jdiskreport/Makefile
@@ -13,7 +13,7 @@ COMMENT= Java program to graphically display disk usage statistics
RUN_DEPENDS= ${JAVAVM}:${PORTSDIR}/java/javavmwrapper
-USE_ZIP= YES
+USES= zip
USE_JAVA= YES
JAVA_VERSION= 1.6+
diff --git a/sysutils/jtopen/Makefile b/sysutils/jtopen/Makefile
index d64d3f0723d7..ce23e564510a 100644
--- a/sysutils/jtopen/Makefile
+++ b/sysutils/jtopen/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/}
MAINTAINER= saper@saper.info
COMMENT= JTOpen is a Java library to access OS/400 or i5/OS system
-USE_ZIP= yes
+USES= zip
NO_WRKSUBDIR= yes
USE_JAVA= 1.4+
diff --git a/sysutils/kshutdown-kde4/Makefile b/sysutils/kshutdown-kde4/Makefile
index 71a648a73a76..80c36c16bfb3 100644
--- a/sysutils/kshutdown-kde4/Makefile
+++ b/sysutils/kshutdown-kde4/Makefile
@@ -10,8 +10,7 @@ DISTNAME= ${PORTNAME}-source-${DISTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Advanced shutdown utility for KDE
-USE_ZIP= yes
-USES= cmake
+USES= cmake zip
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_KDE4= automoc4 kdehier kdeprefix workspace
diff --git a/sysutils/ods2/Makefile b/sysutils/ods2/Makefile
index 8c66759c61a0..d424c714239e 100644
--- a/sysutils/ods2/Makefile
+++ b/sysutils/ods2/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ods2
MAINTAINER= dussuett@wigwam.ethz.ch
COMMENT= An utility for manipulating ODS-2 filesystems
-USE_ZIP= yes
+USES= zip
NO_WRKSUBDIR= yes
MAKEFILE= makefile.unix
MAKE_ARGS= CCFLAGS="${CFLAGS}"
diff --git a/sysutils/pdixtract/Makefile b/sysutils/pdixtract/Makefile
index 1f46008865a0..2a2ceb565b0c 100644
--- a/sysutils/pdixtract/Makefile
+++ b/sysutils/pdixtract/Makefile
@@ -15,7 +15,7 @@ COMMENT= Extracts or converts .pdi file sets to .iso
LICENSE= GPLv2
NO_WRKSUBDIR= yes
-USE_ZIP= yes
+USES= zip
PLIST_FILES= bin/pdixtract
diff --git a/sysutils/rfstool/Makefile b/sysutils/rfstool/Makefile
index 535f1a9c9693..9c796ad8ddd7 100644
--- a/sysutils/rfstool/Makefile
+++ b/sysutils/rfstool/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Read from a Reiser file system
PLIST_FILES= bin/rfstool
-USE_ZIP= yes
+USES= zip
WRKSRC= ${WRKDIR}/rfstool-0.14/RFSTOOL
MAKEFILE= makefile.gcc3x
diff --git a/sysutils/rsyncbackup/Makefile b/sysutils/rsyncbackup/Makefile
index 5b2cbcd80ec6..4641079b9bb1 100644
--- a/sysutils/rsyncbackup/Makefile
+++ b/sysutils/rsyncbackup/Makefile
@@ -16,8 +16,7 @@ PROJECTHOST= rsync-backup
CONFIGSRC= ${WRKSRC}/config
CONFIGFILES= backupset.conf config.conf destinations.conf sources.conf
-USE_ZIP= yes
-USES= perl5
+USES= perl5 zip
NO_BUILD= yes
SUB_FILES= pkg-message
diff --git a/sysutils/searchmonkey/Makefile b/sysutils/searchmonkey/Makefile
index ef3793b36cb7..ee8b321e004c 100644
--- a/sysutils/searchmonkey/Makefile
+++ b/sysutils/searchmonkey/Makefile
@@ -13,8 +13,7 @@ COMMENT= Search using regexes for file names and text
LICENSE= GPLv3 # (or later)
-USES= qmake dos2unix
-USE_ZIP= yes
+USES= qmake dos2unix zip
DOS2UNIX_GLOB= *.cpp *.h
USE_QT4= corelib gui moc_build rcc_build uic_build
diff --git a/sysutils/uif2iso/Makefile b/sysutils/uif2iso/Makefile
index 5dd738389bf7..1df6702782f1 100644
--- a/sysutils/uif2iso/Makefile
+++ b/sysutils/uif2iso/Makefile
@@ -10,8 +10,7 @@ DISTNAME= ${PORTNAME}
MAINTAINER= sylvio@FreeBSD.org
COMMENT= Convert MagicISO UIF files to ISO9660
-USE_ZIP= yes
-
+USES= zip
WRKSRC= ${WRKDIR}/src
PLIST_FILES= bin/uif2iso
diff --git a/sysutils/vstrip/Makefile b/sysutils/vstrip/Makefile
index 00685687cd20..59e2a35984ea 100644
--- a/sysutils/vstrip/Makefile
+++ b/sysutils/vstrip/Makefile
@@ -19,7 +19,7 @@ LDFLAGS+= -lm
PLIST_FILES= bin/${PORTNAME}
-USE_ZIP= yes
+USES= zip
WRKSRC= ${WRKDIR}/${PORTNAME}
post-extract: