aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--converters/fix-mime-charset/files/patch-src_argp-local.h10
-rw-r--r--converters/fix-mime-charset/files/patch-src_decoder.cc10
-rw-r--r--games/crack-attack/files/patch-src_TextureLoader.h10
-rw-r--r--games/galaxyhack/files/patch-JSDL.cpp10
-rw-r--r--graphics/ampasCTL/Makefile4
-rw-r--r--graphics/ampasCTL/files/patch-ctlrender_tiff__file.cc18
-rw-r--r--graphics/ampasCTL/files/patch-lib_IlmCtl_CtlExc.cpp13
-rw-r--r--graphics/graphopt/files/patch-src_classes_nodes.cc9
-rw-r--r--math/ised/files/patch-src_ised.cpp10
9 files changed, 90 insertions, 4 deletions
diff --git a/converters/fix-mime-charset/files/patch-src_argp-local.h b/converters/fix-mime-charset/files/patch-src_argp-local.h
new file mode 100644
index 000000000000..be5ae8c795c4
--- /dev/null
+++ b/converters/fix-mime-charset/files/patch-src_argp-local.h
@@ -0,0 +1,10 @@
+--- src/argp-local.h.orig 2003-11-25 23:51:41 UTC
++++ src/argp-local.h
+@@ -12,6 +12,7 @@
+ #include <getopt.h>
+ #include <string.h>
+ #include <iostream>
++#include <cstdlib>
+
+ #define __need_error_t
+ #include <errno.h>
diff --git a/converters/fix-mime-charset/files/patch-src_decoder.cc b/converters/fix-mime-charset/files/patch-src_decoder.cc
new file mode 100644
index 000000000000..dff13f4623cc
--- /dev/null
+++ b/converters/fix-mime-charset/files/patch-src_decoder.cc
@@ -0,0 +1,10 @@
+--- src/decoder.cc.orig 2003-08-28 18:45:38 UTC
++++ src/decoder.cc
+@@ -1,6 +1,7 @@
+ // @(#) $Id: decoder.cc,v 1.7 2003/08/28 18:45:38 balu Exp $
+
+ #include "decoder.h"
++#include <cstring>
+
+ unsigned char base64_rank[256]=
+ {255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,
diff --git a/games/crack-attack/files/patch-src_TextureLoader.h b/games/crack-attack/files/patch-src_TextureLoader.h
new file mode 100644
index 000000000000..f6ae2a442e18
--- /dev/null
+++ b/games/crack-attack/files/patch-src_TextureLoader.h
@@ -0,0 +1,10 @@
+--- src/TextureLoader.h.orig 2005-04-16 08:13:38 UTC
++++ src/TextureLoader.h
+@@ -27,6 +27,7 @@
+ #ifndef TEXTURELOADER_H
+ #define TEXTURELOADER_H
+
++#include <cstring>
+ #include <GL/glut.h>
+
+ #include "glext.h"
diff --git a/games/galaxyhack/files/patch-JSDL.cpp b/games/galaxyhack/files/patch-JSDL.cpp
new file mode 100644
index 000000000000..bacd8c758b04
--- /dev/null
+++ b/games/galaxyhack/files/patch-JSDL.cpp
@@ -0,0 +1,10 @@
+--- JSDL.cpp.orig 2015-09-20 01:08:54 UTC
++++ JSDL.cpp
+@@ -18,6 +18,7 @@
+ #include <SDL_mixer.h>
+
+ #include <cstdlib>
++#include <cstring>
+ #include <fstream>
+ #include <stdexcept>
+
diff --git a/graphics/ampasCTL/Makefile b/graphics/ampasCTL/Makefile
index 3ae60037e763..93b260196d5a 100644
--- a/graphics/ampasCTL/Makefile
+++ b/graphics/ampasCTL/Makefile
@@ -41,10 +41,6 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|#include <alloca.h>||' \
- ${WRKSRC}/lib/dpx/dpx_util.cc ${WRKSRC}/lib/IlmCtl/CtlExc.cpp \
- ${WRKSRC}/lib/IlmCtl/CtlTypeStorage.cpp ${WRKSRC}/ctlrender/tiff_file.cc
-
@${REINPLACE_CMD} -e 's|lib/CMake|lib/cmake|' \
-e 's|add_subdirectory(doc)||' \
-e 's|lib/pkgconfig|libdata/pkgconfig|' \
diff --git a/graphics/ampasCTL/files/patch-ctlrender_tiff__file.cc b/graphics/ampasCTL/files/patch-ctlrender_tiff__file.cc
new file mode 100644
index 000000000000..91494fdbcb2c
--- /dev/null
+++ b/graphics/ampasCTL/files/patch-ctlrender_tiff__file.cc
@@ -0,0 +1,18 @@
+--- ctlrender/tiff_file.cc.orig 2014-06-03 01:11:24 UTC
++++ ctlrender/tiff_file.cc
+@@ -53,6 +53,7 @@
+ ///////////////////////////////////////////////////////////////////////////
+
+ #include "tiff_file.hh"
++#include <cstdlib>
+ #include <stdarg.h>
+ #include <dpx.hh>
+ #if defined(HAVE_LIBTIFF)
+@@ -61,7 +62,6 @@
+ #include <sys/param.h>
+ #include <math.h>
+ #include <Iex.h>
+-#include <alloca.h>
+
+ void tiff_read_multiplane(TIFF *t, float scale, ctl::dpx::fb<float> * pixels);
+ void tiff_read_interleaved(TIFF *t, float scale, ctl::dpx::fb<float> * pixels);
diff --git a/graphics/ampasCTL/files/patch-lib_IlmCtl_CtlExc.cpp b/graphics/ampasCTL/files/patch-lib_IlmCtl_CtlExc.cpp
new file mode 100644
index 000000000000..de05c3fe7c47
--- /dev/null
+++ b/graphics/ampasCTL/files/patch-lib_IlmCtl_CtlExc.cpp
@@ -0,0 +1,13 @@
+--- lib/IlmCtl/CtlExc.cpp.orig 2014-06-03 01:11:24 UTC
++++ lib/IlmCtl/CtlExc.cpp
+@@ -53,9 +53,9 @@
+ ///////////////////////////////////////////////////////////////////////////
+
+ #include <CtlExc.h>
++#include <cstdlib>
+ #include <stdarg.h>
+ #include <stdio.h>
+-#include <alloca.h>
+ #include <string.h>
+
+ namespace Ctl {
diff --git a/graphics/graphopt/files/patch-src_classes_nodes.cc b/graphics/graphopt/files/patch-src_classes_nodes.cc
new file mode 100644
index 000000000000..05b331ebc257
--- /dev/null
+++ b/graphics/graphopt/files/patch-src_classes_nodes.cc
@@ -0,0 +1,9 @@
+--- src/classes/nodes.cc.intermediate 2015-09-20 00:14:03 UTC
++++ src/classes/nodes.cc
+@@ -1,5 +1,6 @@
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstring>
+ #include "nodes.h"
+
+
diff --git a/math/ised/files/patch-src_ised.cpp b/math/ised/files/patch-src_ised.cpp
new file mode 100644
index 000000000000..26bdefc93f74
--- /dev/null
+++ b/math/ised/files/patch-src_ised.cpp
@@ -0,0 +1,10 @@
+--- src/ised.cpp.orig 2012-09-01 16:10:10 UTC
++++ src/ised.cpp
+@@ -16,6 +16,7 @@
+ **/
+
+ #include <cstdio>
++#include <cstring>
+ #include "vm.h"
+
+ #include <unistd.h>