aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/zabbix/Makefile5
-rw-r--r--net-mgmt/zabbix2/Makefile5
2 files changed, 10 insertions, 0 deletions
diff --git a/net-mgmt/zabbix/Makefile b/net-mgmt/zabbix/Makefile
index 7865b52e6e61..8345aca426fc 100644
--- a/net-mgmt/zabbix/Makefile
+++ b/net-mgmt/zabbix/Makefile
@@ -72,6 +72,11 @@ post-patch:
@${ECHO} 'DisablePinger=yes' >> ${WRKSRC}/misc/conf/zabbix_server.conf
.endif
+pre-configure:
+ @if ldd ${LOCALBASE}/lib/libsqlite3.so 2>&- |${GREP} -q thr;then\
+ ${REINPLACE_CMD} -e 's|-lsqlite3|-lsqlite3 ${PTHREAD_LIBS}|'\
+ ${WRKSRC}/configure; fi
+
.if ${ARCH} == "amd64"
post-configure:
${ECHO_CMD} "#define HAVE_VA_COPY 1" >> ${WRKSRC}/include/config.h
diff --git a/net-mgmt/zabbix2/Makefile b/net-mgmt/zabbix2/Makefile
index 7865b52e6e61..8345aca426fc 100644
--- a/net-mgmt/zabbix2/Makefile
+++ b/net-mgmt/zabbix2/Makefile
@@ -72,6 +72,11 @@ post-patch:
@${ECHO} 'DisablePinger=yes' >> ${WRKSRC}/misc/conf/zabbix_server.conf
.endif
+pre-configure:
+ @if ldd ${LOCALBASE}/lib/libsqlite3.so 2>&- |${GREP} -q thr;then\
+ ${REINPLACE_CMD} -e 's|-lsqlite3|-lsqlite3 ${PTHREAD_LIBS}|'\
+ ${WRKSRC}/configure; fi
+
.if ${ARCH} == "amd64"
post-configure:
${ECHO_CMD} "#define HAVE_VA_COPY 1" >> ${WRKSRC}/include/config.h