aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/dynamips-community/Makefile8
-rw-r--r--emulators/dynamips-community/distinfo6
-rw-r--r--emulators/dynamips-community/files/patch-CMakeLists.txt11
-rw-r--r--emulators/dynamips-community/files/patch-common_dynamips.c32
-rw-r--r--emulators/dynamips-community/files/patch-common_net__io.c15
5 files changed, 40 insertions, 32 deletions
diff --git a/emulators/dynamips-community/Makefile b/emulators/dynamips-community/Makefile
index ae0430e4d891..aed7f30caaa3 100644
--- a/emulators/dynamips-community/Makefile
+++ b/emulators/dynamips-community/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dynamips
-PORTVERSION= 0.2.16
+PORTVERSION= 0.2.17
DISTVERSIONPREFIX= v
CATEGORIES= emulators
PKGNAMESUFFIX= -community
@@ -24,12 +24,13 @@ CONFLICTS= dynamips-[0-9]* dynamips-devel-[0-9]*
USES= cmake
USE_GITHUB= yes
+OPTIONS_DEFINE= DOCS
+
MAKE_JOBS_UNSAFE= yes
GH_ACCOUNT= GNS3
-MAKE_ENV= DYNAMIPS_CODE=${DYNAMIPS_CODE} \
- DYNAMIPS_ARCH=${DYNAMIPS_ARCH}
+CMAKE_ARGS+= -DDYNAMIPS_CODE=${DYNAMIPS_CODE} -DDYNAMIPS_ARCH=${DYNAMIPS_ARCH}
.include <bsd.port.pre.mk>
@@ -52,6 +53,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/man/nvram_export.1 ${STAGEDIR}${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/man/hypervisor_mode.7 ${STAGEDIR}${MANPREFIX}/man/man7
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in README.md README.hypervisor RELEASE-NOTES ChangeLog MAINTAINERS
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
diff --git a/emulators/dynamips-community/distinfo b/emulators/dynamips-community/distinfo
index f51007057f1e..fd0ae0a481d3 100644
--- a/emulators/dynamips-community/distinfo
+++ b/emulators/dynamips-community/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1493198102
-SHA256 (GNS3-dynamips-v0.2.16_GH0.tar.gz) = 0fcf18d701898a77cb589bd9bad16dde436ac1ccb87516fefe07d09de1a196c0
-SIZE (GNS3-dynamips-v0.2.16_GH0.tar.gz) = 832173
+TIMESTAMP = 1506060982
+SHA256 (GNS3-dynamips-v0.2.17_GH0.tar.gz) = d524ef32b78dd7384775920604912d3b4b212ded338cc4df930b0086df1e81ed
+SIZE (GNS3-dynamips-v0.2.17_GH0.tar.gz) = 832721
diff --git a/emulators/dynamips-community/files/patch-CMakeLists.txt b/emulators/dynamips-community/files/patch-CMakeLists.txt
deleted file mode 100644
index 3ace96c86f93..000000000000
--- a/emulators/dynamips-community/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2016-03-16 09:05:47 UTC
-+++ CMakeLists.txt
-@@ -32,7 +32,7 @@ include ( utils )
- include ( dependencies )
- include ( configure )
-
--if(APPLE)
-+if( APPLE OR (CMAKE_SYSTEM_NAME MATCHES "FreeBSD") )
- include_directories(include /usr/local/include/)
- include_directories(include /opt/local/include/)
- endif()
diff --git a/emulators/dynamips-community/files/patch-common_dynamips.c b/emulators/dynamips-community/files/patch-common_dynamips.c
new file mode 100644
index 000000000000..60336bacc9e9
--- /dev/null
+++ b/emulators/dynamips-community/files/patch-common_dynamips.c
@@ -0,0 +1,32 @@
+--- common/dynamips.c.orig 2017-07-24 11:37:51 UTC
++++ common/dynamips.c
+@@ -190,7 +190,7 @@ static void show_usage(vm_instance_t *vm,int argc,char
+ "2691, 3725, 3745, 2600 or 1700) "
+ "(default: 7200)\n\n"
+ " -l <log_file> : Set logging file (default is %s)\n"
+- " -j : Disable the JIT compiler, very slow\n"
++/* " -j : Disable the JIT compiler, very slow\n" */
+ " --idle-pc <pc> : Set the idle PC (default: disabled)\n"
+ " --timer-itv <val> : Timer IRQ interval check (default: %u)\n"
+ "\n"
+@@ -394,7 +394,7 @@ static vm_instance_t *cli_create_instance(char *name,c
+ static int parse_std_cmd_line(int argc,char *argv[])
+ {
+ char *options_list =
+- "r:o:n:c:m:l:C:i:jt:p:s:k:T:U:A:B:a:f:E:b:S:R:M:eXP:N:G:g:L:I:";
++ "r:o:n:c:m:l:C:i:t:p:s:k:T:U:A:B:a:f:E:b:S:R:M:eXP:N:G:g:L:I:";
+ vm_platform_t *platform;
+ vm_instance_t *vm = NULL;
+ int instance_id;
+@@ -563,11 +563,6 @@ static int parse_std_cmd_line(int argc,char *argv[])
+ }
+
+ printf("Using a clock divisor of %d.\n",vm->clock_divisor);
+- break;
+-
+- /* Disable JIT */
+- case 'j':
+- vm->jit_use = FALSE;
+ break;
+
+ /* VM debug level */
diff --git a/emulators/dynamips-community/files/patch-common_net__io.c b/emulators/dynamips-community/files/patch-common_net__io.c
deleted file mode 100644
index d0e2daa11dce..000000000000
--- a/emulators/dynamips-community/files/patch-common_net__io.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- common/net_io.c.orig 2016-03-16 09:05:47 UTC
-+++ common/net_io.c
-@@ -609,9 +609,11 @@ static int netio_tap_open(char *tap_devn
- return(fd);
- #else
- int i,fd = -1;
-+ char tap_fullname[NETIO_DEV_MAXLEN];
-
- if (*tap_devname) {
-- fd = open(tap_devname,O_RDWR);
-+ snprintf(tap_fullname,NETIO_DEV_MAXLEN,"/dev/%s",tap_devname);
-+ fd = open(tap_fullname,O_RDWR);
- } else {
- for(i=0;i<16;i++) {
- snprintf(tap_devname,NETIO_DEV_MAXLEN,"/dev/tap%d",i);