aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-YAPE-Regex-Explain/Makefile25
-rw-r--r--textproc/p5-YAPE-Regex-Explain/distinfo1
-rw-r--r--textproc/p5-YAPE-Regex-Explain/pkg-descr4
-rw-r--r--textproc/p5-YAPE-Regex-Explain/pkg-plist7
5 files changed, 38 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3aef29e82a6f..00b30af7f53e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -302,6 +302,7 @@
SUBDIR += p5-YAML
SUBDIR += p5-YAPE-HTML
SUBDIR += p5-YAPE-Regex
+ SUBDIR += p5-YAPE-Regex-Explain
SUBDIR += p5-dTemplate
SUBDIR += p5-libxml
SUBDIR += p5-podlators
diff --git a/textproc/p5-YAPE-Regex-Explain/Makefile b/textproc/p5-YAPE-Regex-Explain/Makefile
new file mode 100644
index 000000000000..bdbc4d0a8da1
--- /dev/null
+++ b/textproc/p5-YAPE-Regex-Explain/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-YAPE-Regex-Explain
+# Date created: 3 juin 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= YAPE-Regex-Explain
+PORTVERSION= 3.011
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/P/PI/PINYAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Explanation of a Regular Expression
+
+BUILD_DEPENDS= ${SITE_PERL}/YAPE/Regex.pm:${PORTSDIR}/textproc/p5-YAPE-Regex
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= YAPE::Regex::Explain.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-YAPE-Regex-Explain/distinfo b/textproc/p5-YAPE-Regex-Explain/distinfo
new file mode 100644
index 000000000000..f522078be258
--- /dev/null
+++ b/textproc/p5-YAPE-Regex-Explain/distinfo
@@ -0,0 +1 @@
+MD5 (YAPE-Regex-Explain-3.011.tar.gz) = 3e6f3eed266cb52ceec6b1fb70d3e4f8
diff --git a/textproc/p5-YAPE-Regex-Explain/pkg-descr b/textproc/p5-YAPE-Regex-Explain/pkg-descr
new file mode 100644
index 000000000000..74d91e0bf39b
--- /dev/null
+++ b/textproc/p5-YAPE-Regex-Explain/pkg-descr
@@ -0,0 +1,4 @@
+This module merely sub-classes YAPE::Regex, and produces a rather verbose
+explanation of a regex, suitable for demonstration and tutorial purposes.
+
+WWW: http://search.cpan.org/dist/YAPE-Regex-Explain/
diff --git a/textproc/p5-YAPE-Regex-Explain/pkg-plist b/textproc/p5-YAPE-Regex-Explain/pkg-plist
new file mode 100644
index 000000000000..60cff8626a0f
--- /dev/null
+++ b/textproc/p5-YAPE-Regex-Explain/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/YAPE/Regex/Explain.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/YAPE/Regex/Explain/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/YAPE/Regex/Explain
+@unexec rmdir %D/%%SITE_PERL%%/YAPE/Regex 2>/dev/null || true
+@unexec rmdir %D%%SITE_PERL%%/%%PERL_ARCH%%/auto/YAPE/Regex 2>/dev/null || true
+@unexec rmdir %D%%SITE_PERL%%/%%PERL_ARCH%%/auto/YAPE 2>/dev/null || true
+@unexec rmdir %D%%SITE_PERL%%/YAPE 2>/dev/null || true