aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/snownews/Makefile26
-rw-r--r--www/snownews/distinfo1
-rw-r--r--www/snownews/files/patch-Makefile13
-rw-r--r--www/snownews/files/patch-Makefile.inc9
-rw-r--r--www/snownews/pkg-descr23
-rw-r--r--www/snownews/pkg-plist14
7 files changed, 87 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b85f8c1bbd4b..e5d5d48d4370 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -491,6 +491,7 @@
SUBDIR += smb2www
SUBDIR += smb_auth
SUBDIR += snarf
+ SUBDIR += snownews
SUBDIR += squid
SUBDIR += squid24
SUBDIR += squidclients
diff --git a/www/snownews/Makefile b/www/snownews/Makefile
new file mode 100644
index 000000000000..8331a03cb78e
--- /dev/null
+++ b/www/snownews/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# New ports collection makefile for: snownews
+# Date created: Nov 3 2003
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= snownews
+PORTVERSION= 1.3.3
+CATEGORIES= www
+MASTER_SITES= http://home.kcore.de/~kiza/software/snownews/download/
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= A text mode RSS newsreader
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/xml2-config:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
+
+USE_GMAKE= yes
+
+MAN1= snownews.1
+MANLANG= "" de nl fr
+
+.include <bsd.port.mk>
diff --git a/www/snownews/distinfo b/www/snownews/distinfo
new file mode 100644
index 000000000000..05303f33bf17
--- /dev/null
+++ b/www/snownews/distinfo
@@ -0,0 +1 @@
+MD5 (snownews-1.3.3.tar.gz) = 569ab60f18d1e78a9aa1eec534558bb6
diff --git a/www/snownews/files/patch-Makefile b/www/snownews/files/patch-Makefile
new file mode 100644
index 000000000000..2ddc0cefcafb
--- /dev/null
+++ b/www/snownews/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Mon Nov 3 04:41:22 2003
++++ Makefile Tue Nov 4 00:00:15 2003
+@@ -1,8 +1,8 @@
+ include Makefile.inc
+
+-LDFLAGS = -lncurses `xml2-config --libs` $(EXTRA_LDFLAGS)
++LDFLAGS = -lncurses `xml2-config --libs` $(EXTRA_LDFLAGS) -lintl -liconv
+ OBJFILES = main.o netio.o interface.o xmlparse.o updatecheck.o conversions.o dialog.o
+-CFLAGS = -Wall -O2 -DLOCALEPATH="\"$(LOCALEPATH)\"" -DOS=\"$(shell uname)\" `xml2-config --cflags` $(EXTRA_CFLAGS)
++CFLAGS += -DLOCALEPATH="\"$(LOCALEPATH)\"" -DOS=\"$(shell uname)\" `xml2-config --cflags` $(EXTRA_CFLAGS)
+ VERSION = `grep VERSION version.h | sed s/\"//g | sed s/\#define\ VERSION\ //`
+ MAN = doc/man
+ DISTDIR = snownews-$(VERSION)
diff --git a/www/snownews/files/patch-Makefile.inc b/www/snownews/files/patch-Makefile.inc
new file mode 100644
index 000000000000..552bc1ef48cb
--- /dev/null
+++ b/www/snownews/files/patch-Makefile.inc
@@ -0,0 +1,9 @@
+--- Makefile.inc.orig Mon Nov 3 04:41:22 2003
++++ Makefile.inc Tue Nov 4 00:00:24 2003
+@@ -1,5 +1,5 @@
+ CC = gcc
+-MAKE = make
++MAKE = gmake
+ PREFIX = /usr/local
+ LOCALEPATH = $(PREFIX)/share/locale
+ DISTFILES = AUTHOR COPYING CREDITS Changelog README README.de INSTALL INSTALL.solaris INSTALL.FreeOpenNetBSD TODO opml2snow \
diff --git a/www/snownews/pkg-descr b/www/snownews/pkg-descr
new file mode 100644
index 000000000000..0ef784ba3f55
--- /dev/null
+++ b/www/snownews/pkg-descr
@@ -0,0 +1,23 @@
+Snownews is a text mode RSS/RDF newsreader. It supports RSS 1.0 feeds that
+comply with the W3C RDF specification and also supports Radio Userland's
+RSS 0.91 and 2.0 versions.
+
+Features:
+
+ * Runs on Linux, *BSD, OS X (Darwin), Solaris and probably
+ many more Unices. Yes, even works under Cygwin.
+ * Fast and very resource friendly.
+ * Bultin HTTP client will follow server redirects and update feed
+ URLs that point to permanent redirects (301) automatically.
+ * Snownews understands "Not-Modified" (304) server replies and handles
+ gzip/deflate Content-Encoding.
+ * Local cache for minimal network traffic.
+ * HTTP proxy support.
+ * A help menu available throughout the program.
+ * Automatic update checking (can be deactivated).
+ * Few dependencies on external libraries; ncurses and libxml2.
+ * Import feature for OPML subscription lists.
+ * Fully customizable key bindings of all program functions.
+ * Type Ahead Find for quick and easy navigation.
+
+WWW: http://home.kcore.de/~kiza/software/snownews/
diff --git a/www/snownews/pkg-plist b/www/snownews/pkg-plist
new file mode 100644
index 000000000000..2e39a1a7ab3c
--- /dev/null
+++ b/www/snownews/pkg-plist
@@ -0,0 +1,14 @@
+bin/opml2snow
+bin/snownews
+share/locale/de/LC_MESSAGES/snownews.mo
+share/locale/fr/LC_MESSAGES/snownews.mo
+share/locale/nl/LC_MESSAGES/snownews.mo
+share/locale/sl/LC_MESSAGES/snownews.mo
+@unexec rmdir %D/man/fr/man1 2>/dev/null || true
+@unexec rmdir %D/man/fr 2>/dev/null || true
+@unexec rmdir %D/man/de/man1 2>/dev/null || true
+@unexec rmdir %D/man/de 2>/dev/null || true
+@unexec rmdir %D/man/nl/man1 2>/dev/null || true
+@unexec rmdir %D/man/nl 2>/dev/null || true
+@unexec rmdir %D/man/sl/man1 2>/dev/null || true
+@unexec rmdir %D/man/sl 2>/dev/null || true