aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/ncmpcpp/Makefile37
-rw-r--r--audio/snd/Makefile38
-rw-r--r--graphics/silgraphite/Makefile17
-rw-r--r--irc/anope/Makefile13
-rw-r--r--net-im/mcabber/Makefile28
-rw-r--r--net/vnstat/Makefile14
-rw-r--r--x11-fm/gentoo/Makefile16
-rw-r--r--x11-wm/ratpoison/Makefile21
-rw-r--r--x11-wm/wmfs/Makefile23
9 files changed, 88 insertions, 119 deletions
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index 3584dbea6abe..0334df5951bd 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ncmpcpp
-# Date created: August 25 2008
-# Whom: Dennis Herrmann <adox@mcx2.org>
-#
+# Created by: Dennis Herrmann <adox@mcx2.org>
# $FreeBSD$
-#
PORTNAME= ncmpcpp
PORTVERSION= 0.5.10
@@ -30,14 +26,15 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
MAN1= ncmpcpp.1
MAKE_JOBS_SAFE= yes
-OPTIONS= CURL "Enable fetching lyrics from the Internet" on \
- CLOCK "Enable clock-screen support" on \
- UTF8 "Enable UTF8 support" on \
- TAGLIB "Enable taglib support" off \
- OUTPUTS "Enable outputs screen" on \
- VISUALIZER "Enable music visualizer screen" on
+OPTIONS_DEFINE= CURL CLOCK UTF8 TAGLIB OUTPUTS VISUALIZER
+OPTIONS_DEFAULT= CURL CLOCK OUTPUTS VISUALIZER
+CURL_DESC= Enable fetching lyrics from the Internet
+CLOCK_DESC= clock-screen support
+TAGLIB_DESC= taglib support
+OUTPUTS_DESC= Enable outputs screen
+VISUALIZER_DESC= Enable music visualizer screen
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_NCURSES_BASE)
# no need to use ncurses-config if we use ncurses from the base system
@@ -52,46 +49,46 @@ PLIST_FILES= bin/ncmpcpp \
%%DOCSDIR%%/COPYING
PLIST_DIRS= %%DOCSDIR%%
-.if !defined(WITHOUT_CURL)
+.if ${PORT_OPTIONS:MCURL}
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --with-curl
.else
CONFIGURE_ARGS+= --with-curl=no
.endif
-.if !defined(WITHOUT_CLOCK)
+.if ${PORT_OPTIONS:MCLOCK}
CONFIGURE_ARGS+= --enable-clock
.else
CONFIGURE_ARGS+= --disable-clock
.endif
-.if !defined(WITHOUT_UTF8)
+.if ${PORT_OPTIONS:MUTF8}
CONFIGURE_ARGS+= --enable-unicode
.else
CONFIGURE_ARGS+= --disable-unicode
.endif
-.if !defined(WITHOUT_TAGLIB)
+.if ${PORT_OPTIONS:MTAGLIB}
LIB_DEPENDS+= tag:${PORTSDIR}/audio/taglib
CONFIGURE_ARGS+= --with-taglib
.else
CONFIGURE_ARGS+= --with-taglib=no
.endif
-.if !defined(WITHOUT_OUTPUTS)
+.if ${PORT_OPTIONS:MOUTPUTS}
CONFIGURE_ARGS+= --enable-outputs
.else
CONFIGURE_ARGS+= --disable-outputs
.endif
-.if !defined(WITHOUT_VISUALIZER)
+.if ${PORT_OPTIONS:MVISUALIZER}
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
CONFIGURE_ARGS+= --enable-visualizer
.endif
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/ncmpcpp ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/NEWS ${DOCSDIR}/NEWS
@@ -105,4 +102,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG} ""
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/snd/Makefile b/audio/snd/Makefile
index 8b81d0579219..35cb81bbc337 100644
--- a/audio/snd/Makefile
+++ b/audio/snd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: snd
-# Date created: 2000-10-05
-# Whom: trevor
-#
+# Created by: trevor
# $FreeBSD$
-#
PORTNAME= snd
PORTVERSION= 13.0
@@ -14,13 +10,11 @@ MASTER_SITES= ftp://ccrma-ftp.stanford.edu/pub/Lisp/ \
MAINTAINER= dhn@FreeBSD.org
COMMENT= Multitracking sound editor and utilities
-OPTIONS= FFTW3 "Use FFTW" on \
- GSL "Use GNU Scientific Library" on \
- S7 "Use S7 as the extension language" off \
- LADSPA "Include support for LADSPA plugins" on \
- MOTIF "Make Snd with Motif graphics support" off \
- GTK2 "Make Snd with Gtk+ graphics support" on \
- X11 "Make Snd with GUI support" on
+OPTIONS_DEFINE= FFTW3 GSL S7 LADSPA MOTIF GTK2 X11 DOCS EXAMPLES
+OPTIONS_DEFAULT= FFTW3 GSL LADSPA GTK2 X11
+FFTW3_DESC= Use FFTW
+GSL_DESC= Use GNU Scientific Library
+S7_DESC= Use S7 as the extension language
WANT_GNOME= yes
GNU_CONFIGURE= yes
@@ -41,41 +35,41 @@ LDFLAGS+= -L${LOCALBASE}/lib
BROKEN= does not compile on sparc64
.endif
-.if !defined(WITHOUT_FFTW3)
+.if ${PORT_OPTIONS:MFFTW3}
LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3
.else
CONFIGURE_ARGS+= --without-fftw
.endif
-.if !defined(WITHOUT_GSL)
+.if ${PORT_OPTIONS:MGSL}
LIB_DEPENDS+= gsl.16:${PORTSDIR}/math/gsl
.else
CONFIGURE_ARGS+= --without-gsl
.endif
-.if !defined(WITHOUT_S7)
+.if ${PORT_OPTIONS:MS7}
CONFIGURE_ARGS+= --with-s7
.else
CONFIGURE_ARGS+= --without-s7
.endif
-.if !defined(WITHOUT_LADSPA)
+.if ${PORT_OPTIONS:MLADSPA}
BUILD_DEPENDS+= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
RUN_DEPENDS+= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
.else
CONFIGURE_ARGS+= --without-ladspa
.endif
-.if defined(WITH_GTK2)
+.if ${PORT_OPTIONS:MGTK2}
USE_GNOME+= gtk20
CONFIGURE_ARGS+= --with-gtk
.endif
-.if defined(WITH_MOTIF)
+.if ${PORT_OPTIONS:MMOTIG}
USE_MOTIF= yes
CONFIGURE_ARGS+= --with-motif
.endif
-.if defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
CONFIGURE_ARGS+= --with-no-gui
.endif
@@ -91,7 +85,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/bin
.endfor
${INSTALL_MAN} ${WRKSRC}/snd.1 ${MANPREFIX}/man/man1/
-.if !defined(WITHOUT_S7)
+.if ${PORT_OPTIONS:MS7}
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.scm ${DATADIR}
@${MKDIR} ${DATADIR}/tools
@@ -99,7 +93,7 @@ do-install:
@${MKDIR} ${DATADIR}/sndins/samples
${INSTALL_DATA} ${WRKSRC}/sndins/samples/*.scm ${DATADIR}/sndins/samples
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in HISTORY.Snd README.Snd
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
@@ -109,7 +103,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/pix/*.png ${DOCSDIR}/pix
cd ${WRKSRC} && ${PAX} -r -w tutorial ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/DotEmacs ${EXAMPLESDIR}
.endif
diff --git a/graphics/silgraphite/Makefile b/graphics/silgraphite/Makefile
index 0cff22de1b3c..3bf0f5501adc 100644
--- a/graphics/silgraphite/Makefile
+++ b/graphics/silgraphite/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: silgraphite
-# Date created: 30 November 2008
-# Whom: Dennis Herrmann <adox@mcx2.org>
-#
+# Created by: Dennis Herrmann <adox@mcx2.org>
# $FreeBSD$
-#
PORTNAME= silgraphite
PORTVERSION= 2.3.1
@@ -13,16 +9,17 @@ MASTER_SITES= SF
MAINTAINER= dhn@FreeBSD.org
COMMENT= Font engine for complex non-Roman writing systems
-OPTIONS= FREETYPE "Build with Freetype support" on
+OPTIONS_DEFINE= FREETYPE
+OPTIONS_DEFAULT= FREETYPE
-USE_GNOME= pkgconfig
+USE_PKGCONFIG= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-xft --without-pangographite
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_FREETYPE)
+.if ${PORT_OPTIONS:MFREETYPE}
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
USE_ICONV= yes
CONFIGURE_ARGS+= --with-freetype
@@ -36,4 +33,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|$${PREFIX}/libdata/pkgconfig|g' \
${WRKSRC}/engine/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/anope/Makefile b/irc/anope/Makefile
index 075b309b6267..a7f220367345 100644
--- a/irc/anope/Makefile
+++ b/irc/anope/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: anope
-# Date created: 13/04/2004
-# Whom: mat
-#
+# Created by: mat
# $FreeBSD$
-#
PORTNAME= anope
PORTVERSION= 1.8.7
@@ -28,7 +24,8 @@ PORTDOCS= BUGS COPYING DEFCON EVENTS \
USE_RC_SUBR= anope
-OPTIONS= MYSQL "Use mysql" ON
+OPTIONS_DEFINE= MYSQL
+OPTIONS_DEFAULT= MYSQL
.include <bsd.port.pre.mk>
@@ -37,7 +34,7 @@ OPTIONS= MYSQL "Use mysql" ON
CFLAGS+= -fPIC
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
.else
CONFIGURE_ARGS+= --without-mysql
@@ -48,7 +45,7 @@ pre-install:
@${MKDIR} ${DATADIR}
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDCOS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/docs/,} ${DOCSDIR}/
.endif
diff --git a/net-im/mcabber/Makefile b/net-im/mcabber/Makefile
index 87534e2fe627..eb8b9144e51d 100644
--- a/net-im/mcabber/Makefile
+++ b/net-im/mcabber/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mcabber
-# Date created: 2005-10-05
-# Whom: vsevolod
-#
+# Created by: vsevolod
# $FreeBSD$
-#
PORTNAME= mcabber
PORTVERSION= 0.10.1
@@ -32,35 +28,37 @@ USE_GNOME= glib20
MAN1= mcabber.1
-OPTIONS= GPGME "Use security/gpgme for PGP support" off \
- OTR "Off-the-record messaging support" off \
- ASPELL "Use textproc/aspell for spell checking" off \
- ENCHANT "Use texproc/enchant for spell checking" off
+OPTIONS_DEFINE= GPGME OTR
+OPTIONS_RADIO= SPELL
+OPTIONS_RADIO_SPELL= ASPELL ENCHANT
+GPGME_DESC= Use security/gpgme for PGP support
+OTR_DESC= Off-the-record messaging support
+ENCHANT_DESC= Spell checking via enchant
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GPGME)
+.if ${PORT_OPTIONS:MGPGME}
LIB_DEPENDS+= gpgme.19:${PORTSDIR}/security/gpgme
CONFIGURE_ARGS+=--enable-gpgme
.else
CONFIGURE_ARGS+=--disable-gpgme
.endif
-.if defined(WITH_ASPELL) && !defined(WITH_ENCHANT)
+.if ${PORT_OPTIONS:MASPELL}
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+=--enable-aspell
.else
CONFIGURE_ARGS+=--disable-aspell
.endif
-.if defined(WITH_ENCHANT)
+.if ${PORT_OPTIONS:MENCHANT}
LIB_DEPENDS+= enchant.1:${PORTSDIR}/textproc/enchant
CONFIGURE_ARGS+=--enable-enchant
.else
CONFIGURE_ARGS+=--disable-enchant
.endif
-.if defined(WITH_OTR)
+.if ${PORT_OPTIONS:MOTR}
LIB_DEPENDS+= otr.4:${PORTSDIR}/security/libotr3 \
gcrypt.18:${PORTSDIR}/security/libgcrypt
CONFIGURE_ARGS+=--enable-otr
@@ -82,4 +80,4 @@ post-install:
@${CP} -R ${WRKSRC}/contrib ${DATADIR}/
${INSTALL_DATA} ${WRKSRC}/mcabberrc.example ${EXAMPLESDIR}/mcabberrc
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/vnstat/Makefile b/net/vnstat/Makefile
index 0a08965ba3c5..29824e464d2c 100644
--- a/net/vnstat/Makefile
+++ b/net/vnstat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: vnstat
-# Date created: February 17, 2008
-# Whom: Dennis Herrmann <adox@mcx2.org>
-#
+# Created by: Dennis Herrmann <adox@mcx2.org>
# $FreeBSD$
-#
PORTNAME= vnstat
PORTVERSION= 1.11
@@ -26,7 +22,9 @@ PORTDOCS= README INSTALL_BSD UPGRADE vnstat-cron
SUB_FILES= pkg-message
# will compile with image output
-OPTIONS= GUI "Build with graphics/gd dependency" on
+OPTIONS_DEFINE= GUI DOCS
+OPTIONS_DEFAULT= GUI
+GUI_DESC= Build with graphics/gd dependency
.include <bsd.port.options.mk>
@@ -35,7 +33,7 @@ PLIST_FILES= bin/vnstat \
%%GUI%%bin/vnstati \
etc/vnstat.conf.sample
-.if !defined(WITHOUT_GUI)
+.if ${PORT_OPTIONS:MGUI}
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
PLIST_SUB+= GUI=""
MAN1+= vnstati.1
@@ -59,7 +57,7 @@ post-patch:
${WRKSRC}/src/cfg.c
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
diff --git a/x11-fm/gentoo/Makefile b/x11-fm/gentoo/Makefile
index 498b494c215e..76a7c90075e3 100644
--- a/x11-fm/gentoo/Makefile
+++ b/x11-fm/gentoo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gentoo
-# Date created: 12 August 2001
-# Whom: Anders Nordby <anders@fix.no>
-#
+# Created by: Anders Nordby <anders@fix.no>
# $FreeBSD$
-#
PORTNAME= gentoo
PORTVERSION= 0.19.13
@@ -15,7 +11,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/ \
MAINTAINER= dhn@FreeBSD.org
COMMENT= Gtk+ based, file manager inspired by DirectoryOpus
-OPTIONS= FAM "File Alteration Monitor Support" off
+OPTIONS_DEFINE= FAM DOCS
USE_GNOME= gnomehack gtk20
USE_GETTEXT= yes
@@ -27,9 +23,9 @@ MAN1= gentoo.1
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_FAM)
+.if ${PORT_OPTIONS:MFAM}
USE_FAM= yes
.else
CONFIGURE_ARGS+= --disable-fam
@@ -46,7 +42,7 @@ post-patch:
post-install:
${INSTALL_MAN} ${WRKSRC}/docs/gentoo.1x ${MANPREFIX}/man/man1/gentoo.1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in BUGS CONFIG-CHANGES CREDITS NEWS README README.NLS README.gtkrc \
TODO
@@ -59,4 +55,4 @@ post-install:
@${FIND} ${DOCSDIR} -type d | ${XARGS} ${CHMOD} a+x
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/ratpoison/Makefile b/x11-wm/ratpoison/Makefile
index 811becd5bd09..f8c5f9e39fe2 100644
--- a/x11-wm/ratpoison/Makefile
+++ b/x11-wm/ratpoison/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ratpoison
-# Date created: January 20, 2001
-# Whom: Gergely Nagy <8@free.bsd.hu>
-#
+# Created by: Gergely Nagy <8@free.bsd.hu>
# $FreeBSD$
-#
PORTNAME= ratpoison
PORTVERSION= 1.4.5
@@ -19,16 +15,17 @@ COMMENT= Simple window manager with no fat library dependencies
USE_XORG= xext xinerama xtst
GNU_CONFIGURE= yes
-OPTIONS= GDM_SUPPORT "Install session data files for GDM" off
+OPTIONS_DEFINE= GDM_SUPPORT DOCS
+GDM_SUPPORT_DESC= Install session data files for GDM
SUB_FILES= ratpoison.desktop
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
post-patch:
${REINPLACE_CMD} -e 's|bash|sh|g' ${WRKSRC}/contrib/allwindows.sh
-.if defined (WITH_GDM_SUPPORT)
+.if ${PORT_OPTIONS:MGDM_SUPPORT}
PLIST_SUB+= WITH_GDM=""
post-install:
@@ -38,11 +35,11 @@ post-install:
PLIST_SUB+= WITH_GDM="@comment "
.endif
-.if defined(NOPORTDOCS)
-INSTALL_TARGET= SUBDIRS=src install-exec
-.else
+.if ${PORT_OPTIONS:MDOCS}
MAN1= ratpoison.1
INFO= ratpoison
+.else
+INSTALL_TARGET= SUBDIRS=src install-exec
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/wmfs/Makefile b/x11-wm/wmfs/Makefile
index 926cd1441475..87daa5ce8107 100644
--- a/x11-wm/wmfs/Makefile
+++ b/x11-wm/wmfs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmfs
-# Date created: 08 December 2008
-# Whom: Dennis Herrmann <adox@mcx2.org>
-#
+# Created by: Dennis Herrmann <adox@mcx2.org>
# $FreeBSD$
-#
PORTNAME= wmfs
DISTVERSION= 201104
@@ -19,7 +15,7 @@ LICENSE= BSD
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
-USE_GNOME= pkgconfig
+USE_PKGCONFIG= build
USE_XORG= x11 xft xpm
HAS_CONFIGURE= yes
@@ -28,29 +24,28 @@ MANCOMPRESSED= yes
SUB_FILES= pkg-message
-OPTIONS= XRANDR "Enable xrandr support" on \
- XINERAMA "Enable xinerama support" on \
- IMLIB "Enable Imlib2 support" on
+OPTIONS_DEFINE= XRANDR XINERAMA IMLIB
+OPTIONS_DEFAULT= XRANDR XINERAMA IMLIB
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
CONFIGURE_ARGS= --prefix ${PREFIX} \
--man-prefix ${MANPREFIX}/man \
--xdg-config-dir ${PREFIX}/etc/xdg
-.if defined(WITH_XRANDR)
+.if ${PORT_OPTIONS:MXRANDR}
USE_XORG+= xrandr
.else
CONFIGURE_ARGS+= --without-xrandr
.endif
-.if defined(WITH_XINERAMA)
+.if ${PORT_OPTIONS:MXINERAMA}
USE_XORG+= xinerama
.else
CONFIGURE_ARGS+= --without-xinerama
.endif
-.if defined(WITH_IMLIB)
+.if ${PORT_OPTIONS:MIMLIB}
USE_EFL+= imlib2
.else
CONFIGURE_ARGS+= --without-imlib2
@@ -59,4 +54,4 @@ CONFIGURE_ARGS+= --without-imlib2
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>