aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/xa65/Makefile61
-rw-r--r--devel/xa65/distinfo2
-rw-r--r--devel/xa65/pkg-descr6
4 files changed, 70 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fbaf8fb36c6c..04bb7edd9c20 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4440,6 +4440,7 @@
SUBDIR += winpdb
SUBDIR += wizardkit
SUBDIR += wxGlade
+ SUBDIR += xa65
SUBDIR += xc3sprog
SUBDIR += xdg-user-dirs
SUBDIR += xdg-utils
diff --git a/devel/xa65/Makefile b/devel/xa65/Makefile
new file mode 100644
index 000000000000..1750ac590bf8
--- /dev/null
+++ b/devel/xa65/Makefile
@@ -0,0 +1,61 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= xa
+PORTVERSION= 2.3.5
+CATEGORIES= devel
+MASTER_SITES= http://www.floodgap.com/retrotech/xa/dists/
+PKGNAMESUFFIX= 65
+
+MAINTAINER= uffe@uffe.org
+COMMENT= MOS-6502 two-pass cross-assembler for MOS 6502 and compatible CPUs
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+USES= gmake
+
+MAN1= file65.1 ldo65.1 printcbm.1 reloc65.1 uncpk.1 xa.1
+MLINKS= xa.1 xa65.1
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+PLIST_FILES= bin/xa65 \
+ bin/file65 \
+ bin/ldo65 \
+ bin/reloc65 \
+ bin/printcbm \
+ bin/uncpk
+
+post-patch-script:
+.for i in CC LDFLAGS CFLAGS
+ @${REINPLACE_CMD} 's|${i} = |${i} ?= |g' ${WRKSRC}/Makefile
+.endfor
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xa ${PREFIX}/bin/xa65
+.for file in file65 ldo65 reloc65 printcbm uncpk
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+
+.for man in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/man/${man} ${MAN1PREFIX}/man/man1
+.endfor
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for doc in COPYING ChangeLog README.1st TODO
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/xa65/distinfo b/devel/xa65/distinfo
new file mode 100644
index 000000000000..bccce51c708a
--- /dev/null
+++ b/devel/xa65/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xa-2.3.5.tar.gz) = 9cada4128a096169e5acba66b03b5e954ce4201ebb8aefeacb7025ffc0decdd2
+SIZE (xa-2.3.5.tar.gz) = 132551
diff --git a/devel/xa65/pkg-descr b/devel/xa65/pkg-descr
new file mode 100644
index 000000000000..80d0500e9307
--- /dev/null
+++ b/devel/xa65/pkg-descr
@@ -0,0 +1,6 @@
+xa is a high-speed, two-pass portable cross-assembler.
+It understands mnemonics and generates code for:
+NMOS 6502s (such as 6502A, 6504, 6507, 6510, 7501, 8500, 8501, 8502 ...)
+CMOS 6502s (65C02 and Rockwell R65C02) and the 65816.
+
+WWW: http://www.floodgap.com/retrotech/xa/