aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/tangogps/Makefile3
-rw-r--r--audio/gimmix/Makefile1
-rw-r--r--audio/streamtranscoder/Makefile3
-rw-r--r--deskutils/mdh/Makefile1
-rw-r--r--games/crossfire-server/Makefile1
-rw-r--r--games/f1spirit-remake/Makefile1
-rw-r--r--games/kuklomenos/Makefile1
-rw-r--r--games/megaglest/Makefile4
-rw-r--r--games/springlobby/Makefile3
-rw-r--r--misc/esniper/Makefile3
-rw-r--r--misc/gkrellm-helium/Makefile1
-rw-r--r--misc/sword/Makefile2
-rw-r--r--multimedia/xine/Makefile1
-rw-r--r--net-p2p/gtorrentviewer/Makefile3
-rw-r--r--net/nepenthes/Makefile8
-rw-r--r--net/wmlj/Makefile3
-rw-r--r--net/xmlrpc-c/Makefile4
-rw-r--r--security/authforce/Makefile1
-rw-r--r--sysutils/ckl/Makefile3
-rw-r--r--textproc/raptor/Makefile3
-rw-r--r--www/mod_flickr/Makefile3
21 files changed, 53 insertions, 0 deletions
diff --git a/astro/tangogps/Makefile b/astro/tangogps/Makefile
index 92d322abed9b..4a223ae93fdd 100644
--- a/astro/tangogps/Makefile
+++ b/astro/tangogps/Makefile
@@ -28,4 +28,7 @@ USE_GNOME= gtk20 gconf2 libxml2
USE_SQLITE= 3
INSTALLS_ICONS= yes
+post-patch:
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/src/tile_management.c ${WRKSRC}/src/util.h ${WRKSRC}/src/friends.c
+
.include <bsd.port.mk>
diff --git a/audio/gimmix/Makefile b/audio/gimmix/Makefile
index 979ecc342c22..a2eb2739d582 100644
--- a/audio/gimmix/Makefile
+++ b/audio/gimmix/Makefile
@@ -49,5 +49,6 @@ PLIST_SUB+= NLS="@comment "
post-patch:
@${LN} -sf ${LOCALBASE}/share/intltool/Makefile.in.in ${WRKSRC}/po/Makefile.in.in
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/src/gimmix-covers.c ${WRKSRC}/src/gimmix-lyrics.c
.include <bsd.port.mk>
diff --git a/audio/streamtranscoder/Makefile b/audio/streamtranscoder/Makefile
index 0c2dadda8a5d..d4c64ee0bc49 100644
--- a/audio/streamtranscoder/Makefile
+++ b/audio/streamtranscoder/Makefile
@@ -31,6 +31,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|-D_REENTRANT|${PTHREAD_CFLAGS}|g; \
s|-pthread|${PTHREAD_LIBS}|g; s|-O20|$$CFLAGS|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' \
+ ${WRKSRC}/aclocal.m4 ${WRKSRC}/configure \
+ ${WRKSRC}/src/libtranscoder/transcurl.cpp
post-install:
.if !defined(NOPORTDOCS)
diff --git a/deskutils/mdh/Makefile b/deskutils/mdh/Makefile
index 9dc248508927..3a03975138f4 100644
--- a/deskutils/mdh/Makefile
+++ b/deskutils/mdh/Makefile
@@ -43,6 +43,7 @@ post-patch:
s|@INSTALL@ -m 0775|@INSTALL_PROGRAM@|g ; \
s|cp -p|@INSTALL_DATA@|g' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e 's|"getopt\.h"|<getopt.h>|g' ${WRKSRC}/src/mdh.c
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/src/curl.c
post-install:
.if !defined(NOPORTDOCS)
diff --git a/games/crossfire-server/Makefile b/games/crossfire-server/Makefile
index a28df53add9c..6893275527b6 100644
--- a/games/crossfire-server/Makefile
+++ b/games/crossfire-server/Makefile
@@ -48,6 +48,7 @@ post-patch:
s|-ldl||g ; \
s|python[{].*[}]|${PYTHON_VERSION}|g ; \
s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/socket/metaserver.c
post-install:
@${MKDIR} ${DATADIR}/maps
diff --git a/games/f1spirit-remake/Makefile b/games/f1spirit-remake/Makefile
index 027e9859b67d..136bf07cb234 100644
--- a/games/f1spirit-remake/Makefile
+++ b/games/f1spirit-remake/Makefile
@@ -34,6 +34,7 @@ post-patch:
-e 's|"demos"|"${DATADIR}/demos"|g; s|designs/|${DATADIR}/&|g; \
s|f1spirit2.cfg|${DATADIR}/&|g; s|graphics/|${DATADIR}/&|g; \
s|sound/|${DATADIR}/&|g; s|tracks/|${DATADIR}/&|g'
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/sources/F1Shttp.cpp
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/f1s ${PREFIX}/bin
diff --git a/games/kuklomenos/Makefile b/games/kuklomenos/Makefile
index 336dcd752dc3..70edc15bc697 100644
--- a/games/kuklomenos/Makefile
+++ b/games/kuklomenos/Makefile
@@ -40,5 +40,6 @@ post-patch:
's|<SDL/SDL_mixer.h>|"SDL_mixer.h"|g' ${WRKSRC}/SDL_mixer/load_ogg.c
@${REINPLACE_CMD} -e \
'/^sounds_DATA/s|Makefile.am||g' ${WRKSRC}/sounds/Makefile.in
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/net.cc
.include <bsd.port.post.mk>
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 5330d4b55f49..791e1791cec2 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -45,6 +45,10 @@ PLIST_SUB+= EDITOR=""
PLIST_SUB+= EDITOR="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' \
+ ${WRKSRC}/source/shared_lib/sources/platform/posix/miniftpclient.cpp
+
do-install:
${STRIP_CMD} ${WRKSRC}/mk/linux/megaglest
@${MKDIR} ${DATADIR}
diff --git a/games/springlobby/Makefile b/games/springlobby/Makefile
index b0e09ba42493..d9bd3c33516f 100644
--- a/games/springlobby/Makefile
+++ b/games/springlobby/Makefile
@@ -53,6 +53,9 @@ CMAKE_ARGS+= -DOPTION_SOUND:BOOL=OFF
.endif
post-patch:
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' \
+ ${WRKSRC}/src/utils/curlhelper.h \
+ ${WRKSRC}/src/utils/downloader.cpp
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e '/install.*FILES.*share\/doc/ d' \
${WRKSRC}/CMakeLists.txt
diff --git a/misc/esniper/Makefile b/misc/esniper/Makefile
index 6d0622559066..11c9afa93e41 100644
--- a/misc/esniper/Makefile
+++ b/misc/esniper/Makefile
@@ -25,6 +25,9 @@ PLIST_FILES= bin/esniper
PORTEXAMPLES= sample_auction.txt sample_config.txt
+post-patch:
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/http.c
+
post-install:
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
diff --git a/misc/gkrellm-helium/Makefile b/misc/gkrellm-helium/Makefile
index d818a6d5d114..df964a385ed9 100644
--- a/misc/gkrellm-helium/Makefile
+++ b/misc/gkrellm-helium/Makefile
@@ -28,5 +28,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/lib/gkrellm2/plugins|${PREFIX}/libexec/gkrellm2/plugins| ; \
s|CFLAGS =|CFLAGS?=| ; s|-lcurl|-lcurl -L${LOCALBASE}/lib|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|ulong|u_long|' ${WRKSRC}/*.c
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/http_net.c
.include <bsd.port.mk>
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index 749ac5265ca4..6f9807fccf9c 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -51,6 +51,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|:=|=|' ${WRKSRC}/Makefile.am \
${WRKSRC}/Makefile.in ${WRKSRC}/lib/Makefile.am \
${WRKSRC}/lib/Makefile.in
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' \
+ ${WRKSRC}/src/mgr/curlhttpt.cpp ${WRKSRC}/src/mgr/curlftpt.cpp
post-install:
@${MKDIR} ${PREFIX}/share/sword/mods.d
diff --git a/multimedia/xine/Makefile b/multimedia/xine/Makefile
index f7551abc8d5e..849b2864deb0 100644
--- a/multimedia/xine/Makefile
+++ b/multimedia/xine/Makefile
@@ -117,6 +117,7 @@ post-patch:
's|THREAD_LIBS=.*$$|THREAD_LIBS="\$$THREAD_LIBS"|g ; \
s|THREAD_CFLAGS=.*$$|THREAD_CFLAGS="\$$THREAD_CFLAGS"|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/src/xitk/download.c
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/net-p2p/gtorrentviewer/Makefile b/net-p2p/gtorrentviewer/Makefile
index 8b8c2cf59416..216ebf4b2819 100644
--- a/net-p2p/gtorrentviewer/Makefile
+++ b/net-p2p/gtorrentviewer/Makefile
@@ -29,6 +29,9 @@ CONFIGURE_ARGS= --with-pixmapsdir=${PREFIX}/share/pixmaps \
MAN1= gtorrentviewer.1
DOCS= AUTHORS COPYING ChangeLog README
+post-patch:
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/src/main.c
+
.ifndef (NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
diff --git a/net/nepenthes/Makefile b/net/nepenthes/Makefile
index 594152501bfb..4dcee0c5cc12 100644
--- a/net/nepenthes/Makefile
+++ b/net/nepenthes/Makefile
@@ -37,5 +37,13 @@ MAN8= nepenthes.8
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e 's,-Werror,,'
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' \
+ ${WRKSRC}/modules/download-curl/download-curl.hpp \
+ ${WRKSRC}/modules/submit-http/HTTPSession.hpp \
+ ${WRKSRC}/modules/submit-http/HTTPSession.cpp \
+ ${WRKSRC}/modules/submit-http/submit-http.hpp \
+ ${WRKSRC}/modules/submit-mwserv/TransferSession.hpp \
+ ${WRKSRC}/modules/submit-mwserv/submit-mwserv.hpp \
+ ${WRKSRC}/modules/submit-norman/submit-norman.hpp
.include <bsd.port.mk>
diff --git a/net/wmlj/Makefile b/net/wmlj/Makefile
index 033cfe40cfed..e1dee4bc1c5a 100644
--- a/net/wmlj/Makefile
+++ b/net/wmlj/Makefile
@@ -22,4 +22,7 @@ USE_GNOME= gtk12
MAN1= wmlj.1
PLIST_FILES= bin/wmlj
+post-patch:
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/src/network.c
+
.include <bsd.port.mk>
diff --git a/net/xmlrpc-c/Makefile b/net/xmlrpc-c/Makefile
index bcec7ca0bd7e..81df816fdba3 100644
--- a/net/xmlrpc-c/Makefile
+++ b/net/xmlrpc-c/Makefile
@@ -62,5 +62,9 @@ post-patch:
's|-lpthread|${PTHREAD_LIBS}|g'
@${REINPLACE_CMD} -e '/#include.*features.h/d' \
${WRKSRC}/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' \
+ ${WRKSRC}/lib/curl_transport/curltransaction.c \
+ ${WRKSRC}/lib/curl_transport/xmlrpc_curl_transport.c \
+ ${WRKSRC}/lib/curl_transport/curlmulti.c
.include <bsd.port.post.mk>
diff --git a/security/authforce/Makefile b/security/authforce/Makefile
index fe894a1c5ffd..8eec30d6b046 100644
--- a/security/authforce/Makefile
+++ b/security/authforce/Makefile
@@ -30,5 +30,6 @@ post-patch:
@${REINPLACE_CMD} -e '/#include <malloc.h>/d' ${WRKSRC}/src/methods.c ${WRKSRC}/src/misc.c
@${REINPLACE_CMD} -e 's|#include <malloc.h>|#include <stdlib.h>|' ${WRKSRC}/src/extract.c
@${REINPLACE_CMD} -e '/^pwlistsdir = / s|/data$$||' ${WRKSRC}/data/Makefile.in
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/src/http.c
.include <bsd.port.mk>
diff --git a/sysutils/ckl/Makefile b/sysutils/ckl/Makefile
index b7d5c35295aa..aae56ad6f743 100644
--- a/sysutils/ckl/Makefile
+++ b/sysutils/ckl/Makefile
@@ -22,6 +22,9 @@ USE_BZIP2= yes
PORTDOCS= CHANGES LICENSE NOTICE README
+post-patch:
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/src/ckl.h
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/ckl ${PREFIX}/bin
diff --git a/textproc/raptor/Makefile b/textproc/raptor/Makefile
index 7d573bfca8e0..4f6b5f007f43 100644
--- a/textproc/raptor/Makefile
+++ b/textproc/raptor/Makefile
@@ -34,4 +34,7 @@ post-extract:
${REINPLACE_CMD} -e 's|utils ||' \
${WRKSRC}/Makefile.in
+post-patch:
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/src/raptor_internal.h
+
.include <bsd.port.mk>
diff --git a/www/mod_flickr/Makefile b/www/mod_flickr/Makefile
index 373bbd4c8f0c..ae7f7dfa99a4 100644
--- a/www/mod_flickr/Makefile
+++ b/www/mod_flickr/Makefile
@@ -34,4 +34,7 @@ USE_APACHE= 20+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
+post-patch:
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/mod_flickr.c
+
.include <bsd.port.mk>