aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/celestia/Makefile4
-rw-r--r--dns/drill/Makefile8
-rw-r--r--sysutils/cfengine2/Makefile8
-rw-r--r--sysutils/dd_rescue/Makefile8
4 files changed, 25 insertions, 3 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 620d750902d7..4fa9963d51ee 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -41,6 +41,10 @@ OPTIONS= LUA "Lua support" off \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
.if defined(WITH_LUA)
LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua
CONFIGURE_ARGS+= --with-lua
diff --git a/dns/drill/Makefile b/dns/drill/Makefile
index 5b29e9ea5491..0a87ba75855a 100644
--- a/dns/drill/Makefile
+++ b/dns/drill/Makefile
@@ -27,4 +27,10 @@ CONFIGURE_ARGS= --prefix=${PREFIX}
PLIST_FILES= bin/drill
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cfengine2/Makefile b/sysutils/cfengine2/Makefile
index eb635fe260a5..bad9c0f2275e 100644
--- a/sysutils/cfengine2/Makefile
+++ b/sysutils/cfengine2/Makefile
@@ -39,4 +39,10 @@ LDFLAGS+= -L${LOCALBASE}/lib/db41 -ldb41
.error WITH_BDB_VER must be 41 or 42
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/dd_rescue/Makefile b/sysutils/dd_rescue/Makefile
index 293e6e98e2d9..2b4e5098f74b 100644
--- a/sysutils/dd_rescue/Makefile
+++ b/sysutils/dd_rescue/Makefile
@@ -16,6 +16,12 @@ COMMENT= A dd tool suitable for rescuing data from a medium with errors
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= default
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dd_rescue ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@@ -23,4 +29,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README.dd_rescue ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>