aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/elasticsearch/Makefile83
-rw-r--r--textproc/elasticsearch/distinfo2
-rw-r--r--textproc/elasticsearch/files/elasticsearch-plugin.in17
-rw-r--r--textproc/elasticsearch/files/elasticsearch.in127
-rw-r--r--textproc/elasticsearch/files/patch-config-elasticsearch.yml35
-rw-r--r--textproc/elasticsearch/pkg-descr4
-rw-r--r--textproc/elasticsearch/pkg-plist30
10 files changed, 301 insertions, 0 deletions
diff --git a/GIDs b/GIDs
index 8251e2eae241..27bd440f89e8 100644
--- a/GIDs
+++ b/GIDs
@@ -244,5 +244,6 @@ gearmand:*:961:
zookeeper:*:962:
fluentd:*:963:
git_daemon:*:964:
+elasticsearch:*:965:
nogroup:*:65533:
nobody:*:65534:
diff --git a/UIDs b/UIDs
index 89823932d6f7..97b05beab5c0 100644
--- a/UIDs
+++ b/UIDs
@@ -248,4 +248,5 @@ gearmand:*:961:961::0:0:gearmand daemon:/var/empty:/usr/sbin/nologin
zookeeper:*:962:962::0:0:zookeeper user:/nonexistent:/usr/sbin/nologin
fluentd:*:963:963::0:0:fluentd user:/nonexistent:/usr/sbin/nologin
git_daemon:*:964:964::0:0:git daemon:/nonexistent:/usr/sbin/nologin
+elasticsearch:*:965:965::0:0:elasticsearch user:/nonexistent:/usr/sbin/nologin
nobody:*:65534:65534::0:0:Unprivileged user:/nonexistent:/usr/sbin/nologin
diff --git a/textproc/Makefile b/textproc/Makefile
index a6767bec6e38..1ec9e3cc9cf0 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -152,6 +152,7 @@
SUBDIR += ekhtml
SUBDIR += el-aspell
SUBDIR += el-hyphen
+ SUBDIR += elasticsearch
SUBDIR += emacs-wiki
SUBDIR += en-aspell
SUBDIR += en-hunspell
diff --git a/textproc/elasticsearch/Makefile b/textproc/elasticsearch/Makefile
new file mode 100644
index 000000000000..0f4dd198c395
--- /dev/null
+++ b/textproc/elasticsearch/Makefile
@@ -0,0 +1,83 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= elasticsearch
+PORTVERSION= 0.19.12
+CATEGORIES= textproc java devel
+MASTER_SITES= http://cloud.github.com/downloads/${PORTNAME}/${PORTNAME}/
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= A full-text search engine for Java
+
+LICENSE= AL2
+
+USE_ZIP= yes
+USE_JAVA= yes
+NO_BUILD= yes
+JAVA_VERSION= 1.5+
+ONLY_FOR_ARCHS= i386 amd64
+USE_RC_SUBR= ${PORTNAME}
+
+.include <bsd.port.options.mk>
+
+LUCENEVER= 3.6.1
+CONFIG_FILES= elasticsearch.yml logging.yml
+JARS= elasticsearch-${PORTVERSION}.jar \
+ jna-3.3.0.jar \
+ log4j-1.2.17.jar \
+ lucene-analyzers-${LUCENEVER}.jar \
+ lucene-core-${LUCENEVER}.jar \
+ lucene-highlighter-${LUCENEVER}.jar \
+ lucene-memory-${LUCENEVER}.jar \
+ lucene-queries-${LUCENEVER}.jar \
+ snappy-java-1.0.4.1.jar
+DOCS= LICENSE.txt \
+ NOTICE.txt \
+ README.textile
+
+SIGAR_ARCH= ${ARCH:S|i386|x86|}
+SEARCHUSER?= elasticsearch
+SEARCHGROUP?= ${SEARCHUSER}
+USERS= ${SEARCHUSER}
+GROUPS= ${SEARCHGROUP}
+ELASTIC_DBDIR= /var/db/elasticsearch
+ELASTIC_LOGDIR= /var/log/elasticsearch
+
+SUB_LIST= SEARCHUSER=${SEARCHUSER} SEARCHGROUP=${SEARCHGROUP}
+SUB_FILES= elasticsearch-plugin
+PLIST_SUB= SIGAR_ARCH=${SIGAR_ARCH} \
+ SEARCHUSER=${SEARCHUSER} \
+ SEARCHGROUP=${SEARCHGROUP} \
+ LUCENEVER=${LUCENEVER} \
+ PORTVERSION=${PORTVERSION} \
+ ELASTIC_DBDIR=${ELASTIC_DBDIR} \
+ ELASTIC_LOGDIR=${ELASTIC_LOGDIR}
+
+post-patch:
+ ${SED} -i .bak -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/elasticsearch.yml
+
+do-install:
+ ${INSTALL} -d -o ${SEARCHUSER} -g ${SEARCHUSER} -m 750 ${PREFIX}/etc/elasticsearch
+.for f in ${CONFIG_FILES}
+ ${INSTALL} -o ${SEARCHUSER} -g ${SEARCHUSER} -m 444 ${WRKSRC}/config/${f} ${PREFIX}/etc/elasticsearch/${f}.sample
+ @if [ ! -f ${CONFIG_DIR}/${f} ]; then \
+ ${CP} -p ${PREFIX}/etc/elasticsearch/${f}.sample ${PREFIX}/etc/elasticsearch/${f} ; \
+ fi
+.endfor
+ ${INSTALL_SCRIPT} ${WRKDIR}/elasticsearch-plugin ${PREFIX}/bin/elasticsearch-plugin
+ ${MKDIR} ${PREFIX}/lib/elasticsearch
+.for f in ${JARS}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${PREFIX}/lib/elasticsearch/
+.endfor
+
+ ${MKDIR} ${PREFIX}/lib/elasticsearch/sigar
+ ${INSTALL_DATA} ${WRKSRC}/lib/sigar/sigar-1.6.4.jar ${PREFIX}/lib/elasticsearch/sigar/
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/elasticsearch/distinfo b/textproc/elasticsearch/distinfo
new file mode 100644
index 000000000000..f695c690e0f9
--- /dev/null
+++ b/textproc/elasticsearch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (elasticsearch-0.19.12.zip) = d293b091841d64e51ce6bdef381aff34b46e92a529568bcb13a97d2306479567
+SIZE (elasticsearch-0.19.12.zip) = 15558899
diff --git a/textproc/elasticsearch/files/elasticsearch-plugin.in b/textproc/elasticsearch/files/elasticsearch-plugin.in
new file mode 100644
index 000000000000..5f076c49f349
--- /dev/null
+++ b/textproc/elasticsearch/files/elasticsearch-plugin.in
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# $FreeBSD$
+. /etc/rc.subr
+
+name=elasticsearch
+rcvar=elasticsearch_enable
+load_rc_config $name
+
+: ${elasticsearch_config:="%%PREFIX%%/etc/elasticsearch/elasticsearch.yml"}
+
+ES_LIB="%%PREFIX%%/lib/elasticsearch"
+ES_CLASSPATH=$ES_LIB/elasticsearch-0.19.9.jar:$ES_LIB/*:$ES_LIB/sigar/*
+
+JAVA=%%LOCALBASE%%/bin/java
+
+exec $JAVA $JAVA_OPTS -Xmx64m -Xms16m -Delasticsearch -Des.config=${elasticsearch_config} -cp $ES_CLASSPATH org.elasticsearch.plugins.PluginManager $*
diff --git a/textproc/elasticsearch/files/elasticsearch.in b/textproc/elasticsearch/files/elasticsearch.in
new file mode 100644
index 000000000000..97a9a50e0c5f
--- /dev/null
+++ b/textproc/elasticsearch/files/elasticsearch.in
@@ -0,0 +1,127 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: elasticsearch
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf to enable elasticsearch:
+#
+# elasticsearch_enable="YES"
+#
+# elasticsearch_user (username): Set to elasticsearch by default.
+# Set it to required username.
+# elasticsearch_group (group): Set to elasticsearch by default.
+# Set it to required group.
+# elasticsearch_config (path): Set to /usr/local/etc/elasticsearch/elasticsearch.yml by default.
+# Set it to the config file location.
+# elasticsearch_min_mem (num): Minumum JVM heap size, 256m by default.
+# elasticsearch_max_mem (num): Maximum JVM heap size, 1g by default.
+# elasticsearch_props (args): Additional java properties or arguments.
+# elasticsearch_tmp (path): Set to /var/tmp/elasticsearch by default.
+# Set it to the path to be used for temp files.
+#
+. /etc/rc.subr
+
+name=elasticsearch
+rcvar=elasticsearch_enable
+load_rc_config $name
+
+: ${elasticsearch_enable:="NO"}
+: ${elasticsearch_user:=%%SEARCHUSER%%}
+: ${elasticsearch_group:=%%SEARCHGROUP%%}
+: ${elasticsearch_config:="%%PREFIX%%/etc/elasticsearch/elasticsearch.yml"}
+: ${elasticsearch_min_mem:="256m"}
+: ${elasticsearch_max_mem:="1g"}
+: ${elasticsearch_props:=""}
+: ${elasticsearch_tmp:="/var/tmp/elasticsearch"}
+
+# Force the JVM to use IPv4 stack
+# elasticshearch_props"-Djava.net.preferIPv4Stack=true"
+
+required_files="${elasticsearch_config}"
+pidfile="/var/run/${name}.pid"
+
+ES_LIB="%%PREFIX%%/lib/elasticsearch"
+ES_CLASSPATH=$ES_LIB/elasticsearch-0.19.9.jar:$ES_LIB/*:$ES_LIB/sigar/*
+
+
+java_options=" -server \
+ -Xms${elasticsearch_min_mem} \
+ -Xmx${elasticsearch_max_mem} \
+ -Xss256k \
+ -Djava.awt.headless=true \
+ -XX:+UseParNewGC \
+ -XX:+UseConcMarkSweepGC \
+ -XX:CMSInitiatingOccupancyFraction=75 \
+ -XX:+UseCMSInitiatingOccupancyOnly \
+ -XX:+HeapDumpOnOutOfMemoryError \
+ -Delasticsearch \
+ -Des.config=${elasticsearch_config} \
+ -cp ${ES_CLASSPATH}"
+
+extra_commands="console status"
+console_cmd="elasticsearch_console"
+start_precmd="elasticsearch_precmd"
+status_cmd="elasticsearch_status"
+stop_cmd="elasticsearch_stop"
+command="/usr/sbin/daemon"
+command_args="-f %%LOCALBASE%%/bin/java -Des.pidfile=${pidfile} ${elasticsearch_props} ${java_options} org.elasticsearch.bootstrap.ElasticSearch"
+
+elasticsearch_precmd() {
+ touch ${pidfile}
+ chown ${elasticsearch_user}:${elasticsearch_group} ${pidfile}
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 ${elasticsearch_tmp}
+}
+
+elasticsearch_console () {
+ %%LOCALBASE%%/bin/java -Des.foreground=yes ${elasticsearch_props} ${java_options} org.elasticsearch.bootstrap.ElasticSearch
+}
+
+
+elasticsearch_stop() {
+ rc_pid=$(elasticsearch_check_pidfile $pidfile)
+
+ if [ -z "$rc_pid" ]; then
+ [ -n "$rc_fast" ] && return 0
+ echo "${name} not running? (check $pidfile)."
+ return 1
+ fi
+
+ echo "Stopping ${name}."
+ kill ${rc_pid} 2> /dev/null
+}
+
+elasticsearch_status() {
+ rc_pid=$(elasticsearch_check_pidfile $pidfile)
+
+ if [ -z "$rc_pid" ]; then
+ [ -n "$rc_fast" ] && return 0
+ echo "${name} not running? (check $pidfile)."
+ return 1
+ fi
+ echo "${name} is running as pid ${rc_pid}."
+}
+
+elasticsearch_check_pidfile() {
+ _pidfile=$1
+ if [ -z "$_pidfile" ]; then
+ err 3 'USAGE: elasticsearch_check_pidfile pidfile'
+ fi
+ if [ ! -f $_pidfile ]; then
+ debug "pid file ($_pidfile): not readable."
+ return
+ fi
+ read _pid _junk < $_pidfile
+ if [ -z "$_pid" ]; then
+ debug "pid file ($_pidfile): no pid in file."
+ return
+ fi
+ if [ -n "`%%LOCALBASE%%/bin/jps -l | grep -e "^$_pid org.elasticsearch.bootstrap.ElasticSearch\$"`" ]; then
+ echo -n $_pid
+ fi
+}
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/textproc/elasticsearch/files/patch-config-elasticsearch.yml b/textproc/elasticsearch/files/patch-config-elasticsearch.yml
new file mode 100644
index 000000000000..1c23ab037ead
--- /dev/null
+++ b/textproc/elasticsearch/files/patch-config-elasticsearch.yml
@@ -0,0 +1,35 @@
+--- config/elasticsearch.yml.orig 2012-10-26 11:18:09.000000000 -0400
++++ config/elasticsearch.yml 2012-10-26 11:25:29.000000000 -0400
+@@ -140,11 +140,11 @@
+
+ # Path to directory containing configuration (this file and logging.yml):
+ #
+-# path.conf: /path/to/conf
++path.conf: %%PREFIX%%/etc/elasticsearch
+
+ # Path to directory where to store index data allocated for this node.
+ #
+-# path.data: /path/to/data
++path.data: /var/db/elasticsearch
+ #
+ # Can optionally include more than one location, causing data to be striped across
+ # the locations (à la RAID 0) on a file level, favouring locations with most free
+@@ -154,15 +154,15 @@
+
+ # Path to temporary files:
+ #
+-# path.work: /path/to/work
++path.work: /var/tmp/elasticsearch
+
+ # Path to log files:
+ #
+-# path.logs: /path/to/logs
++path.logs: /var/log/elasticsearch
+
+ # Path to where plugins are installed:
+ #
+-# path.plugins: /path/to/plugins
++path.plugins: %%PREFIX%%/lib/elasticsearch/plugins
+
+
+ #################################### Plugin ###################################
diff --git a/textproc/elasticsearch/pkg-descr b/textproc/elasticsearch/pkg-descr
new file mode 100644
index 000000000000..a4d6442315f0
--- /dev/null
+++ b/textproc/elasticsearch/pkg-descr
@@ -0,0 +1,4 @@
+Elasticsearch aims to be a Distributed, RESTful, Search Engine built on top of
+Apache Lucene.
+
+WWW: http://www.elasticsearch.org/
diff --git a/textproc/elasticsearch/pkg-plist b/textproc/elasticsearch/pkg-plist
new file mode 100644
index 000000000000..e8a19dccefd4
--- /dev/null
+++ b/textproc/elasticsearch/pkg-plist
@@ -0,0 +1,30 @@
+@unexec if cmp -s %D/etc/elasticsearch/elasticsearch.yml.sample %D/etc/elasticsearch/elasticsearch.yml; then rm -f %D/etc/elasticsearch/elasticsearch.yml; fi
+etc/elasticsearch/elasticsearch.yml.sample
+@exec if [ ! -f %D/etc/elasticsearch/elasticsearch.yml ] ; then cp -p %D/%F %B/elasticsearch.yml; fi
+@unexec if cmp -s %D/etc/elasticsearch/logging.yml.sample %D/etc/elasticsearch/logging.yml; then rm -f %D/etc/elasticsearch/logging.yml; fi
+etc/elasticsearch/logging.yml.sample
+@exec if [ ! -f %D/etc/elasticsearch/logging.yml ] ; then cp -p %D/%F %B/logging.yml; fi
+@exec install -d -o %%SEARCHUSER%% -g %%SEARCHGROUP%% %%ELASTIC_DBDIR%%
+@dirrmtry %%ELASTIC_LOGDIR%%
+@unexec if [ -d %%ELASTIC_LOGDIR%% ]; then echo "You should remove %%ELASTIC_LOGDIR%% if you don't need it any more."; fi
+@exec install -d -o %%SEARCHUSER%% -g %%SEARCHGROUP%% %%ELASTIC_LOGDIR%%
+@dirrmtry %%ELASTIC_DBDIR%%
+@unexec if [ -d %%ELASTIC_DBDIR%% ]; then echo "You should remove %%ELASTIC_DBDIR%% if you don't need it any more."; fi
+bin/elasticsearch-plugin
+lib/elasticsearch/elasticsearch-%%PORTVERSION%%.jar
+lib/elasticsearch/jna-3.3.0.jar
+lib/elasticsearch/log4j-1.2.17.jar
+lib/elasticsearch/lucene-analyzers-%%LUCENEVER%%.jar
+lib/elasticsearch/lucene-core-%%LUCENEVER%%.jar
+lib/elasticsearch/lucene-highlighter-%%LUCENEVER%%.jar
+lib/elasticsearch/lucene-memory-%%LUCENEVER%%.jar
+lib/elasticsearch/lucene-queries-%%LUCENEVER%%.jar
+lib/elasticsearch/snappy-java-1.0.4.1.jar
+lib/elasticsearch/sigar/sigar-1.6.4.jar
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/NOTICE.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.textile
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry etc/elasticsearch
+@dirrm lib/elasticsearch/sigar
+@dirrm lib/elasticsearch