aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/cjs/Makefile4
-rw-r--r--x11/cinnamon/Makefile3
2 files changed, 4 insertions, 3 deletions
diff --git a/lang/cjs/Makefile b/lang/cjs/Makefile
index 1ef9d4b90405..189f77d64e78 100644
--- a/lang/cjs/Makefile
+++ b/lang/cjs/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
CONFLICTS_BUILD=spidermonkey17-1.7.*
-USES= autoreconf:build gettext libtool gmake pathfix pkgconfig python:build \
- shebangfix
+USES= autoreconf:build compiler:c11 gettext libtool gmake \
+ pathfix pkgconfig python:build shebangfix
USE_GNOME= cairo glib20 gnomeprefix introspection:build \
intlhack
USE_LDCONFIG= yes
diff --git a/x11/cinnamon/Makefile b/x11/cinnamon/Makefile
index 3894a702e6a4..6bdcf929b2ae 100644
--- a/x11/cinnamon/Makefile
+++ b/x11/cinnamon/Makefile
@@ -37,7 +37,8 @@ RUN_DEPENDS= py*-dbus>=0:${PORTSDIR}/devel/py-dbus \
WRKSRC= ${WRKDIR}/Cinnamon-${PORTVERSION}
-USES= autoreconf:build gettext gmake libtool pathfix pkgconfig python shebangfix
+USES= autoreconf:build compiler:c11 gettext gmake libtool \
+ pathfix pkgconfig python shebangfix
USE_GNOME= evolutiondataserver3 gconf2 gnomedesktop3 \
gnomeprefix gtk30 intlhack introspection:build
# this happens before moving the file to ${PREFIX} (which then will be copied to ${STAGEDIR}${PREFIX})