aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/openobex/Makefile14
-rw-r--r--comms/openobex/distinfo6
-rw-r--r--comms/openobex/files/patch-aclocal.m417
-rw-r--r--comms/openobex/files/patch-configure.in20
-rw-r--r--comms/openobex/files/patch-src-btobex.c110
-rw-r--r--comms/openobex/files/patch-src-netbuf.h11
-rw-r--r--comms/openobex/files/patch-src-obex.c26
-rw-r--r--comms/openobex/files/patch-src-obex.h11
-rw-r--r--comms/openobex/files/patch-src-obex_const.h11
-rw-r--r--comms/openobex/files/patch-src-obex_main.c26
-rw-r--r--comms/openobex/files/patch-src-obex_transport.h36
-rw-r--r--comms/openobex/pkg-plist5
12 files changed, 30 insertions, 263 deletions
diff --git a/comms/openobex/Makefile b/comms/openobex/Makefile
index 7d7cf5d69a2f..4a383dbb1b7e 100644
--- a/comms/openobex/Makefile
+++ b/comms/openobex/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openobex
-PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTVERSION= 1.3
CATEGORIES= comms net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,10 +14,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mad@madpilot.net
COMMENT= Open source implementation of the OBEX protocol
-USE_AUTOTOOLS= automake:14:env autoheader:253 autoconf:253 libtool:15
+USE_AUTOTOOLS= automake:14:env autoheader:259 autoconf:259 libtool:15
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --program-transform-name=""
+CONFIGURE_ARGS+= --program-transform-name="" \
+ --disable-usb
+
+post-configure:
+ @ ${REINPLACE_CMD} -e "s|pkgconfigdir =.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g" \
+ ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/comms/openobex/distinfo b/comms/openobex/distinfo
index 3a73dd02a180..cbe7ef0f79ed 100644
--- a/comms/openobex/distinfo
+++ b/comms/openobex/distinfo
@@ -1,3 +1,3 @@
-MD5 (openobex-1.0.1.tar.gz) = 3742666bb98259face76be49b73ea89d
-SHA256 (openobex-1.0.1.tar.gz) = 0661c15e8b5786c9a220d0257ca339b14fbde174e9eb45962ee605bdfa4d9ed8
-SIZE (openobex-1.0.1.tar.gz) = 211696
+MD5 (openobex-1.3.tar.gz) = feaa5dfe5151c0e70e8f868fa4648a43
+SHA256 (openobex-1.3.tar.gz) = 3a80ba2524c66a46db3ac17a788a759015a1f79de6a495fcdf3a316e19fe7c23
+SIZE (openobex-1.3.tar.gz) = 337614
diff --git a/comms/openobex/files/patch-aclocal.m4 b/comms/openobex/files/patch-aclocal.m4
index b184bc0ec824..161e4bbfb0a2 100644
--- a/comms/openobex/files/patch-aclocal.m4
+++ b/comms/openobex/files/patch-aclocal.m4
@@ -1,9 +1,10 @@
---- aclocal.m4.orig Wed Jun 16 19:59:04 2004
-+++ aclocal.m4 Wed Jun 16 20:26:17 2004
-@@ -67,6 +67,36 @@
- BLUETOOTH_HOOK([],failure)
- ])
+--- aclocal.m4.orig Wed Jun 14 15:58:25 2006
++++ aclocal.m4 Sat Nov 25 21:55:24 2006
+@@ -6914,6 +6914,37 @@
+ # AM_CONFIG_HEADER is obsolete. It has been replaced by AC_CONFIG_HEADERS.
+ AU_DEFUN([AM_CONFIG_HEADER], [AC_CONFIG_HEADERS($@)])
++
+dnl adding a check for FreeBSD blutooth netgraph support.
+
+AC_DEFUN([FREEBSD_BLUETOOTH_HOOK],[
@@ -34,6 +35,6 @@
+ FREEBSD_BLUETOOTH_HOOK([],failure)
+])
+
- # Do all the work for Automake. This macro actually does too much --
- # some checks are only needed if your package does certain things.
- # But this isn't really a big deal.
+ # Do all the work for Automake. -*- Autoconf -*-
+
+ # Copyright (C) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
diff --git a/comms/openobex/files/patch-configure.in b/comms/openobex/files/patch-configure.in
index 5db48999a68e..8d72db97db70 100644
--- a/comms/openobex/files/patch-configure.in
+++ b/comms/openobex/files/patch-configure.in
@@ -1,16 +1,10 @@
---- configure.in.orig Wed Oct 1 13:17:13 2003
-+++ configure.in Sat Nov 20 03:25:29 2004
-@@ -39,12 +39,12 @@
-
- IRDA_CHECK
- BLUETOOTH_CHECK
+--- configure.in.orig Wed Jun 14 11:24:13 2006
++++ configure.in Sat Nov 25 21:56:52 2006
+@@ -22,6 +22,7 @@
+ AC_PATH_IRDA
+ AC_PATH_BLUEZ
+ AC_PATH_USB
+FREEBSD_BLUETOOTH_CHECK
- dnl Configure debug facilities
- AC_ARG_WITH(debug,[ --with-debug=level Debug level],
- debug_level="$withval", debug_level="")
+ AC_ARG_OPENOBEX
--CFLAGS="-O2"
- if test "$debug_level" != ""; then
- AC_DEFINE_UNQUOTED([OBEX_DEBUG],$debug_level, [debug level])
- CFLAGS="-g -O1"
diff --git a/comms/openobex/files/patch-src-btobex.c b/comms/openobex/files/patch-src-btobex.c
deleted file mode 100644
index ec549aa4d707..000000000000
--- a/comms/openobex/files/patch-src-btobex.c
+++ /dev/null
@@ -1,110 +0,0 @@
---- src/btobex.c.orig Mon Mar 22 18:31:43 2004
-+++ src/btobex.c Mon Mar 22 18:44:46 2004
-@@ -46,8 +46,12 @@
- #include <netinet/in.h>
- #include <sys/socket.h>
-
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+#include <bluetooth.h>
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- #include <bluetooth/bluetooth.h>
- #include <bluetooth/rfcomm.h>
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
-
- #endif /* _WIN32 */
-
-@@ -65,6 +69,15 @@
- void btobex_prepare_connect(obex_t *self, bdaddr_t *src, bdaddr_t *dst, uint8_t channel)
- {
- #ifndef _WIN32
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+ self->trans.self.rfcomm.rfcomm_family = AF_BLUETOOTH;
-+ bacpy(&self->trans.self.rfcomm.rfcomm_bdaddr, src);
-+ self->trans.self.rfcomm.rfcomm_channel = 0;
-+
-+ self->trans.peer.rfcomm.rfcomm_family = AF_BLUETOOTH;
-+ bacpy(&self->trans.peer.rfcomm.rfcomm_bdaddr, dst);
-+ self->trans.peer.rfcomm.rfcomm_channel = channel;
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- self->trans.self.rfcomm.rc_family = AF_BLUETOOTH;
- bacpy(&self->trans.self.rfcomm.rc_bdaddr, src);
- self->trans.self.rfcomm.rc_channel = 0;
-@@ -72,6 +85,7 @@
- self->trans.peer.rfcomm.rc_family = AF_BLUETOOTH;
- bacpy(&self->trans.peer.rfcomm.rc_bdaddr, dst);
- self->trans.peer.rfcomm.rc_channel = channel;
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
- #endif /* _WIN32 */
- }
-
-@@ -85,9 +99,15 @@
- {
- #ifndef _WIN32
- /* Bind local service */
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+ self->trans.self.rfcomm.rfcomm_family = AF_BLUETOOTH;
-+ bacpy(&self->trans.self.rfcomm.rfcomm_bdaddr, src);
-+ self->trans.self.rfcomm.rfcomm_channel = channel;
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- self->trans.self.rfcomm.rc_family = AF_BLUETOOTH;
- bacpy(&self->trans.self.rfcomm.rc_bdaddr, src);
- self->trans.self.rfcomm.rc_channel = channel;
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
- #endif /* _WIN32 */
- }
-
-@@ -108,9 +128,15 @@
- return -1;
- }
-
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+ if (bind(self->serverfd, (struct sockaddr*) &self->trans.self.rfcomm,
-+ sizeof(struct sockaddr_rfcomm)))
-+ {
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- if (bind(self->serverfd, (struct sockaddr*) &self->trans.self.rfcomm,
- sizeof(struct sockaddr_rc)))
- {
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
- DEBUG(0, "Error doing bind\n");
- goto out_freesock;
- }
-@@ -142,7 +168,11 @@
- int btobex_accept(obex_t *self)
- {
- #ifndef _WIN32
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+ int addrlen = sizeof(struct sockaddr_rfcomm);
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- int addrlen = sizeof(struct sockaddr_rc);
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
- //int mtu;
- //int len = sizeof(int);
-
-@@ -180,16 +210,26 @@
- return -1;
- }
-
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+ ret = bind(self->fd, (struct sockaddr*) &self->trans.self.rfcomm,
-+ sizeof(struct sockaddr_rfcomm));
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- ret = bind(self->fd, (struct sockaddr*) &self->trans.self.rfcomm,
- sizeof(struct sockaddr_rc));
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
-
- if (ret < 0) {
- DEBUG(4, "ret=%d\n", ret);
- goto out_freesock;
- }
-
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+ ret = connect(self->fd, (struct sockaddr*) &self->trans.peer.rfcomm,
-+ sizeof(struct sockaddr_rfcomm));
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- ret = connect(self->fd, (struct sockaddr*) &self->trans.peer.rfcomm,
- sizeof(struct sockaddr_rc));
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
- if (ret < 0) {
- DEBUG(4, "ret=%d\n", ret);
- goto out_freesock;
diff --git a/comms/openobex/files/patch-src-netbuf.h b/comms/openobex/files/patch-src-netbuf.h
deleted file mode 100644
index cdf1d0c31600..000000000000
--- a/comms/openobex/files/patch-src-netbuf.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/netbuf.h.orig Wed Oct 1 13:17:13 2003
-+++ src/netbuf.h Mon Mar 22 10:47:07 2004
-@@ -37,7 +37,7 @@
- #ifndef G_NETBUF_H
- #define G_NETBUF_H
-
--#include <stdint.h>
-+#include <sys/types.h>
-
- typedef struct _slist_t{
- void *data;
diff --git a/comms/openobex/files/patch-src-obex.c b/comms/openobex/files/patch-src-obex.c
deleted file mode 100644
index 9091c8e6c917..000000000000
--- a/comms/openobex/files/patch-src-obex.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/obex.c.orig Mon Mar 22 18:16:53 2004
-+++ src/obex.c Mon Mar 22 18:21:35 2004
-@@ -990,7 +990,11 @@
-
- #ifdef HAVE_BLUETOOTH
- if(src == NULL)
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+ src = NG_HCI_BDADDR_ANY;
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- src = BDADDR_ANY;
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
- btobex_prepare_listen(self, src, channel);
- return obex_transport_listen(self);
- #else
-@@ -1019,7 +1023,11 @@
-
- #ifdef HAVE_BLUETOOTH
- if(src == NULL)
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+ src = NG_HCI_BDADDR_ANY;
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- src = BDADDR_ANY;
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
- btobex_prepare_connect(self, src, dst, channel);
- return obex_transport_connect_request(self);
- #else
diff --git a/comms/openobex/files/patch-src-obex.h b/comms/openobex/files/patch-src-obex.h
deleted file mode 100644
index 59d2835dbbb9..000000000000
--- a/comms/openobex/files/patch-src-obex.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/obex.h.orig Wed Oct 1 13:17:13 2003
-+++ src/obex.h Mon Mar 22 11:11:11 2004
-@@ -30,7 +30,7 @@
- #ifndef OBEX_H
- #define OBEX_H
-
--#include <stdint.h>
-+#include <sys/types.h>
-
- #ifdef _WIN32
- #include <winsock.h>
diff --git a/comms/openobex/files/patch-src-obex_const.h b/comms/openobex/files/patch-src-obex_const.h
deleted file mode 100644
index a1c522b023ef..000000000000
--- a/comms/openobex/files/patch-src-obex_const.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/obex_const.h.orig Wed Oct 1 13:17:13 2003
-+++ src/obex_const.h Mon Mar 22 10:44:58 2004
-@@ -30,8 +30,6 @@
- #ifndef OBEX_CONST_H
- #define OBEX_CONST_H
-
--#include <stdint.h>
--
- typedef union {
- uint32_t bq4;
- uint8_t bq1;
diff --git a/comms/openobex/files/patch-src-obex_main.c b/comms/openobex/files/patch-src-obex_main.c
deleted file mode 100644
index 174b0e933385..000000000000
--- a/comms/openobex/files/patch-src-obex_main.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/obex_main.c.orig Mon Mar 22 18:25:05 2004
-+++ src/obex_main.c Mon Mar 22 18:27:55 2004
-@@ -46,7 +46,11 @@
- #include <stdio.h>
-
- #ifdef HAVE_BLUETOOTH
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+#include <bluetooth.h>
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- #include <bluetooth/bluetooth.h>
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
- #endif /*HAVE_BLUETOOTH*/
-
- #endif /* _WIN32 */
-@@ -79,7 +83,11 @@
-
- #ifdef HAVE_BLUETOOTH
- if (domain == AF_BLUETOOTH)
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+ proto = BLUETOOTH_PROTO_RFCOMM;
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- proto = BTPROTO_RFCOMM;
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
- #endif /*HAVE_BLUETOOTH*/
-
- fd = socket(domain, SOCK_STREAM, proto);
diff --git a/comms/openobex/files/patch-src-obex_transport.h b/comms/openobex/files/patch-src-obex_transport.h
deleted file mode 100644
index 19157b1a42bc..000000000000
--- a/comms/openobex/files/patch-src-obex_transport.h
+++ /dev/null
@@ -1,36 +0,0 @@
---- src/obex_transport.h.orig Mon Mar 22 18:02:08 2004
-+++ src/obex_transport.h Mon Mar 22 18:05:08 2004
-@@ -40,8 +40,12 @@
- #include "irda_wrap.h"
- #endif /*HAVE_IRDA*/
- #ifdef HAVE_BLUETOOTH
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+#include <bluetooth.h>
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- #include <bluetooth/bluetooth.h>
- #include <bluetooth/rfcomm.h>
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
- #endif /*HAVE_BLUETOOTH*/
-
- #include "obex_main.h"
-@@ -52,7 +56,11 @@
- #endif /*HAVE_IRDA*/
- struct sockaddr_in inet;
- #ifdef HAVE_BLUETOOTH
-+#ifdef HAVE_BLUETOOTH_NETGRAPH
-+ struct sockaddr_rfcomm rfcomm;
-+#else /*HAVE_BLUETOOTH_NETGRAPH*/
- struct sockaddr_rc rfcomm;
-+#endif /*HAVE_BLUETOOTH_NETGRAPH*/
- #endif /*HAVE_BLUETOOTH*/
- } saddr_t;
-
-@@ -76,7 +84,4 @@
- int obex_transport_read(obex_t *self, int count, uint8_t *buf, int buflen);
-
-
--#endif OBEX_TRANSPORT_H
--
--
--
-+#endif /*OBEX_TRANSPORT_H*/
diff --git a/comms/openobex/pkg-plist b/comms/openobex/pkg-plist
index a9c8e83efcd0..168250fecd3c 100644
--- a/comms/openobex/pkg-plist
+++ b/comms/openobex/pkg-plist
@@ -1,10 +1,9 @@
-bin/openobex-config
include/openobex/obex.h
include/openobex/obex_const.h
-lib/libopenobex-1.0.so
-lib/libopenobex-1.0.so.1
+lib/libopenobex.so.4
lib/libopenobex.a
lib/libopenobex.la
lib/libopenobex.so
+libdata/pkgconfig/openobex.pc
share/aclocal/openobex.m4
@dirrm include/openobex