aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/py-GeoIP/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net/py-GeoIP/Makefile b/net/py-GeoIP/Makefile
index 16339b6fb943..d1f31725771f 100644
--- a/net/py-GeoIP/Makefile
+++ b/net/py-GeoIP/Makefile
@@ -3,6 +3,7 @@
PORTNAME= GeoIP
PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= net python geography
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,11 +15,12 @@ LICENSE= GPLv2
LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
+OPTIONS_DEFINE= EXAMPLES
+
CPPFLAGS+= -I${LOCALBASE}/include
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
USES= python shebangfix
-EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
PORTEXAMPLES= *
SHEBANG_FILES= examples/*.py
@@ -28,6 +30,8 @@ post-patch:
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/GeoIP.so
+
+post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
cd ${WRKSRC}/examples/ && ${INSTALL_DATA} *.py ${STAGEDIR}${EXAMPLESDIR}/