aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/pg_activity/Makefile2
-rw-r--r--irc/insub/Makefile2
-rw-r--r--misc/py-pyfiglet/Makefile2
-rw-r--r--security/nyx/Makefile2
-rw-r--r--security/py-safe/Makefile2
-rw-r--r--security/py-stem/Makefile2
-rw-r--r--sysutils/moosefs2-master/Makefile6
-rw-r--r--sysutils/moosefs3-master/Makefile6
-rw-r--r--sysutils/py-uptime/Makefile2
9 files changed, 13 insertions, 13 deletions
diff --git a/databases/pg_activity/Makefile b/databases/pg_activity/Makefile
index 7c1aa6b8f437..7cbc1df96b0e 100644
--- a/databases/pg_activity/Makefile
+++ b/databases/pg_activity/Makefile
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= DOCS
USE_GITHUB= yes
GH_ACCOUNT= julmon
-USES= python:2.6+
+USES= python
USE_PYTHON= autoplist distutils noegginfo concurrent optsuffix
PYDISTUTILS_INSTALLARGS= --with-man
diff --git a/irc/insub/Makefile b/irc/insub/Makefile
index 30047a72960b..7b4b1f203c52 100644
--- a/irc/insub/Makefile
+++ b/irc/insub/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= cowsay:games/cowsay \
USE_GITHUB= yes
GH_ACCOUNT= cjones
-USES= perl5 python:2.5+ shebangfix
+USES= perl5 python shebangfix
SHEBANG_FILES= insub.py
USE_PERL5= run
NO_BUILD= yes
diff --git a/misc/py-pyfiglet/Makefile b/misc/py-pyfiglet/Makefile
index 482b1bd66186..1f77f31ed2cd 100644
--- a/misc/py-pyfiglet/Makefile
+++ b/misc/py-pyfiglet/Makefile
@@ -13,7 +13,7 @@ COMMENT= Pure-python FIGlet implementation
LICENSE= GPLv2+
# Actually 2.6-2.7,3.1-3.5 (no 3.0)
-USES= python:2.6-3.5
+USES= python:2.7-3.5
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/security/nyx/Makefile b/security/nyx/Makefile
index f228ff6de188..0754da3fec1d 100644
--- a/security/nyx/Makefile
+++ b/security/nyx/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stem>=1.6.0:security/py-stem@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${FLAVOR}
-USES= python:2.6+
+USES= python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/security/py-safe/Makefile b/security/py-safe/Makefile
index b2ca9f74e6f7..1e949b4f218b 100644
--- a/security/py-safe/Makefile
+++ b/security/py-safe/Makefile
@@ -14,7 +14,7 @@ COMMENT= Python library to test password strength
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:2.6+
+USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/security/py-stem/Makefile b/security/py-stem/Makefile
index dc3b8d10d00d..d21cda9321bf 100644
--- a/security/py-stem/Makefile
+++ b/security/py-stem/Makefile
@@ -18,7 +18,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyflakes>0:devel/py-pyflakes@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pycodestyle>0:devel/py-pycodestyle@${FLAVOR}
-USES= python:2.6+
+USES= python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/sysutils/moosefs2-master/Makefile b/sysutils/moosefs2-master/Makefile
index 8ecba783c485..9ca90f5ecb3a 100644
--- a/sysutils/moosefs2-master/Makefile
+++ b/sysutils/moosefs2-master/Makefile
@@ -33,7 +33,7 @@ CONFIGURE_ARGS+= --localstatedir=${MFS_WORKDIR} \
.if ${MFS_COMPONENT} == cgi
MFS_CGIDIR= ${PREFIX}/share/mfscgi
-USES= python:2.5+
+USES= python
CONFIGURE_ARGS+= --enable-mfscgi \
--with-mfscgi-dir=${MFS_CGIDIR}
.else
@@ -42,7 +42,7 @@ CONFIGURE_ARGS+= --disable-mfscgi
.if ${MFS_COMPONENT} == cgiserv
MFS_CGISERVDIR= ${PREFIX}/sbin
-USES= python:2.5+
+USES= python
USE_RC_SUBR= mfscgiserv
SUB_FILES+= pkg-message-cgiserv
PKGMESSAGE= ${WRKDIR}/pkg-message-cgiserv
@@ -65,7 +65,7 @@ CONFIGURE_ARGS+= --disable-mfschunkserver
.endif
.if ${MFS_COMPONENT} == cli
-USES= python:2.5+
+USES= python
CONFIGURE_ARGS+= --enable-mfscli
.else
CONFIGURE_ARGS+= --disable-mfscli
diff --git a/sysutils/moosefs3-master/Makefile b/sysutils/moosefs3-master/Makefile
index eb5b9a1a827d..79dd87f1c79b 100644
--- a/sysutils/moosefs3-master/Makefile
+++ b/sysutils/moosefs3-master/Makefile
@@ -35,7 +35,7 @@ CONFLICTS= moosefs2-${MFS_COMPONENT}-*
.if ${MFS_COMPONENT} == cgi
MFS_CGIDIR= ${PREFIX}/share/mfscgi
-USES= python:2.5+
+USES= python
CONFIGURE_ARGS+= --enable-mfscgi \
--with-mfscgi-dir=${MFS_CGIDIR}
.else
@@ -44,7 +44,7 @@ CONFIGURE_ARGS+= --disable-mfscgi
.if ${MFS_COMPONENT} == cgiserv
MFS_CGISERVDIR= ${PREFIX}/sbin
-USES= python:2.5+
+USES= python
USE_RC_SUBR= mfscgiserv
SUB_FILES+= pkg-message-cgiserv
PKGMESSAGE= ${WRKDIR}/pkg-message-cgiserv
@@ -67,7 +67,7 @@ CONFIGURE_ARGS+= --disable-mfschunkserver
.endif
.if ${MFS_COMPONENT} == cli
-USES= python:2.5+
+USES= python
CONFIGURE_ARGS+= --enable-mfscli
.else
CONFIGURE_ARGS+= --disable-mfscli
diff --git a/sysutils/py-uptime/Makefile b/sysutils/py-uptime/Makefile
index 026debcba75b..a7de5cdcaf76 100644
--- a/sysutils/py-uptime/Makefile
+++ b/sysutils/py-uptime/Makefile
@@ -12,7 +12,7 @@ COMMENT= Cross-platform uptime library
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING.txt
-USES= python:2.5+
+USES= python
USE_PYTHON= autoplist distutils
post-install: