aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/libsidplay2/Makefile8
-rw-r--r--devel/libassa/Makefile8
-rw-r--r--devel/libformat/Makefile8
-rw-r--r--graphics/nurbs++/Makefile8
-rw-r--r--mail/librfc822/Makefile8
-rw-r--r--mail/milter-sender/Makefile4
-rw-r--r--mail/mmr/Makefile8
-rw-r--r--math/newmat/Makefile8
-rw-r--r--math/rascal/Makefile4
-rw-r--r--net-p2p/mutella/Makefile8
-rw-r--r--net/mutella/Makefile8
-rw-r--r--textproc/nicetext/Makefile8
-rw-r--r--www/mgstat/Makefile8
13 files changed, 85 insertions, 11 deletions
diff --git a/audio/libsidplay2/Makefile b/audio/libsidplay2/Makefile
index 90f26a25ebc0..a2eb0312ff9f 100644
--- a/audio/libsidplay2/Makefile
+++ b/audio/libsidplay2/Makefile
@@ -26,8 +26,14 @@ LIBTOOLFILES= builders/hardsid-builder/configure \
resid/configure
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|g' \
${WRKSRC}/libsidutils/src/ini/ini.cpp
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libassa/Makefile b/devel/libassa/Makefile
index f709136d50a9..5d025a37e5d6 100644
--- a/devel/libassa/Makefile
+++ b/devel/libassa/Makefile
@@ -19,4 +19,10 @@ USE_GNOME= gnomehack
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libformat/Makefile b/devel/libformat/Makefile
index 7619fca4c69f..c6d62db989ea 100644
--- a/devel/libformat/Makefile
+++ b/devel/libformat/Makefile
@@ -18,6 +18,12 @@ COMMENT= C++ library that supports printf style like format printing
MAKEFILE= ${FILESDIR}/Makefile.lib
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -26,4 +32,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/nurbs++/Makefile b/graphics/nurbs++/Makefile
index c90845b4aecc..e76e614b6da3 100644
--- a/graphics/nurbs++/Makefile
+++ b/graphics/nurbs++/Makefile
@@ -22,8 +22,14 @@ INSTALLS_SHLIB= yes
MAN1= nurbs++-config.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/nurbs/nurbs.cpp ${WRKSRC}/nurbs/nurbsS.cpp
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/librfc822/Makefile b/mail/librfc822/Makefile
index 56e856f74877..bbdda1fdd308 100644
--- a/mail/librfc822/Makefile
+++ b/mail/librfc822/Makefile
@@ -17,6 +17,12 @@ COMMENT= A complete parser for RFC822 addresses
DOCS= readme.html readme.txt user-manual.html user-manual.pdf
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
do-install:
${INSTALL_DATA} ${WRKSRC}/rfc822.hh ${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/librfc822.a ${PREFIX}/lib
@@ -25,4 +31,4 @@ do-install:
@cd ${WRKSRC}/documentation && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/milter-sender/Makefile b/mail/milter-sender/Makefile
index 47576c78138f..91cbb8e31e23 100644
--- a/mail/milter-sender/Makefile
+++ b/mail/milter-sender/Makefile
@@ -24,6 +24,10 @@ MAKEFILE= makefile
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
.if ( ${OSVERSION} < 440000 )
BUILD_DEPENDS= gxargs:${PORTSBASE}/misc/findutils
.endif
diff --git a/mail/mmr/Makefile b/mail/mmr/Makefile
index c0c7518dfa9f..1c7617b10165 100644
--- a/mail/mmr/Makefile
+++ b/mail/mmr/Makefile
@@ -15,6 +15,12 @@ COMMENT= Curses based MIME Mail Reader
ALL_TARGET= # empty
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mmr ${PREFIX}/bin
@${MKDIR} ${PREFIX}/share/examples/mmr
@@ -26,4 +32,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/newmat/Makefile b/math/newmat/Makefile
index df706c9c3754..483bf55e7f3d 100644
--- a/math/newmat/Makefile
+++ b/math/newmat/Makefile
@@ -22,6 +22,12 @@ USE_GMAKE= yes
MAKEFILE= nm_gnu.mak
ALL_TARGET= everything
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,^CXX,#CXX,g ; \
s,^CXXFLAGS,#CXXFLAGS,g" ${WRKSRC}/${MAKEFILE}
@@ -31,4 +37,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/libnewmat.a ${PREFIX}/lib
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/rascal/Makefile b/math/rascal/Makefile
index c863041ce94d..a49c540660f3 100644
--- a/math/rascal/Makefile
+++ b/math/rascal/Makefile
@@ -31,6 +31,10 @@ MAN1= rascal.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
.if ${OSVERSION} < 502000
BUILD_DEPENDS= ${LOCALBASE}/lib/libreadline.so.4:${PORTSDIR}/devel/readline
RUN_DEPENDS= ${LOCALBASE}/lib/libreadline.so.4:${PORTSDIR}/devel/readline
diff --git a/net-p2p/mutella/Makefile b/net-p2p/mutella/Makefile
index 39d843b4f081..561f51084bd4 100644
--- a/net-p2p/mutella/Makefile
+++ b/net-p2p/mutella/Makefile
@@ -22,4 +22,10 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/mutella/Makefile b/net/mutella/Makefile
index 39d843b4f081..561f51084bd4 100644
--- a/net/mutella/Makefile
+++ b/net/mutella/Makefile
@@ -22,4 +22,10 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/nicetext/Makefile b/textproc/nicetext/Makefile
index a9b8299a35a3..0fee8c888ca1 100644
--- a/textproc/nicetext/Makefile
+++ b/textproc/nicetext/Makefile
@@ -25,6 +25,12 @@ PROGRAMS= bitcp dct2mstr expgram genmodel gramtest impkimmo impmsc \
impwbstr listword nicetext nttpd printint rinfo scramble \
sortdct txt2dct
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
's|gcc|$${CC}|g ; \
@@ -53,4 +59,4 @@ post-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREMODE} ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mgstat/Makefile b/www/mgstat/Makefile
index 77626937f546..6fea3efd7233 100644
--- a/www/mgstat/Makefile
+++ b/www/mgstat/Makefile
@@ -20,6 +20,12 @@ GNU_CONFIGURE= yes
MGDOCDIR= ${PREFIX}/share/doc/mgstat
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@if ! [ -d ${MGDOCDIR} ]; then ${MKDIR} ${MGDOCDIR}; fi
@@ -28,4 +34,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/USAGE ${MGDOCDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>