aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Set-Window/Makefile23
-rw-r--r--math/p5-Set-Window/distinfo1
-rw-r--r--math/p5-Set-Window/pkg-comment1
-rw-r--r--math/p5-Set-Window/pkg-descr9
-rw-r--r--math/p5-Set-Window/pkg-plist5
6 files changed, 40 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index bd9c24cdc52b..9db78dd162be 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -58,6 +58,7 @@
SUBDIR += p5-Math-Logic
SUBDIR += p5-MatrixReal
SUBDIR += p5-Set-IntSpan
+ SUBDIR += p5-Set-Window
SUBDIR += p5-Statistics-ChiSquare
SUBDIR += p5-Statistics-Descriptive
SUBDIR += p5-Statistics-Distributions
diff --git a/math/p5-Set-Window/Makefile b/math/p5-Set-Window/Makefile
new file mode 100644
index 000000000000..c60d9b0704e5
--- /dev/null
+++ b/math/p5-Set-Window/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: math/p5-Set-Window
+# Date created: 03 January 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Set-Window
+PORTVERSION= 1.00
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Set
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Set::Window.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/math/p5-Set-Window/distinfo b/math/p5-Set-Window/distinfo
new file mode 100644
index 000000000000..2dc53c709a58
--- /dev/null
+++ b/math/p5-Set-Window/distinfo
@@ -0,0 +1 @@
+MD5 (Set-Window-1.00.tar.gz) = f42b0eba45cb50b687c3be58945b896c
diff --git a/math/p5-Set-Window/pkg-comment b/math/p5-Set-Window/pkg-comment
new file mode 100644
index 000000000000..8c781dd21285
--- /dev/null
+++ b/math/p5-Set-Window/pkg-comment
@@ -0,0 +1 @@
+Perl module to manage an interval on the integer line
diff --git a/math/p5-Set-Window/pkg-descr b/math/p5-Set-Window/pkg-descr
new file mode 100644
index 000000000000..4fa298856c5d
--- /dev/null
+++ b/math/p5-Set-Window/pkg-descr
@@ -0,0 +1,9 @@
+A Set::Window object represents a window on the integer line; that is, a
+finite set of consecutive integers.
+
+Methods are provided for creating and modifying windows, for obtaining
+information about windows, and for performing some simple set operations
+on windows.
+
+-Anton
+<tobez@tobez.org>
diff --git a/math/p5-Set-Window/pkg-plist b/math/p5-Set-Window/pkg-plist
new file mode 100644
index 000000000000..24965f303e95
--- /dev/null
+++ b/math/p5-Set-Window/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Set/Window/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Set/Window.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Set/Window
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Set 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Set 2>/dev/null || true